<!DOCTYPE html>
<html lang="en-US">
<head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
    <meta name="viewport" content="user-scalable=yes, initial-scale=1.0, width=device-width"/>

    <link rel="preconnect" href="https://static1.makeuseofimages.com">

                            <link rel="preconnect" href="https://www.google-analytics.com">
            
        
    <link rel="preload"
                      media="(max-width: 480px)"
                      href="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/engineers-setting-up-nginx-server.jpg?q=50&fit=contain&w=480&h=300&dpr=1.5" importance="high"  as="image"><link rel="preload"
                      media="(min-width: 481px) and (max-width: 767px)"
                      href="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/engineers-setting-up-nginx-server.jpg?q=50&fit=contain&w=767&h=450&dpr=1.5" importance="high"  as="image"><link rel="preload"
                      media="(min-width: 768px) and (max-width: 1023px)"
                      href="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/engineers-setting-up-nginx-server.jpg?q=50&fit=contain&w=943&h=500&dpr=1.5" importance="high"  as="image"><link rel="preload"
                      media="(min-width: 1024px)"
                      href="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/engineers-setting-up-nginx-server.jpg?q=50&fit=contain&w=750&h=375&dpr=1.5" importance="high"  as="image">
    
    <script>
        // GLOBAL JS VARIABLES FOR THE PAGE
        var VALNET_GLOBAL_FBAPPID = "172826243054377";
        // GLOBAL JS VARIABLES FOR GOOGLE ANALYTICS
                    var VALNET_GLOBAL_GOOGLEANALYTICSPROPERTYID = "UA-35624077-21";
            var VALNET_GLOBAL_POSTID = "2005087";
            var VALNET_GLOBAL_AUTHOR = "mwiza-kumwenda";
            var VALNET_GLOBAL_CHANNEL = "linux";
            var VALNET_GLOBAL_VIEW = "regular";
            var VALNET_GLOBAL_EXACTVIEW = "all";
            var VALNET_GLOBAL_ISPREMIUM = "false";
            var VALNET_GLOBAL_ENVIRONMENT = "native";
            var VALNET_GLOBAL_POSTTYPE = "article";
            var VALNET_GLOBAL_JREDITOR = "deepesh-sharma";
            var VALNET_GLOBAL_SREDITOR = "ccawley";
            var VALNET_GLOBAL_NUMBERPERPAGE = "all";
            var VALNET_GLOBAL_ISENGAGEMENTTEST = "false";
            var VALNET_GLOBAL_DETECTEDDEVICE = "desktop";
            var VALNET_GLOBAL_IPADDRESS = "107.23.218.4";
            var VALNET_GLOBAL_BROWSERUSERAGENT = "CCBot\/3.0\u0020\u0028https\u003A\/\/commoncrawl.org\/faq\/\u003B\u0020info\u0040commoncrawl.org\u0029";
            var VALNET_GLOBAL_LENGTH = "20-24";
            var VALNET_GLOBAL_DATEPUBLISHED = "20211130";
            var VALNET_GLOBAL_EDITOR = "";
            var VALNET_GLOBAL_POSTPAYMENTCATEGORY = "feature";
            var VALNET_GLOBAL_CATEGORY = "linux";
            var VALNET_GLOBAL_TAGS = "|ubuntu|web-server|install-software|";
            var VALNET_GLOBAL_ISFACEBOOKBROWSER = "F";
            var VALNET_GLOBAL_ADS = "BOT";
            var VALNET_GLOBAL_AMPTRAFFIC = "false";
            var VALNET_GLOBAL_TEMPLATE = "content-all";
            var VALNET_GLOBAL_TLDRPERMALINK = "/how-to-install-nginx-on-ubuntu/";
            var VALNET_GLOBAL_TLDRPAGE = "1";
            var VALNET_GLOBAL_TLDRTOTALNUMPAGE = "0";
            var VALNET_GLOBAL_TLDRVIEWTYPE = "";
            var VALNET_GLOBAL_ISADBLOCK = true;
            var VALNET_GLOBAL_NETWORKCATEGORY = "skills";
            var VALNET_GLOBAL_CONTENTTYPE = "Feature";
            var VALNET_GLOBAL_INTENT = "Evergreen";
            </script>

    <script> window.arrayOfEmbeds = [] </script>
    
            
    
                    
                <link rel="stylesheet" href="/public/build/a-article.cfe78bbe.css">
        
    <!-- Google Analytics -->
<script>
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
</script>
<!-- End Google Analytics -->
        <!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
            new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
        j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
        'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
    })(window,document,'script','dataLayer','GTM-TBXVR8R');</script>
<!-- End Google Tag Manager -->
    <meta name="robots" content="max-image-preview:large">
    <script type="text/javascript">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</script>
    <script type="text/javascript">
        /*!
            Waypoints Inview Shortcut - 4.0.1
            Copyright © 2011-2016 Caleb Troughton
            Licensed under the MIT license.
            https://github.com/imakewebthings/waypoints/blob/master/licenses.txt
        */
        !function(){"use strict";function t(){}function e(t){this.options=i.Adapter.extend({},e.defaults,t),this.axis=this.options.horizontal?"horizontal":"vertical",this.waypoints=[],this.element=this.options.element,this.createWaypoints()}var i=window.Waypoint;e.prototype.createWaypoints=function(){for(var t={vertical:[{down:"enter",up:"exited",offset:"100%"},{down:"entered",up:"exit",offset:"bottom-in-view"},{down:"exit",up:"entered",offset:0},{down:"exited",up:"enter",offset:function(){return-this.adapter.outerHeight()}}],horizontal:[{right:"enter",left:"exited",offset:"100%"},{right:"entered",left:"exit",offset:"right-in-view"},{right:"exit",left:"entered",offset:0},{right:"exited",left:"enter",offset:function(){return-this.adapter.outerWidth()}}]},e=0,i=t[this.axis].length;i>e;e++){var n=t[this.axis][e];this.createWaypoint(n)}},e.prototype.createWaypoint=function(t){var e=this;this.waypoints.push(new i({context:this.options.context,element:this.options.element,enabled:this.options.enabled,handler:function(t){return function(i){e.options[t[i]].call(e,i)}}(t),offset:t.offset,horizontal:this.options.horizontal}))},e.prototype.destroy=function(){for(var t=0,e=this.waypoints.length;e>t;t++)this.waypoints[t].destroy();this.waypoints=[]},e.prototype.disable=function(){for(var t=0,e=this.waypoints.length;e>t;t++)this.waypoints[t].disable()},e.prototype.enable=function(){for(var t=0,e=this.waypoints.length;e>t;t++)this.waypoints[t].enable()},e.defaults={context:window,enabled:!0,enter:t,entered:t,exit:t,exited:t},i.Inview=e}();
    </script>

    <script async src="/public/build/dfp.js"></script>
            <script async src="/public/build/valnet-header.55c5a5df.js"></script>
    
    

    
    
    
                
    

    	
	    	    	        <link rel="amphtml" href="https://www.makeuseof.com/how-to-install-nginx-on-ubuntu/amp/" />
	    
	    	        <link rel="canonical" href="https://www.makeuseof.com/how-to-install-nginx-on-ubuntu/" />
	    
	    	    	        
	        	    
	    <title>How to Install and Configure Nginx on Ubuntu</title>
	    
	    	        	        <meta name="description" content="Develop and deploy robust web applications by installing the Nginx server on Ubuntu." />
	    	    
	    	
        
        
            <meta property="og:title" content="How to Install and Configure Nginx on Ubuntu"/>
    <meta property="og:type" content="article"/>

            <meta property="og:image" content="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/engineers-setting-up-nginx-server.jpg"/>
                    <meta property="og:image:width" content="1680"/>
            <meta property="og:image:height" content="840"/>
                    

                                                <meta property="og:url" content="https://www.makeuseof.com/how-to-install-nginx-on-ubuntu/"/>
                        
    <meta property="og:locale" content="en_US"/>
    <meta property="og:description" content="Develop and deploy robust web applications by installing the Nginx server on Ubuntu."/>

            <meta property="og:site_name" content="MUO"/>
    
                        <meta property="article:published_time" content="2021-11-30T18:00:12Z"/>
                            <meta property="article:modified_time" content="2021-11-30T18:00:12Z"/>
                                        <meta property="article:section" content="Linux"/>
            

    
            <meta name="twitter:card" content="summary_large_image">
                <meta name="twitter:site" content="@MUO_official">
        <meta name="twitter:title" content="How to Install and Configure Nginx on Ubuntu">
        <meta name="twitter:description" content="Develop and deploy robust web applications by installing the Nginx server on Ubuntu.">
                    <meta name="twitter:image" content="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/engineers-setting-up-nginx-server.jpg">
            
        <meta property="fb:app_id" content="172826243054377"/>

		

    <link rel="icon" sizes="48x48" href="/public/build/images/favicon-48x48.fb40876e.png">
    <link rel="icon" sizes="96x96" href="/public/build/images/favicon-96x96.88eebd60.png">
    <link rel="icon" sizes="144x144" href="/public/build/images/favicon-144x144.cc361b2e.png">
    <link rel="icon" sizes="192x192" href="/public/build/images/favicon-192x192.89cc1648.png">
    <link rel="icon" sizes="240x240" href="/public/build/images/favicon-240x240.df310da5.png">

    <link rel="apple-touch-icon" sizes="240x240" href="/public/build/images/favicon-240x240.df310da5.png">
    <link rel="shortcut icon" href="/public/build/images/favicon-192x192.89cc1648.png">

                <script type="text/javascript">
            (function(window, document, account) {
                window.skimlinks_exclude = ["shop-links.co", "shop-edits.co"];
                window.NRTV_EVENT_DATA = { donotlink: true };
                var b = document.createElement("script");
                b.type = "text/javascript";
                b.src = "https://static.narrativ.com/tags/" + account + ".js";
                b.async = true;
                var a = document.getElementsByTagName("script")[0];
                a.parentNode.insertBefore(b,a);
            })(window, document, "muo");
        </script>
    
        
                                <!-- Using AdsNinja V10 -->
                <!-- Ad Header Start -->
                <!-- No AdsNinja v10 Client! -->
                <!-- Ad Header End -->
                
    <!-- GLOABL JS VARIABLES -->
    <script>


    var valnet_site_viewType = "direct";
    var valnet_site_view = "all";
    var valnet_site_campaign = "";
    var valnet_site_device = "desktop";
    var valnet_hideAds = true;
    </script>

</head>

<body class="js-tldr  ">
    <!-- No AdsNinja v10 Client! -->
    <div id="body-anchor"></div>
        <!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-TBXVR8R"
                  height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->

    
    
    
    <div class="w-website">

        <div id="pageStickyFooterAd">
            <div class="close-sticky-footer icon i-close"></div>
            <!-- No AdsNinja v10 Client! -->
        </div>

                            <div id="js-header" class="w-header">

    <header class="header" itemscope itemtype="https://schema.org/WPHeader">

        <h1 class="hide" itemprop="headline">www.makeuseof.com</h1>

        <div class="header-logo">
            <a href="/" title="" rel="home"></a>
        </div>

        <input class="header-menu-btn-input" type="checkbox" id="headerMenu"/>
        <label class="header-menu-btn-label js-nav" for="headerMenu">
            <div class="menu-burger-btn">
                <span class="burger-btn-line"></span>
                <span class="burger-btn-line"></span>
                <span class="burger-btn-line"></span>
            </div>
        </label>

        <div class="w-header-menu">
            <button class="menu-exit-btn icon i-close"></button>
            <div class="header-menu">
                

<nav class="menu-nav" id="menu-site">
    <ul class="menu-nav-list" itemscope itemtype="http://www.schema.org/SiteNavigationElement">
         
                        <li itemprop="name" class="w-drop-down">
                                                            <button class="menu-nav-more-btn js-menu-open">PC &amp; Mobile</button>
                                    
                <ul class="drop-down">
                     
                        <li itemprop="name">
                <a href="/category/windows/" itemprop="url">Windows</a>
            </li>
                                <li itemprop="name">
                <a href="/category/mac/" itemprop="url">Mac</a>
            </li>
                                <li itemprop="name">
                <a href="/category/linux/" itemprop="url">Linux</a>
            </li>
                                <li itemprop="name">
                <a href="/category/google-android/" itemprop="url">Android</a>
            </li>
                                <li itemprop="name">
                <a href="/category/ios/" itemprop="url">iPhone &amp; iPad</a>
            </li>
                                <li itemprop="name">
                <a href="/category/web-based/" itemprop="url">Internet</a>
            </li>
                                <li itemprop="name">
                <a href="/category/security/" itemprop="url">Security</a>
            </li>
                                <li itemprop="name">
                <a href="/category/programming/" itemprop="url">Programming</a>
            </li>
            

                </ul>
            </li>
                                <li itemprop="name" class="w-drop-down">
                                                            <button class="menu-nav-more-btn js-menu-open">Lifestyle</button>
                                    
                <ul class="drop-down">
                     
                        <li itemprop="name">
                <a href="/category/entertainment/" itemprop="url">Entertainment</a>
            </li>
                                <li itemprop="name">
                <a href="/category/productivity/" itemprop="url">Productivity</a>
            </li>
                                <li itemprop="name">
                <a href="/category/creative/" itemprop="url">Creative</a>
            </li>
                                <li itemprop="name">
                <a href="/category/games/" itemprop="url">Gaming</a>
            </li>
                                <li itemprop="name">
                <a href="/category/social-media/" itemprop="url">Social Media</a>
            </li>
            

                </ul>
            </li>
                                <li itemprop="name" class="w-drop-down">
                                                            <button class="menu-nav-more-btn js-menu-open">Hardware</button>
                                    
                <ul class="drop-down">
                     
                        <li itemprop="name">
                <a href="/category/technology-explained/" itemprop="url">Technology Explained</a>
            </li>
                                <li itemprop="name">
                <a href="/category/buying-guides/" itemprop="url">Buyer&#039;s Guides</a>
            </li>
                                <li itemprop="name">
                <a href="/category/smart-home/" itemprop="url">Smart Home</a>
            </li>
                                <li itemprop="name">
                <a href="/category/diy-projects/" itemprop="url">DIY</a>
            </li>
                                <li itemprop="name">
                <a href="/category/product-reviews/" itemprop="url">Product Reviews</a>
            </li>
            

                </ul>
            </li>
                                <li itemprop="name" class="w-drop-down">
                                                            <button class="menu-nav-more-btn js-menu-open highlight">Free Stuff</button>
                                    
                <ul class="drop-down">
                     
                        <li itemprop="name">
                <a href="/tag/longform-guide/" itemprop="url">Free eBooks</a>
            </li>
                                <li itemprop="name">
                <a href="/giveaways/" itemprop="url">Giveaways</a>
            </li>
                                <li itemprop="name">
                <a href="/tag/best-of/" itemprop="url">Top Lists</a>
            </li>
                                <li itemprop="name">
                <a href="/tag/cheat-sheet/" itemprop="url">Free Cheat Sheets</a>
            </li>
            

                </ul>
            </li>
                                <li itemprop="name">
                <a href="/category/best-deals/" itemprop="url">Deals</a>
            </li>
                                <li itemprop="name">
                <a href="/tag/awards/" itemprop="url">Awards</a>
            </li>
                                <li itemprop="name" class="w-drop-down">
                                                            <button class="menu-nav-more-btn js-menu-open">About</button>
                                    
                <ul class="drop-down">
                     
                        <li itemprop="name">
                <a href="/about/" itemprop="url">About MUO</a>
            </li>
                                <li itemprop="name">
                <a href="/advertise/" itemprop="url">Advertise</a>
            </li>
                                <li itemprop="name">
                <a href="/contact/" itemprop="url">Contact</a>
            </li>
                                <li itemprop="name">
                <a href="/privacy-policy/" itemprop="url">Privacy</a>
            </li>
                                <li itemprop="name">
                <a href="https://deals.makeuseof.com/?utm_source=makeuseof&amp;utm_medium=homepage&amp;utm_campaign=shoptab" itemprop="url">Shop</a>
            </li>
                                <li itemprop="name">
                <a href="/contributor/" itemprop="url">Write For Us</a>
            </li>
                                <li itemprop="name">
                <a href="/subscribe/" itemprop="url">Newsletter</a>
            </li>
                                <li itemprop="name">
                <a href="/tag/rup/" itemprop="url">Podcasts</a>
            </li>
            

                </ul>
            </li>
            

    </ul>
</nav>                                
                                    
    <div class="w-menu-follow">
        <span class="menu-follow-button icon i-social">Follow Us</span>
        <div class="menu-follow drop-down">
                        <div class="menu-follow-social">
                <h4 class="menu-nav-title">Follow MUO</h4>
            	<ul>
                                            <li><a class="icon i-youtube" href="https://www.youtube.com/muotv" target="_blank"></a></li>
                                            <li><a class="icon i-facebook" href="https://www.facebook.com/muo.official" target="_blank"></a></li>
                                            <li><a class="icon i-instagram" href="https://www.instagram.com/muoofficial/" target="_blank"></a></li>
                                            <li><a class="icon i-twitter" href="https://twitter.com/MUO_official" target="_blank"></a></li>
                                            <li><a class="icon i-pinterest" href="https://www.pinterest.ca/muo_official/" target="_blank"></a></li>
                                            <li><a class="icon i-feed" href="https://www.makeuseof.com/feed/" target="_blank"></a></li>
                                            <li><a class="icon i-newspaper" href="https://www.makeuseof.com/subscribe/" target="_blank"></a></li>
                    

    	        </ul>
            </div>
            
            

        </div>
    </div>
                
            </div>

        </div>

        
        <button id="js-theme" class="header-theme-btn">
            
<!-- Generator: Adobe Illustrator 25.0.1, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->
<svg version="1.1" class="svg-icon-sun" id="Layer_2" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
	 viewBox="0 0 425.2 425.2" style="enable-background:new 0 0 425.2 425.2;" xml:space="preserve">
<g>
	<path d="M212,319c-59.1,0-107.2-48.1-107.2-107.2c0-59.1,48.1-107.2,107.2-107.2c59.1,0,107.2,48.1,107.2,107.2
		C319.2,270.9,271.1,319,212,319z M212,134.8c-42.5,0-77,34.5-77,77s34.5,77,77,77s77-34.5,77-77S254.5,134.8,212,134.8z"/>
	<g>
		<path d="M313.4,125.6c-3.9,0-7.7-1.5-10.7-4.4c-5.9-5.9-5.9-15.5,0-21.4l35-35c5.9-5.9,15.5-5.9,21.4,0c5.9,5.9,5.9,15.5,0,21.4
			l-35,35C321.1,124.1,317.2,125.6,313.4,125.6z"/>
		<path d="M404.8,226.9h-49.4c-8.3,0-15.1-6.8-15.1-15.1c0-8.3,6.8-15.1,15.1-15.1h49.4c8.3,0,15.1,6.8,15.1,15.1
			C419.9,220.2,413.1,226.9,404.8,226.9z"/>
		<path d="M348.3,363.3c-3.9,0-7.7-1.5-10.7-4.4l-35-35c-5.9-5.9-5.9-15.5,0-21.4c5.9-5.9,15.5-5.9,21.4,0l35,35
			c5.9,5.9,5.9,15.5,0,21.4C356.1,361.8,352.2,363.3,348.3,363.3z"/>
		<path d="M212,419.7c-8.3,0-15.1-6.8-15.1-15.1v-49.4c0-8.3,6.8-15.1,15.1-15.1c8.3,0,15.1,6.8,15.1,15.1v49.4
			C227.1,413,220.4,419.7,212,419.7z"/>
		<path d="M75.7,363.3c-3.9,0-7.7-1.5-10.7-4.4c-5.9-5.9-5.9-15.5,0-21.4l35-35c5.9-5.9,15.5-5.9,21.4,0c5.9,5.9,5.9,15.5,0,21.4
			l-35,35C83.4,361.8,79.6,363.3,75.7,363.3z"/>
		<path d="M68.7,226.9H19.2c-8.3,0-15.1-6.8-15.1-15.1c0-8.3,6.8-15.1,15.1-15.1h49.4c8.3,0,15.1,6.8,15.1,15.1
			C83.8,220.2,77,226.9,68.7,226.9z"/>
		<path d="M110.6,125.6c-3.9,0-7.7-1.5-10.7-4.4l-35-35c-5.9-5.9-5.9-15.5,0-21.4c5.9-5.9,15.5-5.9,21.4,0l35,35
			c5.9,5.9,5.9,15.5,0,21.4C118.4,124.1,114.5,125.6,110.6,125.6z"/>
		<path d="M212,83.6c-8.3,0-15.1-6.8-15.1-15.1V19c0-8.3,6.8-15.1,15.1-15.1c8.3,0,15.1,6.8,15.1,15.1v49.4
			C227.1,76.8,220.4,83.6,212,83.6z"/>
	</g>
</g>
</svg>
            
<!-- Generator: Adobe Illustrator 25.0.1, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->
<svg version="1.1" id="Layer_1" class="svg-icon-moon" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
	 viewBox="0 0 500 500" style="enable-background:new 0 0 500 500;" xml:space="preserve">
<path id="XMLID_814_" d="M412.1,384.9c-136.2,0-246.6-110.4-246.6-246.6c0-47.9,13.7-92.6,37.4-130.5
	C98.6,36.7,22.1,132.1,22.1,245.5c0,136.2,110.4,246.6,246.6,246.6c88.3,0,165.7-46.4,209.2-116.1
	C456.9,381.8,434.9,384.9,412.1,384.9z"/>
</svg>
        </button>

        <button id="js-search" class="header-search-btn icon i-search js-search-target"></button>
    </header>
</div>

<div class="w-header-search js-search-target">
    <button id="js-exit-search" class="header-search-exit icon i-close"></button>
    <div class="header-search">
        <form method="post" class="search-form js-searchBox icon i-search" id="searchform2" action="/search/">
            <input id="js-search-input" type="text" name="keyword" class="input-text search-input" autocomplete="off" id="s2" placeholder="Search MUO" autofocus>
        </form>
    </div>
</div>

<!-- No AdsNinja v10 Client! -->

<!-- No AdsNinja v10 Client! -->


        

        <div class="w-content ">
                <article class="w-article   article">
            


                                                                                                                                                                                           
            
            
                                    
            
            
            


    
                                                                        
        
                        
                                        
            
                                    
            
            
            


    
                                                                        
        
                        
                                        
            
                                    
            
            
            


    
                                                    
        
                        
                                        
                                                            
                                
                            
                                    
            
            
                                                                                    
                                
                                
                                                



            


    
                                                    
                                        
                        
                                        
            
                                                                                                                                                                                                                                    
            
                                                                                                
                                                                
                                                                                                                                    
                                
                                                



            


    
                                                    
        
                        
                                                                        
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                    
            
            
                                                                                                                                
            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                                                                                                                                                
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                                            
                                        
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                    
            
            
                                                                                                                                                                                                                                                
            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                    
            
            
            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                    
            
            
            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                                                                                                                                                
            
            
            


    
                                                    
        
                                            
                                        
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                    
            
            
            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                    
            
            
            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                    
            
            
            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                                                                                                                                                
            
            
            


    
                                                    
        
                                            
                                        
            
                                                                                                                                                                                                                                    
            
            
            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                    
            
            
            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                    
            
            
            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                    
            
            
                                                                                                                                                                                                                                                
            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                    
            
            
            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                        
            
            
                                                        


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                                                                                                                                                
            
            
                                                                
                                
                                                                    
                                                



            


    
                                                    
        
                                            
                                                                                    
            
                                                                                                                                                                                                                                    
            
            
            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                    
            
            
            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                        
            
            
                                                        


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                    
            
            
                                                                                                                                                                                                                                                
            


    
                                                    
        
                        
                                        
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                                                    
                                                



            


    
                                                    
        
                        
                                                                                    
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                            
<!-- No AdsNinja v10 Client! --><header class="article_heading"><div class="heading_breadcrumb">


        <script type="application/ld+json">
        {
            "@context": "https://schema.org",
            "@type": "BreadcrumbList",
            "itemListElement": [
            {
                "@type": "ListItem",
                "position": "1",
                  "name": "Home",
                  "item": "https://www.makeuseof.com/"
            },
                        {
                "@type": "ListItem",
                "position":"2",
                "name": "Linux",
                "item": "https://www.makeuseof.com/category/linux/"
            },                        {
                "@type": "ListItem",
                "position":"3",
                "name": "How to Install and Configure Nginx on Ubuntu",
                "item": "https://www.makeuseof.com/how-to-install-nginx-on-ubuntu/"
            }            ]
        }
    </script>

    <nav>
        <ul>
            <li><a href="/">Home</a></li>
                                                            <li><a href="https://www.makeuseof.com/category/linux/">Linux</a></li>
                                                                                                    </ul>
    </nav>

</div>
<h1 class="heading_title">How to Install and Configure Nginx on Ubuntu</h1>

<div class="heading_meta">
            <a class="meta_txt author" href="/author/mwiza-kumwenda/">By Mwiza Kumwenda</a>
    

                                                                                <span class="meta_txt date"><time datetime="2021-11-30T18:00:00Z">Published 1 day ago</time></span>
            
        



    














</div>

<div class="heading_sharing">
            	
<button class="sharing-btn btn-more" onclick="this.parentNode.classList.add('open')">
	<span class="icon i-share"></span>
	<span class="text">Share</span>
</button>


<a class="sharing-btn btn-facebook" target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.makeuseof.com%2Fhow-to-install-nginx-on-ubuntu%2F%2F&amp;src=sdkpreparse">
	<span class="icon i-facebook"></span>
	<span class="text">Share</span>
</a>

<a class="sharing-btn btn-twitter" target="_blank" href="https://twitter.com/intent/tweet?text=How%20to%20Install%20and%20Configure%20Nginx%20on%20Ubuntu&url=https%3A%2F%2Fwww.makeuseof.com%2Fhow-to-install-nginx-on-ubuntu%2F">
	<span class="icon i-twitter"></span>
	<span class="text">Tweet</span>
</a>

<a class="sharing-btn btn-mail" href="mailto:?Subject=How to Install and Configure Nginx on Ubuntu&Body=Check%20this%20out%21%0Ahttps%3A%2F%2Fhttps://www.makeuseof.com/how-to-install-nginx-on-ubuntu/">
	<span class="icon i-mail-1"></span>
	<span class="text">Email</span>
</a>    </div>    
    <p class="heading_excerpt">Develop and deploy robust web applications by installing the Nginx server on Ubuntu.</p>
                                    <div class="heading_image responsive-img img-size-heading-image " style="padding-bottom:50%">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="750px" srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/engineers-setting-up-nginx-server.jpg?q=50&fit=contain&w=750&h=375&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/engineers-setting-up-nginx-server.jpg?q=50&fit=contain&w=943&h=500&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="767px" srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/engineers-setting-up-nginx-server.jpg?q=50&fit=contain&w=767&h=450&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="480px" srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/engineers-setting-up-nginx-server.jpg?q=50&fit=contain&w=480&h=300&dpr=1.5"/>
                        <!--[if IE 9]></video><![endif]-->
                            <img width="1680" height="840"  alt="engineers setting up nginx server"/>
                    </picture>
        <figcaption class="item-img-caption"></figcaption>
    </figure>
</div>
    <!-- No AdsNinja v10 Client! -->
</header><section id="article-body" class="article-body" itemprop="articleBody">            <p>Web applications have gained wide popularity over the past few years as a means of providing services to different clients. With a web application, you can reach out to a wider audience regardless of the device or operating system they are using.</p>
        <!-- No AdsNinja v10 Client! --><!-- No AdsNinja v10 Client! --><!-- No AdsNinja v10 Client! -->            <p>Being able to install and configure a web server is a valuable skill to have both as a web developer and software engineer. A web server is a program responsible for delivering your web content to clients over the internet or a network.</p>
                    <p>Let&#39;s take a look at how to install and configure the Nginx web server on Ubuntu.</p>
        <!-- No AdsNinja v10 Client! --><h2 id="why-use-nginx">
        Why Use Nginx?</h2>            <p>Nginx is a lightweight and high-performance web server that can run on both Windows and Linux. Apart from being a web server, Nginx is also extensively used as a reverse proxy server and mail proxy server. Note that Nginx is pronounced as &quot;engine x.&quot;</p>
                    <p>As a reverse proxy server, you configure Nginx to route traffic from a specified port to some application running on the server. The Nginx reverse proxy provides an extra layer of security as it checks and filters the traffic before hitting the server.</p>
        <!-- No AdsNinja v10 Client! -->            <p>Nginx runs as a service or daemon on a server and can be easily managed by service managers such as systemctl on Linux. Last but not least, Nginx is well documented and enjoys enormous community support.</p>
        <div class=ad-odd><!-- No AdsNinja v10 Client! --></div><h2 id="how-to-install-nginx-server-on-ubuntu">
        How to Install Nginx Server on Ubuntu</h2>            <p>For the purpose of this guide, we&#39;ll demonstrate how you can install the Nginx server on a Linux machine running Ubuntu.</p>
        <h3 id="step-1-installing-security-prerequisites">Step 1: Installing Security Prerequisites</h3>            <p>If you are installing Nginx on a secure server then it is important that you install these prerequisites to ensure that your installation is secure and you are getting stable versions of the programs.</p>
                    <p>First, update your system&#39;s package list.</p>
        <pre><code class="hljs ">sudo apt update</code></pre>
            <p>Install <strong>gnupg2</strong> for a secure communication channel when downloading the application.</p>
        <pre><code class="hljs ">sudo apt install curl gnupg2 ca-certificates lsb-release ubuntu-keyring</code></pre>
<!-- No AdsNinja v10 Client! -->            <p>Next, you should get the official signing key from Nginx to verify the authenticity of the package.</p>
        <pre><code class="hljs ruby">curl https://nginx.org/keys/nginx_signing.key | gpg --dearmor | sudo tee /usr/share/keyrings/nginx-archive-keyring.gpg &gt;/dev/null</code></pre>
            <p>Now, verify that the imported file contains the proper key by running:</p>
        <pre><code class="hljs python">gpg --dry-run --quiet --import --import-options import-show /usr/share/keyrings/nginx-archive-keyring.gpg</code></pre>
            <p>The output should contain the fingerprint as shown below.</p>
        <pre><code class="hljs ">573BFD6B3D8FBC641079A6ABABF5BD827BD9BF62</code></pre>
            <p>Register and set up the Nginx repository on your system to get stable packages, which is important for production and secure environments.</p>
        <pre><code class="hljs ruby">echo &quot;deb [signed-by=/usr/share/keyrings/nginx-archive-keyring.gpg] http://nginx.org/packages/ubuntu `lsb_release -cs` nginx&quot; | sudo tee /etc/apt/sources.list.d/nginx.list</code></pre>
<!-- No AdsNinja v10 Client! --><h3 id="step-2-installing-nginx">Step 2: Installing Nginx</h3>            <p>The next step is to install the Nginx server. Remember to <a href="https://www.makeuseof.com/why-update-linux-package-repositories-before-installing-new-software/">update your package sources</a> before downloading new packages.</p>
        <pre><code class="hljs ">sudo apt update</code></pre>
            <p>Installing the Nginx server is pretty straightforward. Simply run the following command:</p>
        <pre><code class="hljs ">sudo apt install nginx</code></pre>
            <p><span class="related-single">Learn More: <a href="https://www.makeuseof.com/apt-vs-dpkg/">The Difference Between APT and dpkg on Ubuntu</a></span></p>
        <div class=ad-even><!-- No AdsNinja v10 Client! --></div><h2 id="nginx-in-action">
        Nginx in Action</h2>            <p>The default page served by Nginx is stored in the directory <strong>/usr/share/nginx/html</strong>. You can place your static web pages either in this location or another location of your choice and configure a virtual host.</p>
                    <p>A virtual host allows you to serve multiple web pages on the same server hardware or infrastructure.</p>
                    <p>You can check the status of the Nginx server using the following command:</p>
        <pre><code class="hljs ">sudo systemctl status nginx</code></pre>
                                    <div class="body-img responsive-img img-article-item"  style="padding-bottom:29.833333333333%">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="750px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/engine_x_service_status.png?q=50&fit=crop&w=750&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/engine_x_service_status.png?q=50&fit=crop&w=943&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="767px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/engine_x_service_status.png?q=50&fit=crop&w=767&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="480px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/engine_x_service_status.png?q=50&fit=crop&w=480&dpr=1.5"/>
                        <!--[if IE 9]></video><![endif]-->
            <img width="1200" height="358" class="lazyload" alt="nginx service status output"/>
        </picture>
            </figure>
</div>            <p> The output here shows that the Nginx daemon is active and running. If it is not active, start it by issuing the following command:</p>
        <!-- No AdsNinja v10 Client! --><pre><code class="hljs ">sudo systemctl start nginx</code></pre>
            <p>If you make some configuration changes to Nginx, you can restart the server using <a href="http://www.makeuseof.com/manage-systemd-services-linux/">the systemctl command</a> as follows:</p>
        <pre><code class="hljs ">sudo systemctl restart nginx</code></pre>
            <p>To serve the default Nginx webpage, open the URL <a href="http://localhost:80" rel="noopener noreferrer" target="_blank">http://localhost:80</a> in a web browser. You will be greeted by a page similar to the one below.</p>
                                            <div class="body-img responsive-img img-article-item"  style="padding-bottom:52.583333333333%">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="750px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/nginx_default_served_page.png?q=50&fit=crop&w=750&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/nginx_default_served_page.png?q=50&fit=crop&w=943&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="767px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/nginx_default_served_page.png?q=50&fit=crop&w=767&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="480px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/nginx_default_served_page.png?q=50&fit=crop&w=480&dpr=1.5"/>
                        <!--[if IE 9]></video><![endif]-->
            <img width="1200" height="631" class="lazyload" alt="default page served by the nginx server"/>
        </picture>
            </figure>
</div><div class=ad-odd><!-- No AdsNinja v10 Client! --></div><h2 id="learn-how-to-develop-web-apps">
        Learn How to Develop Web Apps</h2>            <p>Congratulations, you&#39;ve successfully installed and configured Nginx. This guide has looked at how to install and configure a web server on Ubuntu. In addition, we discussed how you can manage the Nginx server daemon using <strong>systemctl</strong>.</p>
                    <p>The demand for web developers has never been this huge, and it shows no signs of slowing down anytime soon. Start your web development journey by learning the basics of HTML today.</p>
                <div id="article-waypoint"></div>
                                                                                                    


                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                        <!-- No AdsNinja v10 Client! -->
                                                                                            <a class="sentinel-article-nextArticle next-btn" data-content-id="2002779" href="/html-introduction/" >
        <div class="next-btn-img">
                            
    
    
<div class="bc-img responsive-img img-article-next-btn">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 768px)"
                        sizes="320px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/09/html-code.jpg?q=50&fit=crop&w=320&h=240&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="140px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/09/html-code.jpg?q=50&fit=crop&w=140&h=140&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1680" height="840" class="lazyload" alt="Photo of code featuring on a computer screen"/>
                    </picture>
            </figure>
</div>

        </div>
        <div class="next-btn-text lines-trim">
            <strong><span class="next-btn-text-title">An Introduction to HTML</span></strong>
                            <p class="next-btn-text-p">If you want to learn how to build websites, then you need to learn HTML.</p>
                    </div>
        <div class="next-btn-cta icon i-arrow-1">Read Next</div>
    </a>
                                        <div class="sharing bottom">
                	
<button class="sharing-btn btn-more" onclick="this.parentNode.classList.add('open')">
	<span class="icon i-share"></span>
	<span class="text">Share</span>
</button>


<a class="sharing-btn btn-facebook" target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.makeuseof.com%2Fhow-to-install-nginx-on-ubuntu%2F%2F&amp;src=sdkpreparse">
	<span class="icon i-facebook"></span>
	<span class="text">Share</span>
</a>

<a class="sharing-btn btn-twitter" target="_blank" href="https://twitter.com/intent/tweet?text=How%20to%20Install%20and%20Configure%20Nginx%20on%20Ubuntu&url=https%3A%2F%2Fwww.makeuseof.com%2Fhow-to-install-nginx-on-ubuntu%2F">
	<span class="icon i-twitter"></span>
	<span class="text">Tweet</span>
</a>

<a class="sharing-btn btn-mail" href="mailto:?Subject=How to Install and Configure Nginx on Ubuntu&Body=Check%20this%20out%21%0Ahttps%3A%2F%2Fhttps://www.makeuseof.com/how-to-install-nginx-on-ubuntu/">
	<span class="icon i-mail-1"></span>
	<span class="text">Email</span>
</a>            </div>
                                        <div class="article-tags">
	<strong class="section-sub-title">Related Topics</strong>
    <ul>
                                                        <li><a href="/category/linux/">Linux</a></li>
                                    <li><a href="/category/programming/">Programming</a></li>
                                                                            <li><a class="tags-link" href="/tag/ubuntu/">Ubuntu</a></li>
                                    <li><a class="tags-link" href="/tag/web-server/">Web Server</a></li>
                                    <li><a class="tags-link" href="/tag/install-software/">Install Software</a></li>
                            	        </ul>
</div>        <!-- No AdsNinja v10 Client! -->
        <!-- No AdsNinja v10 Client! -->
                    

    
    <strong class="section-sub-title">About The Author</strong>
    <div class="w-article-author-bio">
                    <div class="author-bio-img" >
                                                                                                
                                    <img data-src="https://static1.makeuseofimages.com/wordpress/wp-content/authors/603e4af20a35a-social_media_miros_profile_balck_and_white.jpg?fit=crop&amp;w=100&amp;h=100" class="lazyload">
                            </div>
                <div class="author-bio-text">

            <strong class="bio-title">Mwiza Kumwenda
                                    <span class="amount">(41 Articles Published)</span>
                            </strong>

                            <div class="bio-social">
                                            <a href="https://twitter.com/Mwiza_K" rel="nofollow"
                           target="_blank"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 338.39 277.15"><g id="Layer_2" data-name="Layer 2"><g id="Layer_1-2" data-name="Layer 1"><path class="cls-1" d="M1.86,246.51a166.34,166.34,0,0,0,24.25,0,136,136,0,0,0,26.38-4.71,141.61,141.61,0,0,0,39.78-18.06,69.13,69.13,0,0,0,9.25-7c-15.2-.74-28.59-5.14-40.27-13.89a69,69,0,0,1-24.73-34.55,69.28,69.28,0,0,0,30-1C66.47,166.1,34,156.53,21.14,133c-6.2-10.52-9-22-9.34-34.16-.06-1.79,1-.83,1.53-.54a69.39,69.39,0,0,0,21.75,7.16c2.45.4,5,.41,7.77.63C11.5,80.28,4.8,49.34,21.34,12.55c4.35,4.74,8.22,9.15,12.29,13.36A195.61,195.61,0,0,0,69.42,55a196.06,196.06,0,0,0,54.5,24.14,198.7,198.7,0,0,0,39.57,6.57c2.58.16,2.82-.79,2.46-2.91-4.49-26.48,3.38-48.84,23.47-66.38,14.1-12.31,31-17.51,49.83-16.23A67.66,67.66,0,0,1,284,20.45a3.9,3.9,0,0,0,4.15,1,139.16,139.16,0,0,0,38.16-14.4c.84-.48,1.76-.84,3.44-1.63a71.63,71.63,0,0,1-29.2,37.65c13-.94,25.27-4.69,37.89-9.78-1.64,3.77-3.92,6.25-5.95,8.77a131,131,0,0,1-25.5,24.72,5.29,5.29,0,0,0-2.39,5,194.71,194.71,0,0,1-6.7,56.78,208.6,208.6,0,0,1-36,73.41A190.72,190.72,0,0,1,217,244.37a183.21,183.21,0,0,1-42.5,21.34,206.72,206.72,0,0,1-43,9.92,215.22,215.22,0,0,1-41.92.9,191.37,191.37,0,0,1-51.82-11.22A201.19,201.19,0,0,1,1.21,247.65a9,9,0,0,1-1.21-1A2,2,0,0,1,1.86,246.51Z"/></g></g></svg></a>
                                                                                                        <a href="https://www.linkedin.com/in/mwiza/" rel="nofollow"
                           target="_blank"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 324.57 323.28"><g id="Layer_2" data-name="Layer 2"><g id="Layer_1-2" data-name="Layer 1"><path class="cls-1" d="M179.59,133.05c28.71-33,70-38.91,101.47-26.66,12.75,5.39,27.48,19.46,34.09,36.81,6,15.67,8.25,32,8.36,48.65.27,40.13.27,80.25,1.05,120.37.18,9.16-2.87,11.35-11.39,11l-47.75,0c-7.36,0-9.84-1.78-9.74-9.54.43-34.07.15-68.15.19-102.22a111.72,111.72,0,0,0-1.93-22.8c-3.28-15.91-12.14-24.75-26-26.54-23-3-33.8,4.48-40.52,19.75-2.85,6.47-4,13.37-4.34,20.43-1.89,36.6-1.2,73.23-.73,109.84.11,8.87-2.49,11.45-11.26,11.07-20.39,0-30.9-.08-48.71-.08-6.17.13-8.32-1.85-8.3-8.16q.26-99.83,0-199.67c0-6.6,2-8.79,8.73-8.79l48.72,0c6.32,0,8.13,2.41,8.13,8.32C179.68,120.16,179.59,125.49,179.59,133.05Z"/><path class="cls-1" d="M5.36,214.9c0-32.48.24-65-.16-97.46-.11-8.1,1.74-11,10.55-11,16.92,0,30,0,46.79,0,9.39,0,11.05,3.21,11,11.49-.3,46.82-.17,93.64-.13,140.46,0,18.47,0,36.95.35,55.41.15,6.9-1.93,9.6-9.25,9.39H13.87c-6.85.16-8.68-2.37-8.62-8.9C5.5,281.15,5.36,248,5.36,214.9Z"/><path class="cls-1" d="M78.64,39.63c-.07,22.37-16.83,39-39.31,39C17.72,78.68-.3,60.59,0,39.18A39.69,39.69,0,0,1,39.79,0C62,.11,78.72,17.2,78.64,39.63Z"/></g></g></svg></a>
                                                                                                                    </div>
            
            <div class="bio-desc">
                <p>Mwiza develops software by profession and writes extensively on Linux and front-end programming. Some of his interests include history, economics, politics & enterprise-architecture.</p>
            </div>

                            <a class="bio-btn icon i-arrow-5" href="/author/mwiza-kumwenda/">More
                    From Mwiza Kumwenda</a>
                    </div>

    </div>

                <!-- No AdsNinja v10 Client! -->
                            <div class="newsletter-from" id="newsletter-from">
                <div class="btn-nf-container">
                    <h4>Subscribe to our newsletter</h4>
                    <p>Join our newsletter for tech tips, reviews, free ebooks, and exclusive deals!</p>
                    <div class="btn-nf">Click here to subscribe</div>
                </div>
                                <script> window.newsletterForm = '&quot;&lt;div id=\&quot;mlb2-2384299\&quot; class=\&quot;ml-form-embedContainer ml-subscribe-form ml-subscribe-form-2384299\&quot;&gt;\n    &lt;div class=\&quot;ml-form-align-center\&quot;&gt;\n        &lt;div class=\&quot;ml-form-embedWrapper embedForm\&quot;&gt;\n            &lt;div class=\&quot;ml-form-embedBody ml-form-embedBodyDefault row-form\&quot;&gt;\n                &lt;div class=\&quot;ml-form-embedContent\&quot;&gt;\n                    &lt;h4&gt;Subscribe To Our Newsletter&lt;\/h4&gt;\n                    &lt;p&gt;Join our newsletter for tech tips, reviews, free ebooks, and exclusive deals!&lt;\/p&gt;\n                &lt;\/div&gt;\n                &lt;form class=\&quot;ml-block-form\&quot; action=\&quot;https:\/\/app.mailerlite.com\/webforms\/submit\/r3i1n7\&quot; data-code=r3i1n7 method=\&quot;post\&quot; target=\&quot;_blank\&quot;&gt;\n                    &lt;div class=\&quot;ml-form-formContent\&quot;&gt;\n                        &lt;div class=\&quot;ml-form-fieldRow ml-last-item\&quot;&gt;\n                            &lt;div class=\&quot;ml-field-group ml-field-email ml-validate-email ml-validate-required\&quot;&gt;\n                                &lt;input type=\&quot;email\&quot; class=\&quot;form-control\&quot; data-inputmask=\&quot;\&quot; name=\&quot;fields[email]\&quot; placeholder=\&quot;your@email.com\&quot; autocomplete=\&quot;email\&quot;&gt;\n                            &lt;\/div&gt;\n                        &lt;\/div&gt;\n                    &lt;\/div&gt;\n                    &lt;div class=\&quot;ml-form-recaptcha ml-validate-required\&quot;&gt;\n                        &lt;style type=\&quot;text\/css\&quot;&gt;\n                            .ml-form-recaptcha{}.ml-form-recaptcha.ml-error iframe{border:solid 1px red}@media screen and (max-width:480px){.ml-form-recaptcha{\/*width:220px!important*\/}.g-recaptcha{\/*transform:scale(.78);-webkit-transform:scale(.78);transform-origin:0 0;-webkit-transform-origin:0 0*\/}}\n                        &lt;\/style&gt;\n                        &lt;script src=\&quot;https:\/\/www.google.com\/recaptcha\/api.js\&quot;&gt;&lt;\/script&gt;\n                        &lt;div class=\&quot;g-recaptcha\&quot; data-sitekey=\&quot;6Lf1KHQUAAAAAFNKEX1hdSWCS3mRMv4FlFaNslaD\&quot;&gt;&lt;\/div&gt;\n                    &lt;\/div&gt;\n                    &lt;input type=\&quot;hidden\&quot; name=\&quot;ml-submit\&quot; value=\&quot;1\&quot;&gt;\n                    &lt;div class=\&quot;ml-form-embedSubmit\&quot; onclick=\&quot;this.parentNode.classList.add(&#039;open&#039;)\&quot;&gt;\n                        &lt;button type=\&quot;submit\&quot; class=\&quot;primary\&quot;&gt;Submit&lt;\/button&gt;\n                        &lt;button disabled=\&quot;disabled\&quot; style=\&quot;display:none\&quot; type=\&quot;button\&quot; class=\&quot;loading\&quot;&gt;Loading...&lt;\/button&gt;\n                    &lt;\/div&gt;\n                &lt;\/form&gt;\n            &lt;\/div&gt;\n            &lt;div class=\&quot;ml-form-successBody row-success\&quot; style=\&quot;display:none\&quot;&gt;\n                &lt;div class=\&quot;ml-form-successContent\&quot;&gt;\n                    &lt;h4&gt;One More Step\u2026!&lt;\/h4&gt;\n                    &lt;p&gt;Please confirm your email address in the email we just sent you.&lt;\/p&gt;\n                &lt;\/div&gt;\n            &lt;\/div&gt;\n        &lt;\/div&gt;\n    &lt;\/div&gt;\n&lt;\/div&gt;\n&lt;script&gt;\n    function ml_webform_success_2384299(){var r=ml_jQuery||jQuery;r(\&quot;.ml-subscribe-form-2384299 .row-success\&quot;).show(),r(\&quot;.ml-subscribe-form-2384299 .row-form\&quot;).hide()}\n&lt;\/script&gt;\n&lt;img src=\&quot;https:\/\/track.mailerlite.com\/webforms\/o\/2384299\/r3i1n7?v1595538294\&quot; width=\&quot;1\&quot; height=\&quot;1\&quot; style=\&quot;max-width:1px;max-height:1px;visibility:hidden;padding:0;margin:0;display:block\&quot; alt=\&quot;.\&quot; border=\&quot;0\&quot;&gt;\n&lt;script src=\&quot;https:\/\/static.mailerlite.com\/js\/w\/webforms.min.js?v5c5d99c28cfe49b41fe82455507d7558\&quot; type=\&quot;text\/javascript\&quot;&gt;&lt;\/script&gt;\n&quot;'; </script>
            </div>
                        </section>
        
<aside id="secondary" class="sidebar" role="complementary">

    <!-- No AdsNinja v10 Client! -->
            <!-- No AdsNinja v10 Client! -->

    
                                                            <section class="sidebar-trending ">
                                                                        <div class="section-header">
                            <h3 class="section-title">On The Wire</h3>
                        </div>
                                <div class="sentinel-article-sidebarTop browse-grid clip-full col-1">
                                                                                                                    







    

<article class="browse-clip  item-1 js-content" data-content-id=":630387">
        <a class="bc-img-link" href="/tag/micro-usb-cables-charge/" >
                    
    
    
<div class="bc-img responsive-img img-size-full">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="330px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2017/03/usb_c_shutterstock.jpg?q=50&fit=crop&w=330&h=170&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2017/03/usb_c_shutterstock.jpg?q=50&fit=crop&w=943&h=450&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="737px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2017/03/usb_c_shutterstock.jpg?q=50&fit=crop&w=737&h=413&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2017/03/usb_c_shutterstock.jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1680" height="840" class="lazyload" alt="USB-C cable next to a laptop"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/tag/micro-usb-cables-charge/" class="bc-title-link" title="The 8 Best USB-C Cables for Charging and Data Transfer" >The 8 Best USB-C Cables for Charging and Data Transfer</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                                                                                            



                                
                                
    



    

<article class="browse-clip  item-2 js-content" data-content-id=":67589">
        <a class="bc-img-link" href="/tag/6-sites-enhance-instagram-experience/" >
                    
    
    
<div class="bc-img responsive-img img-size-full">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="330px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/09/Manicured-Hands-Using-Instagram.jpg?q=50&fit=crop&w=330&h=170&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/09/Manicured-Hands-Using-Instagram.jpg?q=50&fit=crop&w=943&h=450&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="737px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/09/Manicured-Hands-Using-Instagram.jpg?q=50&fit=crop&w=737&h=413&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/09/Manicured-Hands-Using-Instagram.jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1680" height="840" class="lazyload" alt="Photo of a person using Instagram on their phone"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/tag/6-sites-enhance-instagram-experience/" class="bc-title-link" title="7 Sites That Enhance the Instagram Experience" >7 Sites That Enhance the Instagram Experience</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                                                                                                                        







    

<article class="browse-clip  item-3 js-content" data-content-id=":635482">
        <a class="bc-img-link" href="/tag/company-profile-templates/" >
                    
    
    
<div class="bc-img responsive-img img-size-full">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="330px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2020/03/write-company-profile.jpg?q=50&fit=crop&w=330&h=170&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2020/03/write-company-profile.jpg?q=50&fit=crop&w=943&h=450&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="737px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2020/03/write-company-profile.jpg?q=50&fit=crop&w=737&h=413&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2020/03/write-company-profile.jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1680" height="840" class="lazyload" alt="write-company-profile"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/tag/company-profile-templates/" class="bc-title-link" title="How to Write a Company Profile (Plus Samples and Templates to Aid You)" >How to Write a Company Profile (Plus Samples and Templates to Aid You)</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                            <!-- No AdsNinja v10 Client! -->
                                                                                                                        







    

<article class="browse-clip  item-4 js-content" data-content-id=":2001240">
        <a class="bc-img-link" href="/how-tokenize-assets-create-nonfungible-tokens-nft/" >
                    
    
    
<div class="bc-img responsive-img img-size-full">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="330px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/08/Asset-Tokenization-Featured.jpeg?q=50&fit=crop&w=330&h=170&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/08/Asset-Tokenization-Featured.jpeg?q=50&fit=crop&w=943&h=450&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="737px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/08/Asset-Tokenization-Featured.jpeg?q=50&fit=crop&w=737&h=413&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/08/Asset-Tokenization-Featured.jpeg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1680" height="840" class="lazyload" alt="An illustrative image for globe, coins, and NFT"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/how-tokenize-assets-create-nonfungible-tokens-nft/" class="bc-title-link" title="How Do You Tokenize Assets to Create Non-Fungible Tokens (NFT)?" >How Do You Tokenize Assets to Create Non-Fungible Tokens (NFT)?</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                                                                                                                        







    

<article class="browse-clip  item-5 js-content" data-content-id=":2005245">
        <a class="bc-img-link" href="/what-is-openbsd/" >
                    
    
    
<div class="bc-img responsive-img img-size-full">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="330px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/network-switch-cables.jpg?q=50&fit=crop&w=330&h=170&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/network-switch-cables.jpg?q=50&fit=crop&w=943&h=450&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="737px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/network-switch-cables.jpg?q=50&fit=crop&w=737&h=413&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/network-switch-cables.jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1680" height="840" class="lazyload" alt="Network switch cables"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/what-is-openbsd/" class="bc-title-link" title="What Is OpenBSD? Everything You Need to Know" >What Is OpenBSD? Everything You Need to Know</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                                                                                                                        







    

<article class="browse-clip  item-6 js-content" data-content-id=":150629">
        <a class="bc-img-link" href="/tag/how-to-fix-write-protection-errors-on-a-usb-stick/" >
                    
    
    
<div class="bc-img responsive-img img-size-full">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="330px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2017/05/USB-Write-Errors-Featured.jpg?q=50&fit=crop&w=330&h=170&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2017/05/USB-Write-Errors-Featured.jpg?q=50&fit=crop&w=943&h=450&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="737px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2017/05/USB-Write-Errors-Featured.jpg?q=50&fit=crop&w=737&h=413&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2017/05/USB-Write-Errors-Featured.jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1680" height="840" class="lazyload" alt=""/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/tag/how-to-fix-write-protection-errors-on-a-usb-stick/" class="bc-title-link" title="How to Fix the Disk Is Write Protected USB Error" >How to Fix the Disk Is Write Protected USB Error</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                        </div>
                                                                    <!-- No AdsNinja v10 Client! -->
                                            </section>
                                                                
        

        
                                                                                                <section class="sidebar-sticky ">
                        <!-- No AdsNinja v10 Client! -->
                        <div class="section-header">
                            <h3 class="section-title">trending now</h3>
                        </div>
                                <div class="sentinel-article-sidebarSticky browse-half clip-half">
                                                                                                







    

<article class="browse-clip  item-1 js-content" data-content-id=":821501">
        <a class="bc-img-link" href="/tag/ways-reuse-old-router/" >
                    
    
    
<div class="bc-img responsive-img img-size-half">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="341px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2018/12/old-router.jpg?q=50&fit=crop&w=341&h=215&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="377px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2018/12/old-router.jpg?q=50&fit=crop&w=377&h=300&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="294px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2018/12/old-router.jpg?q=50&fit=crop&w=294&h=234&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2018/12/old-router.jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1680" height="840" class="lazyload" alt="old-router"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/tag/ways-reuse-old-router/" class="bc-title-link" title="12 Useful Ways to Reuse an Old Router (Don&#039;t Throw It Away!)" >12 Useful Ways to Reuse an Old Router (Don&#039;t Throw It Away!)</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                                                                                            







    

<article class="browse-clip  item-2 js-content" data-content-id=":2005339">
        <a class="bc-img-link" href="/spotify-wrapped-2021/" >
                    
    
    
<div class="bc-img responsive-img img-size-half">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="341px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/12/metallic-spotify-logo.jpg?q=50&fit=crop&w=341&h=215&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="377px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/12/metallic-spotify-logo.jpg?q=50&fit=crop&w=377&h=300&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="294px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/12/metallic-spotify-logo.jpg?q=50&fit=crop&w=294&h=234&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/12/metallic-spotify-logo.jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1680" height="840" class="lazyload" alt="metallic spotify logo"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/spotify-wrapped-2021/" class="bc-title-link" title="Spotify Wrapped 2021 Has Arrived: Here&#039;s How to View Yours" >Spotify Wrapped 2021 Has Arrived: Here&#039;s How to View Yours</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                                                                                            







    

<article class="browse-clip  item-3 js-content" data-content-id=":2003962">
        <a class="bc-img-link" href="/what-is-javascript-strict-mode/" >
                    
    
    
<div class="bc-img responsive-img img-size-half">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="341px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/macbook-pro-on-a-table-(1).jpg?q=50&fit=crop&w=341&h=215&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="377px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/macbook-pro-on-a-table-(1).jpg?q=50&fit=crop&w=377&h=300&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="294px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/macbook-pro-on-a-table-(1).jpg?q=50&fit=crop&w=294&h=234&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/macbook-pro-on-a-table-(1).jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1680" height="840" class="lazyload" alt="MacBook pro with JavaScript code"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/what-is-javascript-strict-mode/" class="bc-title-link" title="What Is JavaScript’s Strict Mode?" >What Is JavaScript’s Strict Mode?</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                        </div>
                                                            </section>
                                    
    
</aside>
    </article>
    <section class="w-article-related">
    <!-- No AdsNinja v10 Client! -->

    <div class="section-header">
                    <h3 class="section-title">Read Next</h3>
            </div>


    <div class="sentinel-article-relatedContent browse-grid col-1 col-t-2 col-d-4 clip-full">
                    







    

<article class="browse-clip  js-content" data-content-id=":722779">
        <a class="bc-img-link" href="/tag/cool-duckduckgo-bangs/" >
                    
    
    
<div class="bc-img responsive-img img-size-full">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="330px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2018/01/duckduckgo-bang-commands.jpg?q=50&fit=crop&w=330&h=170&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2018/01/duckduckgo-bang-commands.jpg?q=50&fit=crop&w=943&h=450&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="737px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2018/01/duckduckgo-bang-commands.jpg?q=50&fit=crop&w=737&h=413&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2018/01/duckduckgo-bang-commands.jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1680" height="840" class="lazyload" alt="duckduckgo-bang-commands"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/tag/cool-duckduckgo-bangs/" class="bc-title-link" title="25 Cool DuckDuckGo Bangs That Make Google Search Look Slow" >25 Cool DuckDuckGo Bangs That Make Google Search Look Slow</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                                







    

<article class="browse-clip  js-content" data-content-id=":259708">
        <a class="bc-img-link" href="/tag/3-crazy-excel-formulas-that-do-amazing-things/" >
                    
    
    
<div class="bc-img responsive-img img-size-full">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="330px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2017/10/Crazy-Excel-Formulas-Featured.jpg?q=50&fit=crop&w=330&h=170&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2017/10/Crazy-Excel-Formulas-Featured.jpg?q=50&fit=crop&w=943&h=450&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="737px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2017/10/Crazy-Excel-Formulas-Featured.jpg?q=50&fit=crop&w=737&h=413&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2017/10/Crazy-Excel-Formulas-Featured.jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1680" height="840" class="lazyload" alt=""/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/tag/3-crazy-excel-formulas-that-do-amazing-things/" class="bc-title-link" title="3 Crazy Microsoft Excel Formulas That Are Extremely Useful" >3 Crazy Microsoft Excel Formulas That Are Extremely Useful</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                                







    

<article class="browse-clip  js-content" data-content-id=":2004933">
        <a class="bc-img-link" href="/https-everywheres-turned-10/" >
                    
    
    
<div class="bc-img responsive-img img-size-full">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="330px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/https.jpg?q=50&fit=crop&w=330&h=170&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/https.jpg?q=50&fit=crop&w=943&h=450&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="737px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/https.jpg?q=50&fit=crop&w=737&h=413&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/https.jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1680" height="840" class="lazyload" alt="HTTPS in the browser bar. "/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/https-everywheres-turned-10/" class="bc-title-link" title="HTTPS Everywhere Has Turned 10: Here&#039;s What&#039;s Changed and Why That Matters" >HTTPS Everywhere Has Turned 10: Here&#039;s What&#039;s Changed and Why That Matters</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                            <!-- No AdsNinja v10 Client! -->
                                



                                
                                
                                
    



    

<article class="browse-clip  js-content" data-content-id=":851425">
        <a class="bc-img-link" href="/tag/iphone-wont-connect-to-computer/" >
                    
    
    
<div class="bc-img responsive-img img-size-full">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="330px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2019/06/iphone-wont-connect.jpg?q=50&fit=crop&w=330&h=170&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2019/06/iphone-wont-connect.jpg?q=50&fit=crop&w=943&h=450&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="737px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2019/06/iphone-wont-connect.jpg?q=50&fit=crop&w=737&h=413&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2019/06/iphone-wont-connect.jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1680" height="840" class="lazyload" alt="iPhone and MacBook, both with their screen off"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/tag/iphone-wont-connect-to-computer/" class="bc-title-link" title="Your iPhone Won&#039;t Connect to Your Computer? Here&#039;s the Fix!" >Your iPhone Won&#039;t Connect to Your Computer? Here&#039;s the Fix!</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                                







    

<article class="browse-clip  js-content" data-content-id=":2004969">
        <a class="bc-img-link" href="/how-to-erase-all-content-and-settings-on-mac/" >
                    
    
    
<div class="bc-img responsive-img img-size-full">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="330px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/macbook-desk-coffee.jpg?q=50&fit=crop&w=330&h=170&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/macbook-desk-coffee.jpg?q=50&fit=crop&w=943&h=450&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="737px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/macbook-desk-coffee.jpg?q=50&fit=crop&w=737&h=413&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/macbook-desk-coffee.jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1680" height="840" class="lazyload" alt="Macbook sitting on desk with a coffee mug."/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/how-to-erase-all-content-and-settings-on-mac/" class="bc-title-link" title="Here&#039;s the Quickest Way to Erase All Content and Settings on Your Mac" >Here&#039;s the Quickest Way to Erase All Content and Settings on Your Mac</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                                







    

<article class="browse-clip  js-content" data-content-id=":2005182">
        <a class="bc-img-link" href="/nft-is-collins-dictionary-word-of-the-year-2021/" >
                    
    
    
<div class="bc-img responsive-img img-size-full">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="330px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/NFT-image-(1).jpg?q=50&fit=crop&w=330&h=170&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/NFT-image-(1).jpg?q=50&fit=crop&w=943&h=450&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="737px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/NFT-image-(1).jpg?q=50&fit=crop&w=737&h=413&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/NFT-image-(1).jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1680" height="840" class="lazyload" alt="NFT word image"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/nft-is-collins-dictionary-word-of-the-year-2021/" class="bc-title-link" title="“NFT” Is Collins Dictionary&#039;s Word of the Year for 2021" >“NFT” Is Collins Dictionary&#039;s Word of the Year for 2021</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                            <!-- No AdsNinja v10 Client! -->
                                







    

<article class="browse-clip  js-content" data-content-id=":542171">
        <a class="bc-img-link" href="/tag/6-best-practices-outlook-boost-workflow/" >
                    
    
    
<div class="bc-img responsive-img img-size-full">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="330px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2016/03/outlook-boost-workflow.jpg?q=50&fit=crop&w=330&h=170&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2016/03/outlook-boost-workflow.jpg?q=50&fit=crop&w=943&h=450&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="737px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2016/03/outlook-boost-workflow.jpg?q=50&fit=crop&w=737&h=413&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2016/03/outlook-boost-workflow.jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1680" height="840" class="lazyload" alt="Outlook logo with a checkmark symbol"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/tag/6-best-practices-outlook-boost-workflow/" class="bc-title-link" title="The 10 Best Practices for Outlook to Boost Your Workflow" >The 10 Best Practices for Outlook to Boost Your Workflow</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                                







    

<article class="browse-clip  js-content" data-content-id=":2005110">
        <a class="bc-img-link" href="/what-is-a-prime-lens/" >
                    
    
    
<div class="bc-img responsive-img img-size-full">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="330px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/Prime-Lenses-on-Table.jpg?q=50&fit=crop&w=330&h=170&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/Prime-Lenses-on-Table.jpg?q=50&fit=crop&w=943&h=450&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="737px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/Prime-Lenses-on-Table.jpg?q=50&fit=crop&w=737&h=413&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/Prime-Lenses-on-Table.jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1680" height="840" class="lazyload" alt="Photo of two prime lenses on a table"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/what-is-a-prime-lens/" class="bc-title-link" title="What Is a Prime Lens in Film and Photography?" >What Is a Prime Lens in Film and Photography?</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                                







    

<article class="browse-clip  js-content" data-content-id=":629436">
        <a class="bc-img-link" href="/tag/delete-windows-files-folders/" >
                    
    
    
<div class="bc-img responsive-img img-size-full">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="330px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2017/03/delete-windows-files-space.jpg?q=50&fit=crop&w=330&h=170&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2017/03/delete-windows-files-space.jpg?q=50&fit=crop&w=943&h=450&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="737px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2017/03/delete-windows-files-space.jpg?q=50&fit=crop&w=737&h=413&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2017/03/delete-windows-files-space.jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1680" height="840" class="lazyload" alt="delete-windows-files-space"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/tag/delete-windows-files-folders/" class="bc-title-link" title="Delete These Windows Files and Folders to Free Up Disk Space" >Delete These Windows Files and Folders to Free Up Disk Space</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                        </div>
</section>
        </div>

            
    
                

            





        



<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "Article",
        "mainEntityOfPage": {
            "@type": "WebPage",
            "@id": "https://www.makeuseof.com/how-to-install-nginx-on-ubuntu/"
        },
        "headline": "How to Install and Configure Nginx on Ubuntu",
        "image":{
            "@type": "ImageObject",
            "url": "https://static1.makeuseofimages.com/wordpress/wp-content/uploads/2021/11/engineers-setting-up-nginx-server.jpg",
            "height":840,
            "width":1680
        },
        "datePublished": "2021-11-30T18:00:12Z",
        "dateModified": "2021-11-30T18:00:12Z",
            "author": {
            "@type": "Person",
            "@id" :  "https://www.makeuseof.com/author/mwiza-kumwenda/#author",
            "name": "Mwiza Kumwenda",
            "sameAs":[
                 "https://www.makeuseof.com/author/mwiza-kumwenda/",
                     "https://twitter.com/Mwiza_K"
            ]
        },
        "publisher": {
            "@type": "Organization",
            "@id": "https://www.makeuseof.com/#organization",
            "name": "MUO",
            "sameAs": [
            "https://www.youtube.com/muotv",
            "https://www.facebook.com/muo.official",
            "https://www.instagram.com/muoofficial/",
            "https://twitter.com/MUO_official",
            "https://www.pinterest.ca/muo_official/"    
        ],

            "logo": {
                "@type": "ImageObject",
                "url": "https://www.makeuseof.com/public/build/images/muo-amp-logo.2eef8ce3.png",
                "height":101,
                "width":202
            }
        },
        "articleSection":["linux","ubuntu","web-server","install-software"],
                "description": "Develop and deploy robust web applications by installing the Nginx server on Ubuntu."
    }
</script>

    
                    
<!-- No AdsNinja v10 Client! -->

    
<footer class="w-footer">
        <div class="footer">
                        <nav class="menu-legal">
        <ul>
                                                                <li><a class="write" href="/contributor/">Write For Us</a></li>
                                                                                <li><a class="menu-home" href="/">Home</a></li>
                                                                                <li><a class="menu-contact-us" href="/contact/">Contact Us</a></li>
                                                                                <li><a class="menu-terms" href="/terms-of-use/">Terms</a></li>
                                                                                <li><a class="menu-privacy" href="/privacy-policy/">Privacy</a></li>
                                                                                <li><a class="menu-copyright" href="/dmca-take-down-policy/">Copyright</a></li>
                                                                                <li><a class="menu-about-us" href="/about/">About Us</a></li>
                                                                                <li><a class="menu-fact-checking-policy" href="/fact-checking-policy/">Fact Checking Policy</a></li>
                                                                                <li><a class="menu-corrections-policy" href="/corrections-policy/">Corrections Policy</a></li>
                                                                                <li><a class="menu-ethics-policy" href="/ethics-policy/">Ethics Policy</a></li>
                                                                                <li><a class="menu-ownership-policy" href="/ownership-funding-advertising-policy/">Ownership Policy</a></li>
                                                                                <li><a class="menu-partnership-disclaimer" href="/partnership-disclaimer/">Partnership Disclaimer</a></li>
                                    </ul>
    </nav>

        	</div>
	<div class="footer-copy">
		Copyright &copy; 2021 www.makeuseof.com
	</div>
</footer>

        
    </div>

                    <script src="/public/build/valnet-footer.19470cec.js" async></script>
    
        <script src="/public/build/valnet-footer-article.34c12672.js" async></script>
        <script>
                    var isPreview =  false
                    </script>
            <script async type="text/javascript" src="https://s.skimresources.com/js/85009X1675668.skimlinks.js"></script>
    

    

        <script>
        document.addEventListener('DOMContentLoaded', function () {
            var queryString = window.location.search || '';
            var keyValPairs = [];
            var params      = {};

            queryString     = queryString.substr(1);
            if (queryString.length)
            {
                keyValPairs = queryString.split('&');
                for (var i = 0; i < keyValPairs.length; i++)
                {
                    var key = keyValPairs[i].split('=')[0];
                    if (!key.length) continue;
                    if (typeof params[key] === 'undefined')
                        params[key] = [];
                    params[key].push(keyValPairs[i].split('=')[1]);
                }

                if (params['view'] !== undefined) {
                    if (params['view'] == "list" || params['view'] == "lista") {
                        valnet_cookie.set("view",params['view']);
                    }
                }

                var campaign = null;
                if (params['utm_source'] !== undefined) {
                    campaign = params['utm_source'];
                }
                if (campaign !== null) {
                    valnet_cookie.set("campaign",campaign);
                }
            }
        });
    </script>

                    

                                                        
    <script>

        console.log('viewType: direct');
        console.log('view: all');
        console.log('campaign: ');
        console.log('device: desktop');
                console.log('displayStartButton:  false ');
        
    </script>

    

    
 </body>
</html>

