Why won’t my bootable USB drive for Linux on Mac run?

Anonymous January 7, 2014

I followed all the instructions for the Mac Linux USB Loader that the article on this website said. I wasn’t having any problems with it until I tried to actually run it. This is the message I get after choosing to run the operating system on my usb drive.

kernel path: /casper/vmlinuz | ramdisc path: /casper/initrd.lz
boot parameters:

Loading Linux kernel…done

unaligned pointer 0x2
Aborted. Press any key to exit.

Any help would be very much appreciated.

  1. Hovsep A
    January 8, 2014 at 10:10 am

    can be hardware problem, wrong linux version..;

    Installing Ubuntu on a MacBook Pro

    Fix for making bootable Ubuntu Live USB with persistence using Unetbootin on a Mac

    • Ryan O
      January 8, 2014 at 4:43 pm

      Thanks, I used Unetbootin and it worked great.

  2. Jan F
    January 8, 2014 at 12:18 am

    Maybe try creating a standard Linux Live USB stick?
    I haven't tried it with a USB stick yet but my multi-boot CDs created using Xboot perfectly work on (Intel) Macs.

    * Note: Intel Mac is a must for USB boot. Older PPC models do not support boot via USB

    • Ryan O
      January 8, 2014 at 1:06 am

      Xboot is a windows only program that I can't download on my mac, but thanks for the suggestion.