Why is my wireless internet adapter losing connection randomly?

Mel May 5, 2011
Ads by Google

Seeing what ideas I can get ~ I am not super computer savvy, but know more than just where the power button is. lol

About a month ago, I set up my new HP desktop with Windows 7 64 bit. As with our other desktop, I bought a Netgear WNA3100 wireless adapter. It caused minor issues but figuring it was operator error, I went with it as we have never had issues. This past week however, we have had issues.

It would work fine then all the sudden lose connection. Our internet was fine as at least one or two other computers were working on the internet. Today, it was literally a few minutes and it would disconnect. I’d take it out of the USB and reconnect. Finally, I uninstalled it and reinstalled it. It worked for a few hours and now it’s doing it again. Faulty?? Drivers are all up to date etc. so do I need to go buy a new one? I bumped it a couple weeks ago and am wondering if I have a loose(ish) connection inside of it??


  1. Mel
    May 6, 2011 at 8:20 pm

    I ended up going and buying a new one ~ and it seems to be working fine ~ least for the last 6 hours it's been fine :) Thank you so very much for all your assistance :)

  2. Mel
    May 6, 2011 at 12:26 pm

    I have a HP p6000 series desktop. Came with Win 7 64 bit. I've only had the HP for a little over a month. The WNA3100 is suppose to be 64 bit compatible. I have another desktop identical to the one I use with a WNA1100 on it and have no trouble whatsoever. So it's only my limited knowledge that I say this but I don't believe the ports r an issue. I do have it plugged in the back ~ that's where I always put those. I only use the front ones for flash drives etc.

    After switching ports (again) this morning & a rough start, it's been running fine for the last hour. Yesterday when I re installed it (got the software/drivers from Netgear), it worked from about noon until 7 or 8 pm. Then it disconnected and I just stopped even trying to use the computer. It's not consistent in the issues ~ so it seems to me.

    I apologize if I don't answer your questions right ~ I know a bit about pcs, but not a ton. Thanks :)

    • Tina
      May 6, 2011 at 1:22 pm

      If this is a new laptop it should come with USB 2 or maybe even USB 3. Maybe the wireless adapter doesn't recognize USB 3? Maybe you don't have the right drivers installed for your USB ports?

    • Mike
      May 6, 2011 at 7:15 pm

      To be honest I suggest you to contact Netgear technical support about this issue.

      For example the driver is listed as Win7 64bit compatible but Netgear doesn't list the WNA3100 as Windows 7 compatible in general
      http://kb.netgear.com/app/answers/detail/a_id/11127/kw/Windows%207/r_id/100109 (Updated 04/17/2011 04:36 AM)

      To me this means that I could give you various instruction about installing chipset drivers, completely removing the WNA3100 drivers and reinstalling them, enabling and disabling Windows Zero Config etc... in short ~ a day of work while you might be looking at a compatibility issue.

  3. Mike
    May 6, 2011 at 11:45 am

    The message that the device can perform faster usually means that it's a USB 2.0 device connected to an older Port (USB 1.1/1.0) on your computer.

    Since you haven't stated any information about your HP Desktop I can't tell for sure whether this is message is technically correct or another minor problem with the WNA3100.

    First of all make sure that the drivers for the WNA3100 are 64bit compatible. If they are not compatible this could be the source of all your problems.

    You should also make sure that you have installed the Chipset drivers for your computer Mainboard. Chances [although very small] are that Windows is using some generic driver and the USB Ports are not detected correctly.

    If possible try another USB Port ~ at best one of the backside of the computer. The ports on the front are usually part of a front plane which could be faulty or not properly connected to the Mainboard.

    As for your last suggestion that the USB WiFi dongle might be damaged you can only test this by connecting it to another computer.

  4. Mel
    May 6, 2011 at 11:17 am

    When I booted up today, it did the same thing as it was. A pop up comes up telling me this device can perform faster ~ It tells me to connect to another USB port 2.0. What the heck? I've tried all the USB ports ~ I get the same result.

Ads by Google