Why is my Windows sidebar not working properly?

A Ry August 28, 2011

The gadgets do not show up properly for example, the clock gadget shows up as a black box and it is not working. Other gadgets don’t appear at all.

  1. A Ry
    September 1, 2011 at 2:33 am

    Thanks to all of you but none of the solutions worked for me. Nevertheless, I have got Yahoo! Widgets as a replacement for Sidebar. I guess Sidebar is corrupt because of that no-good Kaspersky antivirus.

    • Aibek
      September 4, 2011 at 7:25 am

      You may try using some other antivirus instead like Micorosft Security Essentials, Avira or AVast. Check out some of the free options here, //www.makeuseof.com/tag/best-windows-software/

    • Tina
      September 4, 2011 at 10:19 am

      A Ry,

      did you try to replace Kaspersky Antivirus with something else and did that fix your issue with the sidebar?

  2. Anonymous
    August 29, 2011 at 8:31 am

    If Jeffrey Method didnt worked

    check your firewall and see that gadgets are allowed?

    can be because  if the XML registration is missing in the system. To
    fix the problem, use the following steps:

    1) Close Windows Sidebar.
    2) Open an elevated Command Prompt window. To do so, click Start,
    click All Programs, click Accessories, right-click Command
    Prompt, and then click Run as administrator.

    ---In the Command Prompt window, type the following and press ENTER:
    regsvr32 msxml3.dll
    ----Similarly, run these commands:
    regsvr32 scrrun.dll
    regsvr32 jscript.dll
    3)If the registration was successful, you'll see the message DllRegisterServer in
    succeeded for each command executed. Open Windows
    Sidebar (sidebar.exe) and check if the problem is resolved

    or use this batch file

    After this do a sfc /scannow
    In the elevated command prompt, type sfc /scannow and press Enter

    How to Fix Gadgets not Displaying Correctly in Windows 7
    you can use the batch file or type the commands that are stated below the batch post

  3. Jeffery Fabish
    August 29, 2011 at 6:08 am

    Hi Ry,

    I assume you're using Windows Vista. Have these gadgets work previously (and if so, what changes have occurred since then)?

    Please go to start -> search: "cmd.exe" without quotes and right click on the application and choose "run as administrator" then proceed to run these commands separately.

    regsvr32 -u sbdrop.dll
    regsvr32 -u wlsrvc.dll
    regsvr32 atl.dll
    regsvr32 sbdrop.dll
    regsvr32 wlsrvc.dll
    regsvr32 vbscript.dll
    net start uxsms

    Then go to start -> search: "services.msc" without quotes. Find the service labeled "Desktop Windows Manager" or "Session Manager" and right click on it, chose "restart". Then restart your computer. If this doesn't fix it, does using the default Aero theme fix it?