Why am I seeing this Windows Media Player 12 script error?

Anthony September 22, 2011

When using “find album info,” both the “search” and “finish” buttons return a script error.

“The value of the property ‘btnSearch_onclick,’ is null or undefined, not a function object.”

I tried some of the ActiveX and security resolutions that I found in previous posts with no luck. Seems like there are files missing?

Any help would be greatly appreciated.

  1. Spencer
    November 8, 2011 at 6:23 pm

    none of this works for me =/ i've tried it all and i'm pretty tech savvy, any more hints? i'm so anal about my music i absolutely have to have this feature

    • Bsarlo
      November 8, 2011 at 7:00 pm

      Are you trying to Edit the Album Info yourself or are you searching for the info, selecting an album, clicking Next, and then clicking Finish?
      If you are trying to add your own info by clicking Edit on the Existing Info side of the Find Album Information box, you are right this doesn't work.
      If you are trying to Search for the album info and using what MS provides, it should work. Are you using IE? You've tried this already?
      Close Media Player
      Open Internet Explorer
      Go to Tools-->Internet Options-->Delete Browsing History-->Delete...
      Then make sure the top checkbox is not checked while the following are : Temporary Internet Files; Cookies; History; Download History. Then click Delete.
      Close IE
      Open Media Player

      Works for me every time...

      You can even edit the tracks after you select an album and click Next.

      Sorry it's not working for you. I know how frustrating it is. I spent days trying to get this to work. Seems like MS should have a fix by now... 

      • Spencer
        November 9, 2011 at 3:02 am

        yes i'm right clicking and hitting find album info then getting all the way to where i can hit "finish" and it gives me the script error. i've tried everything on this thread to try and fix it including the clearing of internet files. to no avail

      • NMAS
        December 23, 2011 at 3:29 pm

        Just want to thank you, I'd been having trouble for a month with very little time to research. Finally had some time to look through these threads. Was still having a problem untill I read your thread where you emphasize to make sure the top box (preserve favorites website data) is NOT checked. That worked for me!

  2. Bsarlo
    November 7, 2011 at 7:57 pm

    This is a really simple fix. Delete your IE browsing history but make sure that the PRESERVE FAVORITES WEBSITE DATA checkbox is unchecked. I've had to do this daily and it works every time.

  3. Tryingtohelp
    October 27, 2011 at 6:37 am

    Glad I could help.
    Noticed this thread on makeuseof is like the third search result in google if you search for this problem so hope it helps many others, wish microsoft would fix it but their busy making windows 8 for us to have to buy and complain about the bugs it later. (lol)

    Anyway for whatever reason probably either my anti-virus updates which i doubt or a windows update probably to IE9 the problem returned.

    I restarted from ha14's GO INTO IE SECURITY again found the ActivX setting had been reverted back so I made the change again.
    Found that Media player add-on was disabled left that alone.
    Did the cmd instructions again.
    Did the globe refresh trick again but awwwww it didn't work this time.
    Thought maybe the server was down but it could get/grab the album info like song names and album art but when I clicked finish, again the script error, I even restarted the computer but still the dreaded error, even waited an hour in case the server was down.

    So i gave up...HELL NO.
    I looked around again and found that some people had to to clean the IE temp files.
    So I opened up CCleaner which is what I use to clean the registry and temp files on my computer, in the cleaner window, clicked the "analyze" button, then "run cleaner" button, even cleaned the registry not sure if this was needed but can't hurt.
    To my surprise opened up media player and it's working again all back to normal.
    You can also search on how to delete temp files in IE 9 but a cleaner is more powerfull.

    A couple notes on using ccleaner or any other cleaner, it is a bit dangerous if you don't know what you are doing, it will erase your history, cookies etc. but you can always uncheck what you don't need it to clean up(delete). Carefull a lot of fake ones so try Ccleaner it's free and also has a paid version, I've used it for over 8 years now.

    So basically if it happens to you again, like it did to me:
    1. Check the settings by going threw ha14's instructions again.
    2. Clean temp files (stated by me)
    3. Clean registry files (stated by tina *please read her post above before doing so)

    To merlin: A little globe is the little icon(picture) to the left of fai.music.meta.... in the Find album information window on the top left side,if you go over it a little box(square) will pop up saying "Refresh", you know it looks like the world if you saw it from the moon with little countries on it, remember people told columbus he'd fall off cause it was flat, it's a small mostly blue circle(round thing). You can also google, yahoo search "globe" or look it up in the dictionary, also most classrooms at least in my day had a globe. I know it sound a little smartassish but trying to describe it as descriptive as possible.

  4. merlin
    October 15, 2011 at 4:31 am

    what is a little globe, I can't find this

  5. Billy
    September 30, 2011 at 5:30 am

    Many thanks to ha14 and Tryingtohelp. All back and running now.

  6. Tryingtohelp
    September 26, 2011 at 8:12 am

    peon25, try this if you did the prior steps above correctly.
    I thought I was in the same boat as you but remembered from searching for a solution before about refreshing fai.music....
    Before you click finish, click on the small globe by the fai.music....... to refresh, then click finish and it should work.
    Remember ha14's steps above must be done first correctly. (I didn't uninstall media player, just started from GO INTO IE SECURITY)
    My exact steps were the same as above except I selected prompt in "Initialize and script ActiveX....." a little more security then just enabling, still didn't prompt me though.
    I also clicked finish and found it didn't work, I was about to give up until I clicked the globe from what I know it refreshes something related to the server media player uses.
    Took me 2 hours to get this working after all the searching.
    We shouldn't have to do Microsoft's homework for them.
    They broke it with Internet explorer 9, I believe with that whole do you want to enable add-ons message you get when you first run explorer after installing it.
    A way to stay safe without worry of the ActiveX enabling thing would be to use Firefox as it has it's own add-ons and such.
    Hope this helps you or anyone else.
    Windows 7 64bit, IE 9 installed but don't use it, Media Player 12.

    • H Fields
      September 27, 2011 at 2:04 am

      Thank you sooo much. I tried your "cick the globe" solution and it worked for me. I did find that I had to close media player and start it back up again, but it worked

    • Steve Smith
      September 27, 2011 at 7:19 am

      Thanks; clicking the little globe fixed it, didn't have to restart or anything else.

      • Tina
        September 27, 2011 at 8:06 pm

        Thanks for the feedback!

  7. Tina
    September 25, 2011 at 8:50 am

    In a similar question that was asked previously, Thomasmary posted a possible solution:

    Ran Norton Registry and File Cleanup and the problem went away.Must have been a combination of reinstalling media player and Norton, since I ran Norton earlier and it didn't fix the problem.

    However, I urge you to be careful with running registry cleanups! Please backup your registry first and try a registry clean only as a very last resort.

  8. Peon25
    September 24, 2011 at 3:35 pm

    Unfortunately did not work for me -- I've tried all this, and still get the Line 345 Char 25 btnFinish_onlick error.

    It was working fine earlier today, music playback stopped when my track list hit the end, I added another album to my library, went to update the album information, and now it's screwed. I've removed/readded WMP 12, changed IE settings, etc. No luck whatsoever.

    Windows Media Player version 12.0.7601.17514

  9. Charlie
    September 24, 2011 at 2:22 am

    I'm having the same problem... Did that solution work for you?

  10. Annapha22
    September 23, 2011 at 3:07 pm

    Hello honey
    I wish you best sucses of life, It is my wish
    to say to you hello please write me on my
    mail so that we can no each other and i will sent to you my
    pictures,My name is Ann baby girl ,i love you ;Please write me,
    ( annfreedom_91@yahoo.in )
    I wish you the best of good luck and sucese of life
    kisss and hugh miss Ann, 

  11. Anonymous
    September 23, 2011 at 10:55 am


    -Click Start, and then click Control Panel.
    -Under Programs, click Uninstall a program.
    -In the tasks pane, click Turn Windows features on or off.
    -In the list of windows features, clear the check box next to Windows Media Player.
    -You receive a warning message in a pop-up window. Click Yes.
    -Restart the computer.
    -Once again go to Turn Windows features on or off.
    -In the list of windows features, put a check mark next to Windows Media Player.
    -You receive a warning message in a pop-up window. Click Yes.
    -Restart the computer again.

    Go into IE Security and add the js url
    to the trusted sites zone.
    Then enable the "Initialize and script ActiveX controls not marked as safe for scripting" just for Trusted Sites.
    Remember to disable the same ActiveX control for your Internet setting

    go to Your IE9 open manage addons click on currently loaded addons and change it to all addons and disable the addon of windows media player

Ads by Google