How can I get Windows 7 Upgrade Advisor to run?

Mike Brumberg June 19, 2011

I downloaded Windows 7 Upgrade Advisor twice, using ‘Remove Programs’ in between. I get the initial screen each time, click on ‘Start check’ and absolutely nothing happens. I left my PC on overnight and only the initial screen is there. I am running on a Dell Vostro 1500 with Windows XP SP3. .NET 2.0 is installed, along with 1.0 and 3.5.

  1. Zekealo
    January 15, 2012 at 9:01 am

    I am having the same problem. I am running Windows Vista and every time I click the button, absolutely nothing happens. I have tried everything Jeff said and nothing has worked. Any assistance would be very appreciated.

  2. Tina
    June 25, 2011 at 10:33 pm


    did the tips above help you getting Windows Upgrade Advisor to run? Please let us know in case you need more help. Thank you!

  3. Anonymous
    June 21, 2011 at 7:38 am

    If the laptop is too old then possible no upgrade will be and this can be an explanation. Posible you can upgrade to vista.

    Think Dell do not upgrade  Dell Vostro 1500

  4. Jeffery Fabish
    June 20, 2011 at 6:32 am

    If your PC can't run the Upgrade Advisor, that aught to enlighten you as to how your computer would perform with the entire operating system installed :P 

    All jokes aside, it sounds like a third party application is preventing it. Have you configured your firewall and or anti-virus to allow for this application to run? 

    Go to start -> run and type "msconfig" without quotes. Under the "General" tab chose "Selective startup" radio button. Under that, you should see "load start up items", disable that check box. 
    Then go to the service tab and chose HIDE ALL MICROSOFT SERVICES (very important!!), after you've done that, and ONLY THEN select "disable all" services. Then go to the "startup" tab and chose "disable all". Then chose "apply" and "OK". You'll be prompted to restart, select yes. Once you restart uninstall Upgrade Advisor, restart THEN install the upgrade advisor. 

    Whether that does or does not solve your problem, you can always go back in and renable the items and services the same way.