Why does my Windows 7 system tray always display the wrong network icon?

Danny Roy Jenuil December 8, 2011
Ads by Google

I am having a problem where the network icon on the Windows 7 system tray is not showing the correct icon whenever I am connected to any network. At first glance, the icon tells me that I am not connected to any available network but when I clicked on it, it shows that I am actually connected to a network. The Internet works fine but I found this problem really annoying and I hope somebody could help me out.

Take a look at this screenshot to get a better picture of my problem:

  1. Shikimikashitemo
    April 22, 2012 at 11:26 am

    make sure there's no other connections delete any net work  connections that are not being used.

    • trier
      August 9, 2012 at 4:19 pm

      This is an annoying fix, but worked for me: go to cmd and write "ipconfig /release" and then "ipconfig /renew". May take forever but it clears up the icon for me.

  2. Baloon
    January 27, 2012 at 10:08 pm

    Same happened to me but sorted itself out after I downloaded SP1 for Windows 7.

  3. Anonymous
    December 9, 2011 at 8:58 am

    Maybe this MicrosoftFixit50229 can help 

    click Start, type Customize icons and then click Customize icons on the task bar. Next click Turn system icons on or off, and then set Volume, Network, and Power System to On. Click OK, make sure that the behavior for Power, Network, and Volume are set correctly, and then click OK.

    • Myke46
      December 29, 2011 at 11:50 am

      OK.tried both suggestions.Neither worked but after resetting icons,I see a notification next to network icon stating that  "the service which detects this status is turned off".Would you by any chance know  the name for that particular service?

      • Anonymous
        December 29, 2011 at 12:44 pm

        you can try this
        1. Click start
        2. Type services.msc in the search bar, Open services.msc
        3. Search DNS client and DHCP Client services and start the services if they are stopped.

        or reset TCP/IP, use microsoft fix it

        or via command line
        1) netsh winsock reset catalog (resets winsock entries)
        2) netsh int ip reset reset.log hit (resets TCP/IP stack)

        • Myke46
          December 29, 2011 at 7:48 pm

          when I tried your first suggestion,all was fin e except DNS client(could not turn it on),FixIt-didn't work and #2 command got an "invalid"path.I see a pattern here, just don't know where it leads

        • Anonymous
          December 29, 2011 at 10:01 pm

          so tell me do you have internet access?  what about the icons?

          you can try 
          Network List Service - Started - Automatic instead manual

          go to run and type troubleshooting then choose Network and Internet and then Network adapter

          also possible that you have a malware infection like conficker, do scan on safe mode with malwarebytes antimalware, superantispyware, clamwin.

          if you think you have association problem if you wish you can try to download the LINK file from here
          extract and click on it and reboot

        • Myke46
          December 30, 2011 at 11:58 am

          The icon has reverted to the monitor with the red X over it but I have a great connection.I'll run the malware scans this pm when I get home from work.I got 8GBs of memory for Christmas that I am dying to install but would like to have everything running correctly before I do.I realize there's no immediate correlation,just an anal thing.Thanks,will let you know how scans work out.

        • Myke46
          December 31, 2011 at 10:00 pm

          Sorry it took so long to get back-Roguekiller reports that I have an Infection:Root.MBR.I had to use msconfig to safe boot and once in it,I couldn't update any AV.So I loaded a few ,including Malwarebytes and Superantispyware and nothing else so far has detected it except Roguekiller but it offers no option to clean or quarantine.Any suggestions?

      • Anonymous
        January 1, 2012 at 2:10 pm

        Hi, well mine is the sound icon, sometime it has the X on it but the sound works, perhaps as in your case can be driver conflict that microsoft has to fix it.

        Concerning roguekiller report (Infection:Root.MBR), this can be a false positive, but if you wish to repair mbr follow this article guide

        To fix the MBR:

        1. Open a Windows Recovery Console
        • For Windows XP: Installing and using the Recovery Console in Windows XP
        • For Windows Vista: System Recovery Options in Windows Vista
        • For Windows 7: System Recovery Options in Windows 7

        2. Use the tool BOOTREC.exe to fix the MBR as in:

        bootrec.exe /fixmbr

        3. Restart the computer and you can then scan the system to remove any remaining malware.

        • Myke46
          January 2, 2012 at 12:10 pm


          I went ahead and ran the bootrec.exe/fixmbr command using repair disc,rebooted,booted back into safe mode and ran malwarebytes,which only found cookies-Icon remains unchanged.Even though the NLA is turned on,should I go ahead and follow directions on "cosideritfixed"?Also,at the risk of sounding ignorant,which file extension fix should I run from "winhelponline?
          By the way,I want you,and all the MUO staff to know how much I appreciate your help.You are definitely my favorite tech site.

        • Myke46
          January 2, 2012 at 12:15 pm

          sorry,I forgot to mention that when I try to access troubleshooting through 'run' I get a message telling me that Windows can't find it.

        • Anonymous
          January 2, 2012 at 6:17 pm

          you should be able to have it like this Control Panel > All Control Panel Items > Troubleshooting then click on view all if you wish

        • Anonymous
          January 3, 2012 at 6:47 pm

          okay you can try nlasvc.dll in safe mode also to take ownership download the following

          concerning reseting network adapter

          1. Open the Registry Editor
          2. If you use Windows 7 browse to:
          HKEY_CURRENT_USERSoftwareClassesLocal SettingsSoftwareMicrosoftWindowsCurrentVersionTrayNotify
          3. Delete the data of the following keys in this folder:
          4. Open the Task Manager.
          Switch to the process tab.
          Kill every explorer.exe process
          (this is necessary because the explorer.exe has a backup copy of this keys in the RAM and writes it back to the registry on shutdown)
          Switch to the application tab of the Task Manager.
          Press "New Task".
          Type "explorer.exe" and press [Enter].

        • Anonymous
          January 2, 2012 at 1:18 pm

          up to you to decide to run the fix from 
          "cosideritfixed if you think you can handle the procedure or if its really the solution for the problem!. i cant have responsibility if something goes wrong during this manipulation.

          you can try the following from winhelponline

          let us know the outcome

          also perhaps to reinstall driver for my network adapter

          perhaps is something to do with Incoming Connections in Network and Sharing Centre

        • Myke46
          January 3, 2012 at 12:25 am

          First of all I am well aware that you are in no way responsible for what i do.I cannot tell you how much I appreciate your suggestions.Alright,narrowing down, 'Services' shows Network List Service as "starting"(perpetually,it seems).It was set on Manual and I tried setting it on Auto but it made no difference,still "starting".Also,no matter how I try to access the network and sharing center or any other item related to the adapter,just hangs trying to connect.So it seems like the NLS and everything related to it are stuck mid-connection.
          I also tried the nlasvc.dll,it allowed me to take ownership but after that it popped up an unnumbered error message telling me "This file does not have program associated wih it for performing this action..."
          Maybe resetting the network adapter from cmd?

    December 9, 2011 at 7:38 am

    Hello, Before making any changes make sure to set a system restore point. Also make sure to try and update the drivers. After setting restore point, you could try the following:

    -- click on start
    -- type cmd in search box
    -- right click on cmd entry and select run as administrator
    -- once command prompt opens type the following and press enter after each entry:
    winmgmt /verifyrepository

    winmgmt /salvagerepository

    -- restart computer

    If this started happening not long ago, you also try system restore to the point where it was working ok.

    • Myke46
      December 29, 2011 at 11:41 am

      Thanks for the advice.Unfortunately,both suggestions failed.

      • FIDELIS
        December 29, 2011 at 5:07 pm

        Hello, have you tried the following:

        -- click on up arrow in taskbar next to clock
        -- click on customize
        -- click on restore default icons behaviour
        -- click on ok

Ads by Google