Why does Windows 7 not recognize my DVD plug and play device?

Regina October 5, 2011

I have a problem with external DVD drives. I’ve tried three different drives plugged in via USB, and none of them are detected by Windows after the first time they are plugged in. Those same USB ports work with other devices. I’ve tried to uninstall and reinstall the USB drivers for these devices, and I’ve tried the built-in Windows troubleshooters, but have had no luck. Please help!

  1. Jay
    October 6, 2011 at 5:39 pm

    check for any window7 updates if you missed any.
    try another usb port.

  2. Anonymous
    October 6, 2011 at 8:52 am

    see what Unknown Device Identifier 7.00 will tell you 

    October 6, 2011 at 7:07 am

    Hello, do you know if you external dvd drives work ok in other computers?  I might be worth your while to check.  This is a possible solution:


    A while back, somebody brought me a computer to fix where the dvd/cd drive would not work.  Of course, this was an internal drive....  The way to fix it was to get rid of the upper and lower filter entries in the registry.  If you decide to try this steps, make sure to make a backup of your registry and also create a restore point.

    -- Click on the Start
    -- type regedit on the search box and then click OK.

    -- navigate to the following registry entry:


    -- highlight and then right click on the UpperFilters entry
    -- click delete on the Edit menu
    -- click Yes

    -- highlight and then right click on the LowerFilters entry
    -- click delete on the Edit menu
    -- click Yes

    -- exit registry
    -- restart computer

  4. Jeff Fabish
    October 6, 2011 at 4:25 am

    Insert the external DVD drive and go to Start -> Run/Search: "devmgmt.msc" and press enter. This will launch the device manager. Does it recognize your external DVD drive? If so, go to Start -> "Computer", is your drive listed there? You may want to try this Microsoft fix.

  5. Anonymous
    October 6, 2011 at 2:49 am

    Can you provide us with the models you used?
    Are the USB ports USB 2.0 or 1.0?