Why won’t the WiFi function work on my iPhone 4S after upgrading to 6.1.3?

Christine S August 13, 2013

It worked prior to the upgrade. I tried reinstalling an earlier saved version of my iPhone and that didn’t work either. I have of course tried the usual reboot – soft and hard – as well as removing network settings.

  1. Susendeep D
    August 17, 2013 at 11:45 am

    If resetting didn't solved the problem,then ask Apple support to replace your device(if under warranty) as searching the forums concluded that they couldn't find any meaningful resolution towards this issue.Wi-fi and Bluetooth works occasionally and stops after that.

  2. Hovsep A
    August 13, 2013 at 3:16 pm

    reset AirPort Express to accept WPA/WPA2 Personal

    1) Open AirPort Utility and click on the Airport Express icon, then click Edit.
    2) Click the Wireless tab and change the security setting
    3) WPA/WPA2 Personal, Immediately set it back to WPA2 Personal. "Update" button should become active in the lower right corner. clicked Update and follow instructions
    or set up a new network connection while in the AirPort utility

    turn off cellular data under General -- > Network see if wifi will come back

    1. Turn on "Airplane Mode"
    2. Turn iphone off
    3. Took the SIM card out
    4. Turn iphone on
    5. Put sim card in (activate phone message?)
    6. Turn "Airplane Mode" on message?
    7. Join network message?

    Resetting an AirPort Base Station or AirPort Time Capsule FAQ