Why won’t the Nvidia Quadro K600 work with my PC?

Lane G August 2, 2013
Ads by Google

I’m trying to get the following video card to work in my ‘HP Pavilion Elite’ H8-1020 (Windows 7)
NVIDIA Quadro K600
– http://www3.pny.com/NVIDIA-Quadro-K600-P3276C365.aspx
The chipset in the H8-1020 is Intel H61 so from what I can tell, I have a PCI-E 2.0 16x slot which is what the card calls for.
This PC shipped with a Radeon HD6570 installed so I removed that card and installed the Quadro.

When I turn on the computer, I get POST from BIOS but it won’t go any further. It just sits on the screen telling me I can press ESC to enter setup but pressing ESC does nothing. No beeps either.

I reconnected the stock video card looking for an option to disable secure boot but the option does not exist in the BIOS.

Under ‘boot order’ in the BIOS, I tried disabling all the UEFI devices and leaving only legacy devices active but that did not help.
Bios is v7.16 which is the latest and I tried reflashing it but that didn’t help either.
I also tried accessing the BIOS while using the onboard video but that also did not help. Under the security menu, there is still no option for ‘Secure Boot Configuration’.

I tried pulling the battery on the mobo – didn’t help.
I tried resetting BIOS to defaults – didn’t help.

At this point, I am trying to figure out if the problem is that the card is simply incompatible or if there is some setting in the BIOS that is preventing the card from working. I don’t think I need a larger power supply only because the HD6570 appears to consume more power than the K600 does.


  1. MakeUseOf TechGuy
    August 5, 2013 at 12:50 pm

    Lane, please don't copy paste your question to multiple forums. I found your duplicate over at Toms Hardware: http://www.tomshardware.com/answers/id-1754495/quadro-install.html

  2. Lane G
    August 4, 2013 at 11:26 pm

    According the manufacturer, it is PCIE 2.0 (x16)

  3. James
    August 4, 2013 at 2:54 pm

    A quick google tells me that machine does not in fact have pci-e 2.0 slots, but only 1.0.

    • Bruce E
      August 4, 2013 at 11:20 pm

      The card that was originally installed in the machine uses a PCIe 2.0 (or 2.1, depending on source) x16 interface. Double-checked the Carmel motherboard used in the system as well. It uses the Intel H61 chipset which according to the Intel docs supports PCIe 2.0.

    • James B
      August 5, 2013 at 7:44 am

      Proves nothing. The chipset is irrelevant if the board itself doesn't support it - and while some PCIe 2.0 are generally backward compatible (ie, the Radeon has been working fine on an older slot), some are not (hence why the new one doesn't work). Every tech spec that exists for this system quite clearly states it's a PCI Express 16x, not PCI Express 2.0 X16. Difference.

    • Bruce Epper
      August 5, 2013 at 12:11 pm

      The determining factor for the version of PCIe supported is the northbridge of the motherboard chipset. Even though the documentation does not state version 2.0, it still will be version 2.0 simply because of the H61 chipset in this instance. For the motherboard to be only version 1.0a or 1.1, you would need to revert all the way back to around 2006/7 and the P35 (or was it the P33?) chipset. This machine is much newer than that, so version 2.0 support is guaranteed.

    • MakeUseOf TechGuy
      August 5, 2013 at 12:49 pm

      If this were a custom rig with verifiable components, then sure, your logic is faultless. But this is an HP machine, which means the only thing guaranteed is bad performance and incompatible components.

      Moreover, why do you think the specs would downplay the capabilities of the PCIe slots? You think they would deliberately write it's only PCI-e 1.0 when in fact it's the superior version 2.0?

    • Bruce Epper
      August 5, 2013 at 3:43 pm

      I don't think it is a matter of downplaying the hardware but more of the marketing department not understanding what they are trying to sell and the PCIe version number being dropped. A lot of marketing departments think the number of lanes is much more important that the version of the bus that is implemented simply becaue the number of lanes used for video cards tends to be so much larger than the version. After all, isn't seeing x16 more impressive than seeing v2.0? It must be remembered that even the spec sheets that are seen on the OEM's website are frequently written by non-technical people.

      I have found a few locations such as this one that specifically state version 2.0, but I have been unable to track down any specific documentation direct from Pegatron (formerly Asustek) which tends to be a fairly common problem when dealing with OEM parts for the big builders.

      And looking at your James B comment above starting with 'Proves nothing.' above got me thinking about something else OP initially said, so:

      OP: When you get video on the screen, does the system perform the remainder of the hardware inventory (listing drives detected, etc) or does it halt before the entire system inventory has completed? In other words, does POST complete or not? Also, do you have any other cards in the PCIe x1 slots? If so, remove those and retry booting with the Quadro card in place and see if you get the same results.

    • Lane G
      August 5, 2013 at 6:42 pm

      POST doesn't complete.
      If I continue to tap the ESC key as instructed, the internal speaker eventually starts chirping.
      No cards are installed in the 1x slots.
      When I have the case open again later today, I will see if the PCIE port is labeled as v2.0 on the motherboard itself.

    • MakeUseOf TechGuy
      August 5, 2013 at 7:21 pm

      I don't suppose you're able to try another power supply? Again, one of the problems with buying a brand name PC is the atrocious PSUs they put in there. You'd be surprised how many issues are caused by insufficient power...

  4. Bruce E
    August 3, 2013 at 11:14 pm

    The problem isn't with the video card at all here. You are actually getting video through POST in this entire thing. So, put the original card back into the machine. Start it up and boot into Windows. Go to Device Manager and tell it to remove your original video card from the setup and delete all of the drivers. Power down the machine, put in the Quadro card and boot it up again. It should boot Windows immediately after POST (instead of hanging up when Windows tries to load the wrong (ATI) driver), automagically install a set of NVIDIA drivers (probably not the best set to use, so you'll probably want to update them as soon as you have a chance), and let you get back to work.

    • Lane G
      August 5, 2013 at 12:41 pm

      I tried removing the drivers. I even removed them in safe mode using driver sweeper. It still did the same thing.

  5. Jan F
    August 3, 2013 at 7:06 am

    PCI-Express slots can supply up to 75W bus power so that shouldn't be a problem with the K600 using 41W according to the specifications.

    I also don't recall hp locking down the BIOS/Firmware ~ they are usually fine with customers doing hardware upgrades. After all this means voiding the warranty and hp can charge you for any subsequent repairs.

    My first impression is indeed (and unfortunately) that there is something with the K600 card itself. Basically what should follow the POST process is the initialization of the other hardware including the GPU. So if your system boots up fine using the Radeon but stops there with the K600 installed it appears to be the source of the problem.

    Can you test the K600 in another system, maybe at friends or so? Or if you bought it in a local store explain your problem and ask them to test the card.
    If you bought it online check the return and RMA policies. Depending on the seller it may just be easier to return it and buy another card.

  6. Hovsep A
    August 2, 2013 at 8:46 pm

    have you disabled the on board graphic card first then plug Quadro K600 and try to boot.

Ads by Google