Why won’t my Samsung phone boot after rooting it?

Anonymous September 30, 2013

After I tried rooting my phone (Samsung Galaxy Star Duos/GT-S5282) using Odin software (by downloading the pre-rooted firmware through booting in download mode) (today). It showed a green button/block saying ‘PASS’. But when I tried to boot it, it just shows – ‘SAMSUNG GALAXY STAR’ or the boot screen. It doesn’t even show the SAMSUNG logo or the boot animation, just makes the start sound & then shuts down with vibration! Please help me!! What should I do next!! PLEASE, IT’S URGENT !!

  1. Dalsan M
    September 30, 2013 at 7:55 pm

    I agree with Hovsep's suggestion. Performing a "factory reset", or in your case, wiping all data and cache, should correct the issue. The system files became corrupt somehow, not uncommon, and this should refresh the system so your phone can boot normally.

  2. Hovsep A
    September 30, 2013 at 3:28 pm

    go to recovery mode : Vol up + home + power. When your device vibrates, release only the power button
    then you need to wipe data from and cache in order to eliminate the bootloop.