Why won’t my Nokia C3-00 update?

Anas Ali November 14, 2012

I had some problem during when i was trying to update my nokia C3-00 via the nokia suit. just when it was about done there was an error stating the phone has been disconnected from the usb, please connect again and re try. but it was still connected to the usb wire. i have tried updating it a couple of time but there is always the same issue. it didn’t harm the phone much. i still use it. but it gives an error with a number some times. I need a solution to this please!

  1. Douglas Mutay
    November 14, 2012 at 3:23 pm

    Make sure you have the last Nokia software installed to be sure it will pick the correct drivers for your phone then make a hard reset to your nokia and try again.

    • Anonymous
      November 18, 2012 at 6:19 pm

      How to make a hard reset?

      • susendeep dutta
        November 19, 2012 at 6:39 am
        • Douglas Mutay
          November 19, 2012 at 6:54 am

          Thanks for the link, Susendeep. They are giving the key sequence of *#7370#.
          You can also test *#7780#. This will restore your phone to the way it was when you bought it. Make sure your battery is charged or nearly full before you do it. Good luck

  2. Nikhil Chandak
    November 14, 2012 at 2:04 pm

    ask in a Nokia store

    • Anonymous
      November 18, 2012 at 6:21 pm

      Like the one in my phone?

      • susendeep dutta
        November 19, 2012 at 6:29 am

        No,he is referring to Nokia Care.

        • Nikhil Chandak
          November 19, 2012 at 3:07 pm

          Yea , right susendeep !
          I was telling him to ask this in a Nokia store

  3. Ashish Yadav
    November 14, 2012 at 9:14 am

    Best is to take it Nokia care center and ask the guys to completely erase and install the OS on it. I have a C203 and that was the only thing which cured my problems.

    • Anonymous
      November 18, 2012 at 6:22 pm


  4. susendeep dutta
    November 14, 2012 at 7:50 am

    Try latest version of Nokia Suite -


    It appears that the problem is in with the installed drivers for the phone which is not communicating properly with your phone.After installing latest version,try to update it to see if it helps or not.

    If your phone is under warranty,then you can also try visiting to nearest Nokia Care and ask them to update your phone.

    • Anonymous
      November 18, 2012 at 6:20 pm

      Thanks :) I'll try it out :)

  5. Boni Oloff
    November 14, 2012 at 4:27 am

    I see many probelm with Nokia C3-00 in MOU.
    I think you should try to see them first.

    • Anonymous
      November 18, 2012 at 6:20 pm

      MOU? What is that?

      • susendeep dutta
        November 19, 2012 at 6:30 am

        He's referring to Makeuseof(MUO).

  6. Drew Butler
    November 14, 2012 at 2:17 am

    Try to factory reset the device and then try updating again. Hope this helps

    • Anonymous
      November 18, 2012 at 6:19 pm

      Tried that already, doesn't work :(

Ads by Google