Why isn’t the “;” key working on my keyboard?

kevin gnanaraj December 16, 2012

My semi-colon key does not work if left unused for ~30 minutes. The only way to get it working again is to restart the computer and hold it down at the windows loading screen. What is the problem and is there any way to fix it? All the other keys work fine except for this. My keyboard is a Razer Cyclosa.

  1. kevin gnanaraj
    January 3, 2013 at 1:18 pm

    The system updated itself and the key started working properly. Thanks guys for the help.

  2. kevin gnanaraj
    December 18, 2012 at 6:34 am

    I've tried reinstalling the drivers, and it hasn't solved the problem. It's probably hardware and I'll get round to it, thanks.

  3. Ahmed Musani
    December 17, 2012 at 5:57 pm

    reinstalling the drivers might help

  4. Manuel Guillermo López Buenfil
    December 17, 2012 at 3:45 pm

    I'll say that it is a hardware problem.
    Cleaning your keyboard may help, you can try to open it to clean anything that could have gotten stuck inside. Even if it looks fine, cleaning it may help.

  5. ha14
    December 17, 2012 at 8:58 am

    you can try Aqua Key Test (i never used it my self) if you wish

    it can be be hardware problem

  6. Ahamed Yaseen
    December 17, 2012 at 8:21 am

    In Control Panel change your regional settings or re install driver

  7. Ashwin Ramesh
    December 17, 2012 at 7:20 am

    Did you spill something on your keyboard? If not, then try re-installing the drivers.

  8. Jose Paolo Gonzales Otico
    December 16, 2012 at 11:33 pm

    Try to reinstall the Razer drivers. If you're not using the Razer drivers then try installing them.
    If that's not working then it maybe a hardware issue with the keyboard.

Ads by Google