Why is the touchpad of my Acer Aspire 5250 no longer working?

John Mullen January 11, 2013

Touchpad is not working. Can I download any drivers to fix this? I tried FN-7.

  1. Adrian Bagnato
    January 15, 2013 at 8:38 am

    Is this on a new installation of windows or did you turn it on and it suddenly stopped working? You gotta give more info!

  2. Paul Pruitt
    January 13, 2013 at 3:24 pm

    Try Fn+ F7 instead of Fn + 7.

    • John Mullen
      January 13, 2013 at 11:47 pm

      trying it out now .Let you know what happens

  3. Ahmed Musani
    January 12, 2013 at 9:15 am

    ddownload the latest driver from the manufacturers website and then perform installation uninstalling the previous driver first and restarting.

  4. Jim Chambers
    January 12, 2013 at 4:27 am

    Try suggestion in this MUO Tech Help concerning Acer laptop : How can I fix a laptop touchpad that doesn't work anymore?

  5. ha14
    January 11, 2013 at 9:43 pm

    see if on the side of the laptop there is button that can On/Off the touch pad, you can also open Acer and be sure that the cable is right connected.

  6. Oron Joffe
    January 11, 2013 at 8:38 pm

    Dany's answer is excellent. What you need to do is proceed logically to locate the problem. First, check the "trackpad" control panel (actual name may vary depending on the OS and model of trackpad). Does it exist? Does it recognise the trackpad? Is there an option there to disable the trackpad (if there is, and it shows the trackpad is enabled, disable it, click [OK] then reopen the panel and reenable). If still not working, look in the device manager - does it show the trackpad? With or without errors? If there are errors, read them and see if you can make sense of them (perhaps post them here if required). If a trackpad device is not shown (usually under "pointing devices") then is there an unrecognised device on the list? This is probably your trackpad that "lost" its driver, and you should try reinstalling the driver.
    The important thing is to proceed in order, noting down what facts you have established. Sooner or later you'll pinpoint the problem and, what's better, the solution!

  7. Dany Bouffard
    January 11, 2013 at 8:04 pm

    It might be the driver for the touchpad that is not correctly installed or a hardware failure. For the driver just make sure the correct driver for your touchpad is installed and up to date. It might also mean that your touchpad has been disabled, some Laptop can disable the touchpad with a combination of key on the keyboard.

Ads by Google