Why is my Windows 7 laptop not detecting any Android devices?

Stephanie w January 5, 2013
Whatsapp Pinterest

My Windows 7 laptop is not detecting either my phone (Xperia S) or my tablet (Google Nexus 7). Sometimes I get a driver error, sometimes nothing at all.

I have tried re-installing the driver for the phone, which didn’t work, and I’m not sure how to re install the driver for the Nexus.

Both the phone and the tablet have connected fine with another computer (Windows XP). My laptop could also detect my friend’s iPad.

  1. Nevzat Akkaya
    January 21, 2013 at 9:00 am

    If your current user is not a administrative account, you may try it with an administrative Windows account, it might work.

  2. FIDELIS
    January 9, 2013 at 6:40 am

    Hello, if you have tried everything else suggested, I would try uninstalling the USB driver in your computer and then restart. Once computer is running, it will install the appropriate drivers for it. Then you can try.

  3. susendeep dutta
    January 7, 2013 at 11:46 am

    Did you tried the updated version of drivers present in the links below -

    Xperia S ICS driver -

    http://developer.sonymobile.com/downloads/drivers/xperia-s-driver-for-ics/

    or if your phones doesn't connects to PC using the above driver,then use Sony PC companion software and install it.Keep it open and watch your phone for any popup.Allow installation from phones end when asked and also see that the software will install required drivers for your phone.

    Nexus 7 -

    http://support.asus.com/Download.aspx?SLanguage=en&m=Nexus+7&p=28&s=2

    expand the USB section and download the driver for Windows.

  4. Jim Chambers
    January 6, 2013 at 10:47 pm

    Use a regular USB2 port and not a Combo (USB2/e-SATA) or USB3 port. Check USB settings in Bios. Check the 4 contacts in the port for misalignment.

  5. Nikhil Chandak
    January 6, 2013 at 12:03 pm

    check these
    http://bit.ly/Sd6Qlk
    http://windowsforums.org/topic/7682-tips-for-solving-problems-with-usb-devices/
    if it helps , then its good
    or then u shall follow ha14's advice

  6. Ashwin Divakaran
    January 6, 2013 at 9:05 am

    Ensure Plug n Play is enabled

  7. Gerry Anthony
    January 6, 2013 at 7:05 am

    unplug the cable and dial this *#7284#. On USB section change PDA> MODEM, then exit. Enter again and change MODEM>PDA.

    • asad
      July 9, 2013 at 2:02 pm

      Thanks it worked for my S3

  8. Paul Pruitt
    January 6, 2013 at 3:42 am

    Try connecting with Connectify, VirtualRouter, Winhotspot and AndroidWifi instead of USB. Some or all of them allow transfer of files via Wifi to your Smartphone device.

  9. ha14
    January 6, 2013 at 2:36 am
  10. Alan Wade
    January 5, 2013 at 10:31 pm

    So, assuming you have plugged in an USB cabel to your device then your computer, have you:
    a) tried another USB port
    b) tried another USB device - i.e. a printer for example.

Ads by Google