Why is my USB not working on any computer?

Taryn DeForest November 7, 2012
Ads by Google

I was using my USB stick last night and I knew that I would need it at school today. I turned off my computer and pulled out my USB. When I went to school today, I plugged it in to the computer and it kept saying “USB Device Not Recognised.”

We tried it on 3 different laptops. When I got home, I turned on my computer and plugged in my USB. I got the same message. I tried all the different ports on my home computers. I got the same message every time.

My entire computer is backed up on my USB as well as my school stuff and I would really like to get all my files back. If downloading new software to fix this can be avoided, I would greatly appreciate it.

  1. Jim Chambers
    November 11, 2012 at 2:42 am

    If you removed your USB drive before computer completed shutdown it is probably damaged. Most suppliers recommend that you safely eject USB drive before shutdown as its presence slows the shutdown process.

  2. Marc Carrion
    November 9, 2012 at 9:26 am

    There's two possibilities: One is the usb is physically damaged due to any number of possibilities. The more likely possibility is the you forgot to safely remove it before actually removing it and it is damaged

  3. cracker pack
    November 9, 2012 at 6:48 am

    are you sure you ejected it last time you used it

  4. cracker pack
    November 9, 2012 at 6:47 am

    usb drive must be damaged

  5. Nikhil Chandak
    November 8, 2012 at 2:05 pm

    It may be very old
    repair it
    or buy a new one

  6. Lisa Santika Onggrid
    November 8, 2012 at 1:38 pm

    Maybe it has bad sector. Or the lifespan has ended.

  7. Boni Oloff
    November 8, 2012 at 4:24 am

    There are many people do try to recover their flash disk with any way they can. But in my experience, it never success.

  8. josemon maliakal
    November 8, 2012 at 3:52 am

    YA..THATS CORRECT...it's damaged

  9. Asriel Rusdyawan
    November 8, 2012 at 12:51 am

    Maybe some files in the USB had been Corrupted or the electricity around the computer had gone unstable..

  10. Eserpess der
    November 7, 2012 at 10:59 pm

    I think it might be a hardware problem with one of the pins. I'm sorry but theirs nothing that you can do that I am aware of. Next time back up your computer on a spare drive and 2 USB's....You should never have a problem again.

  11. Alex Perkins
    November 7, 2012 at 5:58 pm

    The USB drive probably got corrupted

  12. Naveen Kumar
    November 7, 2012 at 4:15 pm

    you must have damaged it while trying to pull it or inserting so hard.give info about what USB stick are using (transcend,hp, san disk).........

  13. Harshit Jain
    November 7, 2012 at 4:13 pm

    Maybe it is dead. Try any recovery software and if you still have warranty, get it replaced.

  14. Aniket Singh
    November 7, 2012 at 3:03 pm

    it may be dead........if it is decting on computer try some software like partition master pro
    it may work

  15. Aditya Roy
    November 7, 2012 at 2:27 pm

    Install USBDeview
    This should help your pc detect your flash drive. Good luck

  16. Aditya Roy
    November 7, 2012 at 2:23 pm

    To recover data you may need to download Recuva http://www.piriform.com/recuva

  17. Adam Campbell
    November 7, 2012 at 12:59 pm

    Try with different Operating Systems, maybe you already did but that is all I can think of

  18. dhanunjayarao chunduri
    November 7, 2012 at 12:44 pm

    It is an error accrued in your pen drive chip you don't have a chance to recover your files with any software, but you may recover with another pen drive remove the other pen drive chip and solder it to your defaulted pen drive.

  19. ha14
    November 7, 2012 at 12:36 pm

    always use safely eject USB then unplug from computer then shut down computer. Now if the USB key do not work on other computers then it is related to your USB key hardware problem.

    see if TestDisk can detect it

    • Harshal Warkhede
      November 7, 2012 at 2:08 pm

      Totally agree. USB drive must be damaged.

Ads by Google