Why is my USB Network Adapter not working after upgrading to Windows 7?

Geethan Ambanpola May 8, 2013
Ads by Google

It’s been one year since I bought it, a made-in-China USB network adapter manufactured by some company called KONIX with the model number W206. My network card had fired up suddenly. The adapter worked fine for around 5 months until I formatted my laptop to upgrade it from Windows Vista to Windows 7. After this, it just stopped working.

I checked the device manager and it displays a kind of warning icon with an exclamation mark (!) next to it. After some research, a forum asked me to roll back the driver in device manager. But the option is greyed out – it seems there hasn’t been any previous drivers installed for it before. The links below give some info about the device itself that I found out after seamless web searches:


BTW I asked one of my friends to use the adapter on his laptop and it seems it works- it’s my laptop I’m having trouble with.

Please provide me a solution to this because I need a wired connection to configure my new ZTE ZXV10 W300 router. Thanks a lot ppl! :D

  1. melissa
    May 15, 2013 at 4:40 pm


    • Geethan Ambanpola
      May 18, 2013 at 1:33 pm

      meliss, please post your question individually via the website.

  2. Geethan Ambanpola
    May 12, 2013 at 3:29 pm

    Thanks a lot people for all your help. This is one epic commmunity but it seems i am not going anywhere with fixing this adapter. But like i have mentioned in my original question, the main reason i am trying to fix this adapter is to configure my ZTE ZXV10 W300 router which needs a wired connection in order to do so. So the baseline question now is- "Is it ok to configure my router using another persons pc, which does not have any LAN port issues like in mine?". Will it affect the authority level- or in other words, will i not have total control over the router and its system?

    The youtube link below walksthrought the way to configure the router, which i have no problem with.

    Configuring the router, as the link will show, will involve changing the router settings using a web browser. If i configure the router and its wireless settings using anothers pc, will i be able to alter the settings in the future using my personal laptop and be able to access this browser settings?

    Thank you all. I hope i will get a final solution at last. :D

    • ha14
      May 17, 2013 at 6:55 pm

      in any case you can reset the router and try again with your laptop MAC address to have a new IP

  3. Alan Wade
    May 10, 2013 at 9:50 am

    If all else fails contact Konix direct and see what they have to say about it. There are contact details available on their site:
    [Broken Link Removed]

    • Geethan Ambanpola
      May 12, 2013 at 4:40 am

      Alan Wade- I am currently already in the proccess of contacting the KONIXtech team but i am having little feedback. Anyways, thanks for your advice :D

  4. yudics
    May 9, 2013 at 7:16 am

    hi Geethan, it seems like your driver not win 7 ready. but you may try this, try to uninstall the driver from device manager, and then refresh it (scan for hardware change), and let the windows find the driver for new device..

    • null
      May 9, 2013 at 4:56 pm

      There must be a driver for the adapter, but it is not shown in the device manager. And like i have stated, this is a chinese model and i really cant find any drivers available for download. By the way, the website mentions the device is only compatible with OS up to Windows XP, but the friend i gave to for testing had Windows 7 and it worked fine.

    • yudics
      May 10, 2013 at 7:00 am

      hi, there some article explain that your device supporting plug n play, that's mean your device can run without special driver, have you tried my suggestion? and what the result? any changes?

    • Geethan Ambanpola
      May 12, 2013 at 4:37 am

      I tried your suggestion, but to no avail. When i scanned for hardware changes, the result was the same issue i have explained in my original question. But you are indeed right that this device supports plug n play....except for my laptop :D My friend says that a driver automatically installed itself when he plugged it in to his lap.

    • yudics
      May 14, 2013 at 2:21 am

      hi Geethan, i'm glad if you finally find the way to configure your router, but if you're still curious about your USB Network adapter, you can read this article: http://www.unknowndevicedrivers.com/usb-ports-not-working/, maybe you'll find the solution in there..

    • yudics
      May 14, 2013 at 12:29 pm

      hi Geethan, i'm glad if you finally find the way to configure your router, but if you're still curious about your USB Network adapter, you can read this article: http://www.unknowndevicedrivers.com/usb-ports-not-working/, maybe you'll find the solution in there..

    • Geethan Ambanpola
      May 14, 2013 at 5:10 pm

      Man this is CRAZY!!! This website has got everything. Thanks a bucket man! I am finally gonna fix this thing..... Thanx again man! :D :D

  5. Rajaa Chowdhury
    May 9, 2013 at 3:26 am

    Is the device driver for the USB network adapter compatible with Windows 7? Vista or earlier driver may be incompatible. Google the model name alone with windows 7 drivers and download the appropriate driver.

  6. ha14
    May 8, 2013 at 8:54 pm

    is there any windows 7 driver for your USB Network Adapter? if not then use the vista driver but install it under windows comptability.

    uninstall the driver from device manager

    1) Download the driver
    2) Right Click the driver installation file and select Properties/Compatibility Tab. use the vista one
    3)Click Apply/OK.
    4)Right Click the file and select the Run As Administrator option to install

Ads by Google