Why is my PC having hardware problems after the BIOS was reset?

Osama Javaid March 1, 2013

My PC was at repair shop for BIOS resetting. After repairing I brought it home but since then I am having some issues, I am posting these together because they all appeared simultaneously after repair.
It turns OFF for 2-3 seconds during boot up but then starts again automatically and then keep operating normally.
Secondly, sometimes it don’t detect the internet connection. After restarting 2-3 times, it detects it.
Third, the PS/2 port is not working.

  1. Jan Fritsch
    March 2, 2013 at 12:08 am

    I am starting to think that you may have damaged your motherboard beyond repair with the failed BIOS upgrade.

    PS/2 should be connected before the system is powered on. If the PS/2 port is enabled within the BIOS and not working I would say that it is damaged, dead, simple as that.

    As for the network issue I assume it is an onboard NIC of the motherboard?
    If I understand correctly the network only works if you reboot the system without powering it off in between (restart via Start Menu). This further makes me believe that the NIC is having trouble being initialized within the time it takes to boot up.

    Go into the BIOS and enable the "Wake on LAN (WOL)" or "Wake on Magic Paket" option. This way the card should remain in an initialized state even then you shutdown the system.

    If you do want to perform another BIOS flash make sure to use the recovery BIOS update (.BIO)

    Beyond that I would say the only thing left to do is the suggested reinstallation of Windows and after that an exchange of the motherboard.

    • Osama Javaid
      March 2, 2013 at 7:18 am

      Actually you are not getting my point,
      I had a (bad) habit of updating BIOS. My computer was fine until BIOS version 0048, but when I updated to version 0099 (THE UPDATE WAS SUCCESSFUL, I GOT BIOS FLASH SUCCESSFUL MESSAGE) , after next reboot which happens after successful update, system was unable to boot from any hard drive, windows CD or USB...Then I took it to repair shop and they restored the very old factory version of my BIOS. Now this time I only updated to the safe version which was version 0048 for me. But these 3 problems are there since the PC came back
      1. PS/2 port causes the mouse and keyboard lights to light up but they never work on this port.
      2. System never detects an internet connection on boot up, only detects it on a restart.
      3. It turns itself OFF for 2-3 seconds during boot and then starts again normally. (This only happen on boot, never on restart)

    • Jan Fritsch
      March 2, 2013 at 1:47 pm

      Since the issues started following the update then some corruption did happen at that point, regardless of the success message. Especially GUI tools running within Windows are not to be trusted in that regard. Any "not successful" message would triggers the BIOS to roll back to the previous version.

      Either way, the suggested method is to perform a recovery update to the latest transitional version (0099) and then upgrade to the latest one available (0111). Also be aware of any jumper settings necessary for a recovery update and normal boot later on.

      (1) Your keyboard lights going on means that the device was detected. Therefor it's (a) an issue at the end of the keyboard or (b) the port. At best try another PS/2 keyboard and try cleaning the PS/2 ports using compressed air to make sure all contacts are free of dust.

      (3) As I mentioned before the power-off for 2-3 seconds usually indicates a BIOS health or hardware check which should not happen during a normal boot after a normal shutdown.
      Assuming you are using the onboard LAN for internet the other issue (2) is most likely related to the first one e.g. a very late initialization of the network chip or change in IRQ causing Windows to redetect the hardware and drivers.

      If you have some power strip with a switch make sure not to cut the power using the switch and then try booting up. If the 2-3 second power-off following by a normal boot up still happens the issue is at the BIOS/board level.

    • osama
      March 2, 2013 at 6:45 pm

      I tried other PS/2 keyboards. They are not working in my PC. I tried my keyboard on another computer, it was working on the other PC. It means problem is at my PS/2 port which i repeatedly cleaned. As u suggested, i didn't cut the power from the wall outlet after shutdown. Now the 2-3 seconds OFF not happened on the next boot. It only happens when I cut power from power outlet after shutting down. What's the diagnosis now?

    • osama
      March 2, 2013 at 6:45 pm

      I tried other PS/2 keyboards. They are not working in my PC. I tried my keyboard on another computer, it was working on the other PC. It means problem is at my PS/2 port which i repeatedly cleaned. As u suggested, i didn't cut the power from the wall outlet after shutdown. Now the 2-3 seconds OFF not happened on the next boot. It only happens when I cut power from power outlet after shutting down. What's the diagnosis now?

    • Jan Fritsch
      March 3, 2013 at 4:10 am

      There is not much to diagnose based on this ~ basically you already gave the answer to yourself.

      You are looking at a defective PS/2 port on your motherboard. There is nothing you can really do about it. You could try soldering a new PS/2 connector on but the chances are high of permanently damaging the motherboard all together.

      As for the power-off it is ~ as I tried to explain before ~ the intended behavior. Cutting the power form the outlet usually indicates that you are about to perform hardware changes e.g. exchanging RAM or something. Therefor if a full power-outage (or unplugging from the outlet) is detected the motherboard starts up doing a hardware check which takes a second or two, then powers off for the mentioned 2-3 seconds and then boots up normally. Since this diagnostic power-on-off doesn't happen if you keep the outlet plugged in it is working as it should.

    • Jan Fritsch
      March 3, 2013 at 4:17 am

      Sorry, cut myself short there:
      Basically the only thing that's left is the networking issue. I would start with the basics there.

      Download the latest driver for your network card, then go into the Device Manager (Start > Search "Device Manager"), navigate to the network interfaces and delete it ~ it should be something like "Intel 82xxxx Gigabit...". Then in the Actions menu select to search for new or changed hardware to re-detect your network card.

  2. susendeep dutta
    March 1, 2013 at 3:03 pm

    Then ask your shop to send your motherboard to Intel for repair or replacement as this seems to be beyond the capacity of the shopkeeper.Intel has reputation of sending boards directly to home quickly.

  3. Alan Wade
    March 1, 2013 at 7:19 am

    I would go with Jim's suggestion otherwise you could end up spending a lot of time error searching the problems you are having which maybe, and I do say maybe, a different BIOS version could correct.
    The shop should have checked your machine for any further problems before releasing it back to you.

    • Osama Javaid
      March 1, 2013 at 11:23 am

      it all started when I tried upgrading my BIOS from version 0048 to 0099 for my Intel DH61WW notherboard. System ceased to boot up and I had to take it to repait shop. They restored BIOS to very old version. I again upgraded to the one which was working fine for me before (0048) but now I am not gonna update it to 0099 at any cost.

  4. Jim Chambers
    March 1, 2013 at 3:19 am

    Take it back to shop and have them fix it to your satisfaction. If you don't what to do this, check all connections such as memory, video card etc. as some cases flex when moved. Go into Bios setup and reset to default or optimum settings and save. Check PS/2 port for bent pin.

    • Osama Javaid
      March 1, 2013 at 11:21 am

      done , problem NOT solved

    • Jim Chambers
      March 1, 2013 at 6:13 pm

      If the Bios Chip is a socket mount type rather than soldered on motherboard, try carefully removing and then reseating it preferably after using contact cleaner spray. Make sure to plug it in in correct orientation.

  5. ha14
    March 1, 2013 at 12:47 am

    unplug from wall, remove cmos battery for 15min, then reinsert cos and replug to wall, boot again.

    do a memory test

    Run Diagnostics to Check Your System for Memory Problems

    check your graphic card is well attached to the motherboard

    try to update drivers and repair windows.

    • Jan Fritsch
      March 1, 2013 at 3:30 am

      The power-off followed by powering up normally after 2-3 seconds usually means that the BIOS performed some health and/or hardware check and can usually be seen after a full power outage.

      If that happens at every boot I would say something prevents your BIOS from saving it's state in the CMOS. My advice would be (as ha14) suggested to unplug and remove the CMOS battery for a few seconds and then reinsert it.
      If your BIOS has a reset button or jumper (see hardware manual) perform this too once the battery is back in place.

      Since you cleared the BIOS settings your PS/2 port should be working too now. But since you are booting up anyway you can hit the BIOS key (usually DEL) and make sure the PS/2 port is enabled.

      As for the internet connection you'll have to be more specific how it is established in order to get better troubleshooting advice. Are you connecting to a local network or WiFi or is it some dial-in or logon directly through the modem?

      Either way, it may be solved with the initial error too. Since your BIOS doesn't appear to save it's state there is a chance that some change in hardware IRQs happens and forces the operating system to redetect the hardware on every startup. Another possibility is that the hardware check causes the network card to initialize at a very late state.
      Both would obviously delay any attempt to establish a network connection which depending on the extend of the process(es)
      could take several minutes.

    • Osama Javaid
      March 1, 2013 at 11:18 am

      I unplugged CMOS battery and all hardware components and power cables. Kept the computer in this state for several minutes then replugged all components. BIOS time was reset which means that BIOS was clear. I restored the BIOS to default settings and correct the system time and date and booted. One or two times there was not any power off during boot but now it started again. I also checked that PS/2 port is enabled in the BIOS but that port is still not working. I connect to internet via DSL. During normal boot, there is a red cross on the taskbar network icon which means i am disconnected. No matter how many times I shut down and boot up it stays this way. It only connects when I restart the windows from start menu.

    • ha14
      March 1, 2013 at 11:37 am

      check in BIOS Legacy USB support and activate.
      unplug mouse and keyboard and plug them when OS boot.

      Keyboard and mouse not working in Windows

      go to winndows update and see if there are updates available or use a driver scan tool like DriverEasy

      How To Reinstall Windows 7 Without Changing Your Personal Settings, Installed Programs & Drivers

      perhaps you want to consider repair windows 7.

      1) Click start
      2) Type services.msc in the search bar, Open services.msc
      3) Search DNS client and DHCP Client services and start the services to automatic if they are stopped.
      4) Network Connections >> set to manual
      5) Network List Service >> startup manual
      6) Network Location Awareness >> startup to Automatic
      7) Network Store Interface Service >> startup to Automatic

      reset TCP/IP, use microsoft fix it

    • Osama Javaid
      March 1, 2013 at 11:51 am

      all are at their default settings which u told me

    • ha14
      March 1, 2013 at 12:25 pm

      consider to repair/install windows, if you already made a backup image then use it. fresh start can fix problems.

Ads by Google