Why is my laptop battery not charging?

MOHSIN RAZA June 22, 2013

During charging of my laptop battery it says plugged in, not charging. What should I do now? I am using Windows 7 Home Edition.

  1. Lisa P
    October 14, 2013 at 8:26 am

    There are multiple solutions proposed, and here are the steps that fixed it for me:

    Disconnect AC
    Remove battery
    Connect AC
    Under the Batteries category, right-click all of the Microsoft ACPI Compliant Control Method Battery listings, and select Uninstall (it’s ok if you only have 1).
    Disconnect AC
    Insert battery
    Connect AC


  2. HCM
    June 29, 2013 at 10:00 pm

    Sounds like the battery is on it's last breath. Try putting it a freezer bag and freeze it over night then try charging it.

  3. Dan
    June 29, 2013 at 10:56 am

    I had a Compaq a few years ago where the charging port was apparently in a hot area of the computer. (Yes the plastic on the tip would show signs of melting.) I tried a new charger, and found the reviews on the chargers showed a high failure rate. The problem was probably heat buildup at that area, not the design of the charger. I was able to charge the computer, but only when it was turned off and not generating heat. Have you tried charging when the computer is turned off?

  4. pahaysaz
    June 25, 2013 at 1:09 pm

    It is normal for most modern systems to show "Plugged In. Not Charging." in the top range of their battery capacity. When they get to about 93-95 percent, they automatically start charging. It blew my mind until I saw it work the first few times. It is quite normal!

  5. Jaypee Cruz
    June 25, 2013 at 6:23 am

    they say prevention is better than cure.. .. .. if your battery is not recharging may be you haven't prevented losing its battery life loss during overcharging.. .. and other factors like proper storage and discharging it.. .. now you're at the curing stage of buying a new one.. .

  6. Paul Prakash J
    June 25, 2013 at 5:44 am

    This also happens when a compatible battery is installed rather than the vendor supplied original. I am currently struck with similar problem. My battery won't charge beyond 10%, irrespective of how long it is plugged in. I already checked the power cord, no problem there.

    Better replace the battery.

  7. Degenerated S
    June 25, 2013 at 5:16 am

    yeah ....Its the end of battery life.... I have a battery which gets stuck at 7% of charge and wont charge anymore ....I have tried changing power adapter , but no results , so I guess u need to replace it!

  8. Ethan Wong
    June 25, 2013 at 4:31 am

    Hello, recently since my laptop charger became unusable due the the cord getting twisted i bought a universal charger last Christmas. IT was working perfectly fine until about 1-2 months ago when occasionally it would cut out. at first i thought nothing of it until it stopped charging unless i pushed the charging head into the laptop with a little bit of force. so i decided to take the charger out and look at it and i notice that the little charging jack that is meant to be in the laptop was in the actual charger. i was not able to get the jack out and it is really stuck there, and now i cannot charge the laptop. Do you guys have any suggestions to what i should do ? also i was looking at the charger and i jsut noticed that its american and i have been using it with an australian 240V powerpoint. :(

  9. PseudoChris
    June 24, 2013 at 9:01 pm

    If it's more than 1-2 years old then buy a new battery.

    Also, make sure it stays powered on without the battery installed when the AC adapter is plugged in. If it doesn't it could be a problem with your DC input jack/soldering.

    • Ethan Wong
      June 25, 2013 at 4:15 am

      hey chris im just wondering what i should as last christmas i bought a universal charger and it has been working fine till the last month or two, it would occasionally stop charging, so i looked at it then i noticed that the dc input has come out and is stuck inside the universal charging head really not sure what to do :L ??

  10. tgv
    June 24, 2013 at 8:35 pm

    i suggest first to have a volt-meter and check if you have the proper voltage at the end of the charger. if not, then blame the cable. (this happened yesterday to me).
    second: if cables are ok then must be the battery. if so you must replace (i didnt test ha14's solution).
    batteries are made so if their voltage is lower than a certain limit then they cannot be recharged, and this is a Big Problem :(

  11. danielooi
    June 24, 2013 at 10:19 am

    If you been using your lap top for a few years, it is probably that the battery life has ended. However a faulty power adapter also might caused this issue, you can try charging a known power adapter first.

    • ha14
      June 24, 2013 at 6:25 pm

      quite right:) possible that battery need to be replaced

  12. DalSan M
    June 22, 2013 at 8:19 pm

    I don't know if it matters whether your laptop is upside down or not for this, but if ha14's suggestion doesn't work, then press the power button for at least 30 seconds while the battery is out. This supposedly does a power reset (hard reset) on laptops and may allow you to charge the battery again. http://www.ehow.com/how_4450822_hard-reset-laptop.html?dmsp=manual

  13. ha14
    June 22, 2013 at 7:02 pm

    1) Unplug battery
    2) go to device manager
    2) locate Microsoft ACPI-Compliant Control Method Battery it should be under battery
    3) right click on it and choose uninstall (do not delete)
    4) Shutdown, replug battery
    5) Reboot

    How To: Proper Power Cycle Procedure for Laptops

    • null
      June 24, 2013 at 8:00 pm

      Hi, ha14.
      Just tried it. Didn't work for my Acer...maybe this battery just ran out.
      One more thing: on your post, on 3rd step, is it really uninstall?

      Thanks! :)

    • ha14
      June 25, 2013 at 8:34 am

      well it is uninstall, since you do not delete the driver then upon reboot windows will reinstall the driver. If you uninstall and delete the driver then upon reboot windows will not install the driver since driver setup is missing, you have to download from the net the driver to install;

Ads by Google