Why is my Kingston 4GB pen drive not detected on any PC?

pankaj parihar June 16, 2013

I am using a Kingston 4GB pen drive. When I connect it on any PC there is no action. The power light of the pen drive blinks, but never shows an icon or any action on any PC.

I have tried it on every PC, but the pen drive is not detected. I have tried to find it by device manger, but couldn’t get it. What else can I do?

  1. susendeep dutta
    June 28, 2013 at 3:45 pm

    If your pendrive is not at all detected by any PC,then perhaps it has been damaged.

    Makeuseof also has discussed similar question.Try solution listed in the link below -

    [Broken Link Removed]

  2. Lisa Santika Onggrid
    June 20, 2013 at 7:20 pm

    Is it new? Or it used to be working fine? Do ha14's instructions first then tell us the results.

  3. Adil Farooq
    June 19, 2013 at 6:47 am

    May be it have some kind of hardware lock located on any side of your USB and you have locked it just move that button and it will be shown in your pc.

  4. Oron Joffe
    June 17, 2013 at 9:45 am

    If nothing at all shows up on device manager, then the drive is probably corrupt. But just in case, disconnect the drive, download USBDeview and with it, track and remove all past instances of that drive. Now quit USBDeview and plug the drive back in, you may be in luck!

  5. Phill Duplessis
    June 17, 2013 at 6:24 am

    It seems that your pen drive has some hardware issue so that you are unable to see it on any PC or in Disk Management.

  6. Alan Wade
    June 16, 2013 at 4:31 pm

    Try ha14's solution and if it dosnt work then buy a new pen drive!

  7. Riffy Campo
    June 16, 2013 at 12:26 pm

    your drive is not working maybe or something is corrupted on it. be sure to put it correctly or maybe your computer has a problem with it

  8. Sonesh Lakhani
    June 16, 2013 at 11:40 am

    May be your pen drive is corrupted

    Get a new pen drive

  9. ha14
    June 16, 2013 at 10:36 am

    1) go to start then run type cmd
    2) right click on cmd and choose launch as administrator
    3) type diskpart hit enter
    4) type list disk hit enter
    do you see your usb key there?

    • Hema Sai
      August 9, 2013 at 1:50 pm

      Then what i do???

    • Hovsep A
      August 9, 2013 at 10:11 pm

      if you don't see in diskpart it can mean that your USB key is corrupted, you can try on another pc, linux, mac? if it is detected there then do format there.

Ads by Google