Why is my grandson’s HP Touchpad not charging even a new charger?

Anonymous September 7, 2013
Ads by Google

I Bought new Touchpads for my 2 grandchildren Christmas before last. One of the Touchpads I couldn’t charge but after purchasing a new charger made for the HP Touchpad it charged fine. I noticed that when it was fully charged the round plug that plugs into the wall that the USB fits into was warm (almost hot). I bought another charger for my other grandson’s HP Touchpad and have it at my house now. When I plug the charger into the Touchpad, I see the two lights in the lower button flashing back and forth, but it still is not charging or turning on. I also noticed that the round socket is not even warm when plugged into the wall socket. I have reset the round socket to no avail. I have pushed all the buttons at the same time without the Touchpad rebooting and turning on. What can I do now?

  1. Tim B
    September 10, 2013 at 2:10 am

    I have a TouchPad that's had problems with battery and such too, but I don't really use it these days so I haven't sorted it out. The last time I did get it going (before forgetting about it again) was after leaving it plugged in for a very long time. So I'd suggest you try that, but I'm also assuming you probably have.

    It's also worth remembering that they're really quite poorly built and were firesale'd for a reason, which is something I've come to accept with mine.

  2. Bob R
    September 9, 2013 at 6:22 pm

    Tried most of these solutions to no avail. This morning I unplugged everything, rebooted the round AC plug-in and hooked it back up to the Touchpad. I then got the tracing of a battery with a question mark on the inside showing on the screen. Nothing happened in 2 hours so I began pushing buttons again to no avail. What does the picture of the battery with the ? in it mean?

    • Bruce E
      September 9, 2013 at 10:32 pm

      I had the same thing happen to my TouchPad nearly a year ago. I have no clue what the image means, but I just left it plugged in for about a week since I didn't need it for anything at the time anyway and it started working again the next time I needed it and tried to power it up. Haven't had another problem with it since. The problem started after the battery had fully discharged though.

  3. Hovsep A
    September 8, 2013 at 8:25 am

    HP TouchPad Not Charging? Don’t Worry, It’s Probably Not Bricked!

  4. Dalsan M
    September 8, 2013 at 6:14 am

    Try some of the suggestions in this thread: http://forum.xda-developers.com/showthread.php?t=1381564. There are to many to list here, but there isn't a "one-size fits all" solution for your situation. You could try holding the power button for at least 30 seconds (close to 1 minute or so may be better), then try plugging it in for a while, and then press the "card" (home) button and power button at the same time, holding it for at least 30 seconds. If that doesn't help, try holding the power button and repeatedly press the home button. Again, there are many more suggestions provided in the link, but results so vary greatly.