Why is my external hard disk not recognized?

Joses Lemmuela June 5, 2013
Ads by Google

Two days ago, when I was copying my ‘entire’ files to the external HDD, I accidentally dropped (damnit!) the drive from about 2.5 feet down, yet surprisingly nothing happened and the files kept copying and finished it.

Then, yesterday, I disconnected the drive without ejecting from Windows first when I was installing a certain printer driver (likely irrelevant, though). Then, when I tried connecting the drive again, it was recognized as a new drive and Windows asked it to be formatted! Of course, I didn’t do it at first, then I disconnected and connected again, and it now doesn’t show up anymore.

External HDD: Western Digital MyPassport 1TB 0748

If I try to connect the drive, Windows will recognize something is connected with a bell sound effect, then the drives turn on, and spins. The only outside difference from before now is that the white light keeps blinking. There is NO noticeable weird noises (like clicking noises), the drive spins normally.

It won’t show up in Explorer/My Computer, but it shows up in the Device and Printers as “My Passport”, and in Device Manager as “WD 0748 something”. If I open Disk Management, it will usually hang and not display anything except the Loading Virtual Data Service… at the bottom.

Sometimes it loads, and displays the drive as “Disk 2”, with no size and if that happens, there is an “initialize” menu when I right-click. If I try to safely disconnect the drive via Windows eject, it’ll fail to eject, and somehow it shows in My Computer/Explorer, as drive G:. But then if I try to click it Explorer will fail and not respond. And then the only way to turn off the drive is by disconnecting it physically (Not even shutting down the Windows work as it seems like my PC still sends power to the USB on standby!).

I have tried a few Data Recovery Programs, yet they fail to recognize the drive. I tried assigning a partition, and it didn’t work. As far as physical goes, I haven’t really tried anything except connecting the drive to my sister’s computer, which also didn’t recognize it.

I learned my lesson the hard way, I will never forget/postpone to back up again. But my luck still sucks, as it is the final step of finishing the comp, and I was going to back up THIS WEEK (for the first time in my life) anyway. And also, the drive is very new, bought in May. As for how valuable the data is… It’s about my lifetime of data from when I started with my second computer.

Since the drive is still spinning, I hope I can still revive it. As for data recovery company, I simply don’t have the money for that.

Thank you for reading, and thanks in advance,

  1. dhanunjayarao chunduri
    June 6, 2013 at 2:30 am

    The file system of the HDD has been currepted this is the reason for your problem. If you want to recover your data,boot from a linux live cd and then try to recover the data if it won't work then try with wonder share live boot cd 2012 this may solve your problem.
    Don't forget to reply.

    • Joses Lemmuela
      June 9, 2013 at 10:04 am

      I tried booting from a Linux Live CD, but it still doesn't recognize it :( If the file system of the HDD had been corrupted, can it(the file system) be fixed? As with WonderShare Live Boot CD, I'm a bit hesitant to try it too. Does it have a special feature that other back-up programs don't have?

      Thanks for the response,

  2. ComputerRepair89 .
    June 6, 2013 at 2:12 am

    This might help. Family friend had same issue and quick google search helped out. my grammar sucks or I would just tell you how to do it, but i feel you better understand the two links below then my words over the internet. also if this fails to help you uninstall the printer driver and then reboot and try plug in hdd again if the two links DO NOT HELP YOU

    First link describes the issue but fails to show you how to replace the files if there missing


    second link below this text. someone asked how to replace the files and one user tells him how to


    Hopes this help sorry for the bad grammar.

    • Joses Lemmuela
      June 7, 2013 at 6:53 am

      (Un)fortunately, both the usbstor.inf and usbstor.pnf is present, and I even overwrited them from the folder by which you gave from the second link. As for uninstalling the printer's driver, do I just go into the Device Manager and uninstall from the specific printer?

      Thanks for the response,

  3. Brandon Ragoo
    June 5, 2013 at 5:21 pm

    Sounds like an hardware issue to me. Try booting into Linux format it , and use it once it works well in Linux you could try using Windows again and should have no issues. If it fails to work in Linux also and gives error messages then its got to be hardware issue. Somehow based on the info you told me I thinking hardware issue is the problem.

    • Joses Lemmuela
      June 9, 2013 at 10:00 am

      I tried booting off a Linux live CD, the file manager and GParted doesn't detect it. So then, is it a hardware issue? If is it, what kind of hardware issue?

      Thanks for the response,

    • Brandon Ragoo
      June 9, 2013 at 4:07 pm

      To my knowledge it definitely is an hardware issue then. You cold listen to the hard drive if it spins and see if it makes any noise which sounds like a slack screw but based on the information you posted you said you already tried that. The other way to determine what is the hardware issue will be to open the hard drive which I will not recommended. If you still have warranty on it I will recommended you return it to the store and see if you can get a new one.

    • Joses Lemmuela
      June 10, 2013 at 4:03 am

      I definitely listened to the drive for a minute, it's (probably) spinning normally. I still think somehow that the failure is not on the head/platter. Of course, I'm not crazy enough to go and open the drive, that's basically suicide o.o And also, I want the data back, more-so than a new drive, since, well, it's >>5 years of my data<<.

      Thanks for responding,

    • Brandon Ragoo
      June 11, 2013 at 1:14 am

      I don't know of any way to recover data from your hard drive at this moment since nether Linux or Windows seems to detect the hard drive, however in the world of technology I believe nothing is impossible, however you may have to look into some advanced methods, I didn't get time to read this article yet but probably it may help you based on the name of the article. Have a read when u get time and let me know if this article helps or any other method u discovered http://www.popularmechanics.com/technology/how-to/tips/4294038#

  4. Degenerated S
    June 5, 2013 at 4:25 pm

    yeah. I have a western Digital portable drive and it had the same problem, I opened my drive from a liinux OS and copied all my files and then I formatted the Drive and now it works fine

    • Joses Lemmuela
      June 9, 2013 at 9:56 am

      Unfortunately for me, it still doesn't work in Linux :( Neither the default file manager or even GParted recognizes the external drive(Although like Disk Management, GParted hanged when trying to find the drive).

      Thanks for the response,

  5. Oron Joffe
    June 5, 2013 at 4:23 pm

    Sounds to me like the problem was caused by not dismounting (ejecting) the drive properly rather than mechanical damage. Try Partition Recovery (http://www.partition-recovery.com/) or similar application to recover the file system.

    • Joses Lemmuela
      June 7, 2013 at 6:39 am

      I tried the program, but it's stuck loading the devices. :(

      Thanks for the response,

    • Joses Lemmuela
      June 7, 2013 at 12:07 pm

      I got it to run, and it somehow recognized the HDD as not ready, and showed options to fix the MBR. So I tried that, but nothing happened. But at least, it's now showing in Disk Management and several other programs that hanged before.

    • Joses Lemmuela
      June 5, 2013 at 2:26 pm

      When trying to open the program, it showed this:

    • ha14
      June 5, 2013 at 2:58 pm

      it can be your antivirus/firewall blocking it to connect to internet so disable them to run the solution;
      or right click on it and choose run as administrator

      1. Go to run and type cmd then right click on it and choose run as administrator
      2. type DISKPART and hit enter
      3. type : LIST DISK. This will show you all the connected disk with the offline one. qee if yours is offline!
      4. Now select the offline disk using the next command SELECT DISK wheredisk_no is the offline disk number which you can get from step 3 result.
      5. Now you have selected the offline disk. Now enter command ONLINE DISK.

    • Joses Lemmuela
      June 7, 2013 at 5:11 am

      I tried it again today, and somehow without changing anything, it runs. But it seems like I'm stuck in 'Detecting Problems'.

      As for the cmd part, if I have to plug in the external HDD, it simply hangs after the DISKPART command. It won't allow me to type anything more after that, so I can't even command LIST DISK D:
      This is the log, by the way:
      Microsoft Windows [Version 6.1.7601]
      Copyright (c) 2009 Microsoft Corporation. All rights reserved.


      Microsoft DiskPart version 6.1.7601
      Copyright (C) 1999-2008 Microsoft Corporation.
      On computer: VAENIR-INPROTO0
      _ <--Stops right here

      Thanks for the response,

    • Joses Lemmuela
      June 7, 2013 at 12:04 pm

      Somehow I got the DISKPART to run. I followed the steps, and it found that the disk is already ONLINE. Even if I try to make it offline, cmd would say a I/O Device error. This is the log:

      Microsoft Windows [Version 6.1.7601]
      Copyright (c) 2009 Microsoft Corporation. All rights reserved.


      Microsoft DiskPart version 6.1.7601
      Copyright (C) 1999-2008 Microsoft Corporation.
      On computer: VAENIR-INPROTO0


      Disk ### Status Size Free Dyn Gpt
      -------- ------------- ------- ------- --- ---
      Disk 0 Online 931 GB 0 B
      Disk 1 No Media 0 B 0 B
      Disk 2 Online 0 B 0 B


      Disk 2 is now the selected disk.


      Virtual Disk Service error:
      This disk is already online.


      DiskPart has encountered an error: The request could not be performed because of
      an I/O device error.
      See the System Event Log for more information.


    • ha14
      June 7, 2013 at 9:46 pm

      try Western Digital Data Lifeguard Diagnostic for Windows

      HGST Windows Drive Fitness Test (WinDFT)
      never tried it myself

    • Joses Lemmuela
      June 9, 2013 at 10:23 am

      Both doesn't detect the drive :( I'm starting to give up on recovery by software, perhaps it is really a mechanical problem? I'm sorry for asking so much, I'm just really desperate to salvage the data inside the drive.

      Thanks for the response,

    • ha14
      June 9, 2013 at 10:56 am

      well the thing is as i understand Bios through diskpart can see your hard drive, but windows in computer do not show it to you. You can try to uninstall the driver from device manager while leaving the hard drive plugged reboot so that windows install the driver. The problem is that in this case it is possible that the hard drive will not be recognized by windows since there are some problems????it is up to you to decide to go this path.

      now you can also try to use another pc to see if the hard drive can be recognized there.

      there is also hirensbootcd with minixp inside, download and burn and boot on it
      check if it can be recognized by minixp, in this case you can save your important files to another place.

      if it is hardware problem well you can buy the same hard drive and use the case for your the disk.

Ads by Google