Why is my 16GB USB drive showing as 8GB after formatting?

Happy Singg December 11, 2012

I have recently purchased a brand new Strontium USB 3.0 Jet USB drive. I was just trying to format the drive using some utility, but as soon as I formatted the drive it turned to an 8GB spaced drive instead of the 16GB drive I purchase. I am unable to restore the drive back to it’s actual size, even after using the Jet USB firmware as advertised on the official website.

Does anyone know how I can recover the space I have lost? Urgent help required please!

  1. Joel Thomas
    March 24, 2013 at 9:37 am

    Its really Simple actually
    In my computer
    Right click your device and click format
    when the box comes
    change space to 16 gb
    and partion type to nfts
    after formating you get your 16 gb intact

  2. Duy Nguyen Minh
    December 14, 2012 at 8:26 am

    USb is enough 8GB. Format fix it. restore it.

  3. Duy Nguyen Minh
    December 14, 2012 at 8:26 am

    USb is enough 8GB. Format fix it. restore it.

  4. Thehunting Lion
    December 13, 2012 at 7:13 pm

    probably might be a fake one or try your luck using better partition handling software like 'gparted' in ubuntu

  5. Ahamed Yaseen
    December 12, 2012 at 2:56 pm

    It may be duplicate... and can try using usb disk format tool....

  6. Sashritha Peiris
    December 12, 2012 at 3:13 am

    If on mac try CleanMyDrive

  7. Hans ??? ?
    December 11, 2012 at 7:50 pm

    Either you accidentally formatted it wrong (8GB size) or it contains a hidden security part of 8GB. I use the HP formatting tool to reset the USB Flash drive: http://www.softpedia.com/get/System/Hard-Disk-Utils/HP-USB-Disk-Storage-Format-Tool.shtml

  8. Abba Jee
    December 11, 2012 at 7:26 pm

    Did your recently purchased USB drive showed you 16 GB space once or it's on box?

  9. Rohit Pandey
    December 11, 2012 at 6:39 pm

    formatting problem with different type of partition..........

  10. Jitendra Adhikari
    December 11, 2012 at 6:34 pm

    Try formatting it as NTFS and not FAT32.

  11. Stephen Stephens
    December 11, 2012 at 5:09 pm

    PS Using the windows format drive option will be useless if somehow there was more than one partition created on the flash drive. Trust me, i had this problem myself a week or two ago when trying to install a FreeBSD distro on one.

  12. Stephen Stephens
    December 11, 2012 at 5:08 pm

    I'm not quite sure what the issue is exactly, but it doesn't hurt to do this.

    Download a partition manager (i think this is the one I used)

    Install it, run it, open up your new flash drive. check to see if there's two partitions on it. if so, remove them both. Apply, safely eject, plug back in and see if it works. Good luck

  13. Anonymous
    December 11, 2012 at 4:15 pm

    You cannot "lose" any storage on an USB, install and try this first: https://www.sdcard.org/downloads/formatter_3/. If this isn't working then one of the
    flash memory chips or the USB controller is probably broken.

  14. Roomy Naqvy
    December 11, 2012 at 4:03 pm

    How can anyone lose space in a USB drive? Try to format it. Command prompt should help too. Else, it isn't a genuine USB.

  15. Naval Gupta
    December 11, 2012 at 2:55 pm

    1. Ensure that the usb port has the correct drivers installed for reading usb3.0
    2. Try to format the drive on another computer
    3. In case the above does not work, then best option would be to avail the warranty


  16. Ahmed Musani
    December 11, 2012 at 2:30 pm

    You might not have formatted it in the correct format. which format did you format in?

  17. pp potana
    December 11, 2012 at 2:01 pm

    may be its a fake version...otherwise you shouldn't face this problem

  18. Alan Wade
    December 11, 2012 at 1:07 pm

    Format it using the in-built Disk Management and let us know the results.

  19. Aniket Singh
    December 11, 2012 at 12:21 pm

    try reformating it with windows ...........if this problem appear same.....try software like partion master pro it may help u

  20. ha14
    December 11, 2012 at 10:08 am

    1. Right-click on computer and select “Manage”
    2. Select “Disk Management”
    3. Right-click on your USB drive and select “Delete Volume”
    4. Wait for volume to delete, then right-click on USB and select “New Simple Volume”
    5. Follow the prompts and it will reformat the USB to your 16GB default.

    command prompt with administrative rights
    chkdsk /f X: (x your usb letter)

    December 11, 2012 at 9:37 am

    You should try command line formatting option.

    Open cmd and type cd..
    until c:\ then type format and drive name
    e.g. format f:\

  22. Douglas Mutay
    December 11, 2012 at 9:16 am

    Try use the Windows format option and select restore default option and see if it help.

  23. Qin Tang
    December 11, 2012 at 6:45 am

    Hi, how do format your USB? Did you use some software? I'm afraid you will lost the other 8GB space.

  24. luis donis
    December 11, 2012 at 6:28 am

    hello can try giving format with HP tool that works great once I step like me I leave it here download here: [Broken Link Removed]

    • Yiz Borol
      December 11, 2012 at 9:49 pm

      This right here is your best bet.
      I bought a Chinese 256GB flash drive for $50 (about 1/3 the normal price at that time and still less than half what is today) after reformatting it showed up as only 32GB (still large but not 256GB) someone suggested the hp program, and it worked like a charm.

    • Âdil Farôôq
      December 16, 2012 at 7:13 am

      Yeah it the best tool for such problems i also tried that and worked for me perfectly fine.

  25. Faizan Aslam
    December 11, 2012 at 5:28 am

    The USB is either not genuine or over heat caused half of it to stop working.

Ads by Google