Why is Airport not working properly on my Macbook Pro?

Amy Wang June 11, 2013

I’ve tried everything: resetting the PRAM, the locations trick by deleting and re-adding, I even held down the power key for 10 seconds, but everything only works temporarily for me.

After a while, my Airport will eventually glitch up and not connect to my WiFi. It’ll ask for my password again and it just shows a ‘connection timeout’ whenever I try to reconnect. I’ve never had this issue before. Does anyone know how to fix this issue?

  1. Oron Joffe
    June 12, 2013 at 3:25 pm

    It sounds like a problem of a currupt preferences file on the Mac. Deleting the preference file, or creating a new "location" (and hence, a new preference file) is probably the solution and these are indeed the suggestions implied in Susendeep's reply.

  2. Jan Fritsch
    June 12, 2013 at 12:36 pm

    Have there been any changes in the WiFi configuration?

    When you are asked for the password make sure to select the proper security option (WEP, WPA, WPA2 ...).

    If there are multiple devices on your WiFi/network make sure the DHCP range is large enough to provide all devices with internal IP addresses. One often loses track with all the mobile phones, tablets, etc. connected to a network nowadays.

    In System Preferences > Network select your AirPort adapter, click the advanced options and remove the network from the preferred network list so no old saved settings override the required ones.

    Finally, wipe all the AirPort and NIC settings off your Mac – go to /Library/Preferences/System Configuration/ and delete the following preferences lists


    Followed by a reboot.

    * You may lose certain settings by doing this. You will lose saved networks.

    You may have to go into System Preferences > Network, click the Add (+) button and add your AirPort NIC manually afterwards. Alternatively you can open up a Terminal window and input "/usr/sbin/networksetup -detectnewhardware"

  3. ha14
    June 12, 2013 at 8:31 am

    Troubleshooting Wi-Fi issues in OS X Lion and Mac OS X v10.6

    AirPort and Bluetooth: Potential sources of interference

    iStumbler Release 99
    will show you Routers around you, and what channels they are using. More than one Router on a channel causes interference

  4. susendeep dutta
    June 12, 2013 at 8:00 am

    Make sure that everything is updated i.e. OS etc.

    Secondly,try the suggestions listed by forum users -

    webgoat -

    you need to be in /Library/Preferences and not ~/Library/Preferences .. with finder active select the go menu and choose go to folder... type in /Library/Preferences/SystemConfiguration and you will see the files... it will require an administrator password to delete them and if you move them to somewhere besides trash it just going to copy them instead of moving them


    jasmurphy -

    1. Enter a new location - remember to go to the TCP/IP tab and Renew the DHCP Lease - seems to work for some.

    2. Delete the contents of HD/Library/Preferences/SystemConfiguration, Empty Trash and Reboot.


    I tried 2 once more but on 'shutdown' then restarted manually. Don't know why but it worked!

    Worth a shot if you don't get anywhere with 1 & 2.