Why has my Canon all in one printer has stopped scanning?

Alan T September 4, 2013

After months of satisfactory use I now get Canon MP Navigator EX has stopped working when I try to open the scan software. I have checked for some common problems but I am now left with a dysfunctional system. Can you help please?

  1. Alan T
    September 7, 2013 at 6:30 am

    Hi all, thanks for your replies. This has been a pain and I have had emails and phone calls to canon. Nothing worked so eventually they sent me to a link I had used before anyway. I looked deeper into the replies. Buried deep in the comments are indications that cloud storage may be a problem. I deleted my "MyCloud" and with it the problem vanished. http://www.youtube.com/watch?v=2Sbb44GhAXU . Problem solved and closed.

  2. Alan W
    September 6, 2013 at 3:45 pm

    I too, like Oron have had this problem and could only fix it by uninstalling all the printer software then running CCleaner to clear any residule reg entries and finally reinstalling all the software again.

  3. Hovsep A
    September 4, 2013 at 8:24 pm

    reset the printer by powering down completely for 60min? the reinstall drivers.

  4. Oron J
    September 4, 2013 at 8:00 pm

    I've had this problem too in the past, but it only occured when I updated Canon's software... If this is what happened to you, try removing EVERYTHING, every last piece of software associated with your printer/scanner, and reinstall, and hopefully it will work. If the problem occured without any change to your software, I suggest you try to get in touch with Canon via their web site and ask for their advice.