Why doesn’t Google Play work on mobile data?

Katherene joan May 5, 2013

Google Play is preinstalled on my Samsung galaxy S5 300 and previously i could download apps from Google Play while on Wi-Fi. But now I’m on mobile data and i can no longer access the Google Play shop’. It loads, but never finishes. What do I do?

  1. susendeep dutta
    May 11, 2013 at 11:38 am

    Even after clearing data from Google Play's app(by going to Settings -->Applications --> Manage Applications -->Google Play --> Clear cache,Clear data),then it must be problem with the slow internet or jitter problem(data packets comes at irregular interval of time).

    Try going to Airplane mode and after 2 mins,switch off Airplane mode.

    If it doesn't helps,then try disabling data by going to Settings --> Wireless and Networks -->Mobile networks --> (untick) Use packet data and Data Roaming.After 2 mins,tick those two fields again for enabling data network.

    If it still doesn't works,then switch off your phone for 5 mins and then switch on and then see whether data network comes or not.

    If still doesn't works,then go outside to place where you can expect some good network coverage(outside your home).

    If these measures doesn't solve your problem,then it must be network problem with your carrier.

  2. Vishal Srivastava
    May 6, 2013 at 5:37 pm

    Here is what I'll suggest you to do-
    1. Check if packet data is enabled or not. This is a common mistake.
    2. Load Play and see if it work.
    3. Check on a WIFI if it works (NOW, previous experience is useless. Check its current state). If it doesn't work, skip to step 6.
    4. If it doesn't work, clear cache and data and try again.
    5. If it still doesn't work, uninstall updates and try again.
    6. In the worst case scenario, uninstall Google Play and reinstall it from Google website.

  3. Chanuka Fernando
    May 6, 2013 at 6:53 am

    maybe u are using only 2G networks and if you are using 3G then go to settings/wireless and networks/mobile networks and tick the usa packet data and go

  4. DalSan M
    May 5, 2013 at 5:40 pm

    You could try clearing the cache like ha14 suggests, but if that didn't work, try to clear the data using the same method, except select Clear Data (would have to sign in again). If that still didn't work, then try Uninstall Updates through the same method. When you start the Google Play Store app again, sign in and update the Play Store and see if it helps.

  5. Chinmay Sarupria
    May 5, 2013 at 2:23 pm

    Maybe your internet speed is too slow. If that's not the case then you can go to their desktop site and remotely install the app from there. It will be downloaded on your device.

  6. ha14
    May 5, 2013 at 8:15 am

    go to google play and clear cache, you will have to register/sign the account again

  7. Junil Maharjan
    May 5, 2013 at 6:02 am

    check the settings and see if you can install and update apps when on mobile data.

Ads by Google