Why does my Galaxy Tab 2 7.0 say “Downloading. Do not turn off target?

Jannah Milcah Agbayani May 12, 2013

My galaxy tab 2 7.0 wont turn on. I tried the holding the power and the volume button. It worked but I accidentally pressed the up volume and now the screen says “Downloading. Do not turn off target” What am I gonna do? Please help me :( I dont wanna lose my tab!

  1. Zmann444
    July 13, 2013 at 1:34 pm

    i tryed but i couldnt find anything im going to have a specialist look at so ill let u know

  2. Harshit J
    May 13, 2013 at 4:38 pm

    You don't need to reinstall the firmware. Just press and hold the power button for sometime and your device will restart.

  3. susendeep dutta
    May 13, 2013 at 6:10 am

    Download Kies software for Windows and then install it.

    After that,go to Tools –> Emergency Firmware Recovery to try to see whether Kies offers you way to recover your tablet.

    Moreover,if Kies detect you tablet and offers you to update(Android 4.1.2) it,then you can be safe to be sure that your tablet would be back with updated features.

    Also,try pressing power+volume down buttons together to see whether the tablet goes into recovery mode.

  4. ha14
    May 12, 2013 at 9:08 pm

    push the power button like for a min?

  5. DalSan M
    May 12, 2013 at 9:02 pm

    It is in "Download Mode", in which it is waiting for an update to install. You can restart your device without any problems. If you did hard reset your device, all information and data may be lost. If you cannot start your device normally, then let us know so we can try to get it working again.You may just have to reinstall Android to your device.

    • neisha
      August 30, 2013 at 1:03 am

      I tried what you wrote have the same issue as the first commentary but every time I try to cut it back on it cuts right back off.

    • Dalsan M
      August 30, 2013 at 5:28 pm

      Try performing a power reset by holding the power button for 30 seconds without it being plugged in. Then place your Tab on a home charger for a couple minutes, then press the power button again for 30 seconds with the charger plugged in. To try to get out of Download Mode, press and hold the power button for around 1 minute. If this does not help, try the suggestions here:

Ads by Google