Why does my desktop POST only after Caps Lock key is pressed?

Anonymous November 21, 2013

All of a sudden a weird problem has come up. My desktop starts up only after i press Caps Lock key. At first it didn’t start at all and i tried a few things like removing components, clearing dust but nothing worked and finally i tried a few keys on my keyboard and caps lock key helped. What is the problem?

Please help. Thanks.

  1. Oron J
    November 23, 2013 at 2:01 pm

    As Bruce says, the first thing to try is a different keyboard. It could be something else, but you have to exclude the obvious first. Let us know how you get on!

  2. Bruce E
    November 21, 2013 at 8:04 pm

    Try testing with another keyboard. If the system will POST without any interaction, the original keyboard itself has a problem (most likely cause).

  3. Hovsep A
    November 21, 2013 at 1:11 pm

    have you tried reset cmos battery, before anything first do a windows restore point also make an image

  4. Alan W
    November 21, 2013 at 1:06 pm

    A little more detail would help out such as which version of Windows do you have?
    Have you ran a Windows Repair?
    How old is your hardware?