Why does my CD-DVD combi-drive recognise CDs but not DVDs?

Michael R August 30, 2013

I have an Optiarc AD5170A which works perfectly for CDs but DVDs are not recognized. The driver seems to be ok, I have tried diagnosing any problems there. Do you think this is a hardware or software problem, and what can I do to fix it?

  1. David C
    September 2, 2013 at 5:07 pm

    Its just because your driver is not properly installed, what I would suggest that go to your CD ROM manufacturer `s website go to support section and find the latest and updated driver of your device then download and install hit. Hopefully this shall solve your issue by updating the latest drive. Thanks

  2. Jan F
    August 30, 2013 at 7:27 pm

    If the DVD only fails to playback it may be driver/software related. If the drive fails to recognize DVDs at all I'm afraid the laser may be damaged.

    Every time you insert an optical media the drives laser is being calibrated for that media type (CD/DVD). Now, when the drive is frequently used (every other day or so) with mostly the same media what happens is that the laser somehow get's "stuck" at a calibration level and stops reading the other media type.

    Personally I had two CD+DVD burner drives going bad within half a year because I used them almost daily for DVD playback ~ CDs were a no-go, DVDs only worked 1 out of 3 times.

    Back to your issue:
    One thing you could try is flashing a new firmware and see if that solves the issue. Of course this comes at a (small) risk ~ if things go wrong the drive may be broken for good.

    You can find stock and tweaked firmwares at the following page.
    Also make sure to carefully read the flashing tutorial

    • Jan F
      August 30, 2013 at 7:32 pm

      Well, I totally forgot that it may also just be a dirty lense. So you could also try to take out the optical drive, open it up (I believe it's only 5 screws at the bottom) and carefully clean the lense of the laser with a cotton bud.

      Don't apply any pressure to it, just carefully go over the lense.

  3. David C
    August 30, 2013 at 1:35 pm

    Its most probably a driver issue try updating the device drivers from hardware manager in the control panel if that dosnt work try to manually un-install the drivers and download the latest driver from the manufacturers site and install them manually.

  4. Hovsep A
    August 30, 2013 at 8:16 am

    CD/DVD Troubleshooter