Why does my Android become unresponsive with a black screen after downloading apps?

keshav prasad March 19, 2013

I have an Android with 4.0 1GHz and 512MB. After downloading apps, its screen goes black and unresponsive. How can I normalise the phone?

  1. susendeep dutta
    March 20, 2013 at 11:51 am

    It seems that your phone's OS becomes unresponsive and hence shows black screen as it's shown in all Linux OSes.Android is Linux based.

    The reason for unresponsiveness may be low memory (512 MB RAM) in which ~386 MB might be available for the user.The play store app might be requiring more RAM during app installation so your phone becomes unresponsive.

    You can normalize your phone by using apps that are light weight,contains no ads.

  2. DalSan M
    March 19, 2013 at 9:48 pm

    Along with what ha14 and Harshit mentioned, I would check which apps are running in the background and see how much memory is left as free. To do this, go to Settings, Applications (or application manager), then go to Running. It will show you the apps that are running and allows for you to stop unnecessary apps to free some memory. Select Cached and stop unnecessary apps from there as well to free up some memory, too. This may help some, but it sounds more like an app is causing the issue, in which stopping the apps from running can help you to find the offending app.

  3. Harshit Jain
    March 19, 2013 at 3:04 pm

    Firstly just download a premium antivirus app trial like AVG, AVAST etc. and scan your mobile. Uninstall the antivirus app after scanning.
    If there are no viruses, then try to remember when did the black screen started appearing.
    If it started appearing after installing any app, then uninstall it.
    If the problem is still not solved then check if there is any firmware update available for your phone.
    If this does not fix the problem, you have two options, firstly to reset your phone and secondly to give the phone to your customer service center.

  4. ha14
    March 19, 2013 at 2:26 pm

    uninstall the application, try to update firmware if new update exist, last option will be hard reset (you will lose files so do backup)