Why does Chrome no longer load web pages on my computer?

Cristián T September 21, 2013
Ads by Google

I’ve been having a problem on my computer all of a sudden and every time I open Google Chrome, it strangely asks for administrator permissions, and when I say yes, then it won’t load any web pages. It doesn’t show any error message, just a grey screen in the window. Also I have League of Legends on my computer and it crashes every 5 minutes and I’m not sure if I can correlate the two problems together but they both started all of a sudden. Other than that, I have no idea what’s going on since I have no clue how to fix this, other than the fact that I’m running Windows 7.

  1. Jorge B
    September 24, 2013 at 5:24 pm

    My girlfriend sometimes has the same problem on Chrome. Have you tried clearing the DNS cache?
    - Start menu, type "cmd" (no quotes) (Right-click and "Run as Administrator", just in case)
    - Type "ipconfig -flushdns" (again, no quotes)

    As for LoL, no idea. Keep looking

    • Hovsep A
      October 6, 2013 at 4:57 pm

      it does work but sometime the problem resides elsewhere.

  2. Susendeep D
    September 24, 2013 at 3:05 pm

    Then first try the below solution linked below -


    If still the basic steps mentioned in the above link doesn't work,then try the suggestion of user -

    deuel1 -

    " type -no-sandbox in the Google chrome shortcut path (target) so it looks like this:

    C:UsersHorowitzAppDataLocalGoogleChromeAppl icationchrome.exe -no-sandbox

    (with a space after exe)
    it worked for me and other people on the net. hope it helps you... "

    This will however disable chrome's sandbox which makes sure that any unstable tab doesn't crashes the whole browser.

    If you are apprehensive of disabling sandbox,then try the below solution by the user -

    chaoz28 -

    "....Click the icon Google Chrome the right click --> Properties --> Find Target --> Then rename the chrome to anything you like. example "working". Easy as that. ....."

    Also,try to clean cache by going to chrome's wrench menu.You can also use CCleaner to clean system wide junk and unwanted files.

    Regarding crashing of your program,try updating your antivirus and perform full scan of your system.Remove unnecessary programs and edit startup items.

  3. Oron J
    September 21, 2013 at 11:10 am

    I think before you go for the radical solutions proposed by Hovsep and Susendeep, you should try clearing your cache (Menu=>Tools=>Clear browsing data...). Make sure to choose "from the beginning of time and choose to delete cookies and cache at the very least. 4 times out of 5 this solves the problem.

    • Cristián T
      September 22, 2013 at 5:05 pm

      I tried that. It doesn't seem to work becuase it won't open webpages.

    • Oron J
      September 22, 2013 at 5:28 pm

      Reading your question again, and Susendeep's thoughful reply, a few things come to mind:
      1. I know it sounds trivial, but have you rebooted your PC?
      2. Try disabling all extensions on Chrome, and see if it works. To do this, right click on the Chrome icon and choose "Properties", then add at the end of the line but just before the quotation marks, --disable-extensions (with a space before the --). Click OK and start Chrome. If it starts OK, it's probably one of the extensions.
      3. You may have malware. Scan your computer with your AV, and with an anti-spyware package (e.g. Malwarebytes Free, which you can download from malwarebytes.org).

  4. Susendeep D
    September 21, 2013 at 10:17 am

    Try following the suggestion of

    Manicipal -

    " I figured out that Microsoft is doing something weird here. For the solutions to rename Chrome.exe to Chrom.exe actually removes some compatibility settings that Microsoft applies to Chrome.exe. If you got to Chrome (Likely something like C:Program Files (x86)GoogleChromeApplication) right click on Chrome.exe > Properties > Compatibility. You may see that "Run this program in compatbility mode for:" is ticked. Likely as "Windows XP".

    By renaming Chrome.exe to Chrom.exe you can go to the campatibility tab again and see this is now unticked and Chrome works fine. So rather than renaming Chrome to Chrom, just untick "Run this program in compatbility mode for" and hit "Apply". Chrome worked fine for me then. ....."

    • Cristián T
      September 22, 2013 at 5:04 pm

      I ran Chrome in compatability mode and now the settings can open, at least. But I can't open webpages like Google Search.

  5. Hovsep A
    September 21, 2013 at 9:52 am

    have you tried to uninstall chrome and reinstall?
    Google Chrome Safe Mode
    How-To: Create a Desktop Shortcut for Google Chrome Safe Mode

    • Cristián T
      September 21, 2013 at 9:07 pm

      I did try to uninstall and reinstall Chrome, but that didn't work. I haven't tried running Chrome in safe mode, but I'll try it when i get home tonight.

    • Hovsep A
      October 6, 2013 at 4:57 pm

      any success in solving the problem?

Ads by Google