Why do I receive “Error code 80070490” when I try to install Windows 7 service pack 1?

Ashwin Divakaran May 26, 2013

I could not install Windows 7 SP1 update for the past few months. I tried installing through Windows Update and also through manual install. It just keeps giving the dreaded error “code 80070490”. I know this can be fixed by a repair or complete reinstall , but i have lost the DVD and i cant find any other alternative.Please Help

  1. ha14
    May 26, 2013 at 9:54 pm

    Error code 0x80070490 when you use Windows Update or Microsoft Update to install updates

    Windows Update error 80070490

    • Rajaa Chowdhury
      May 26, 2013 at 11:45 pm

      The first link provided by ha14 should resolve the issue. If not, then only do windows repair.

    • Ashwin Divakaran
      May 28, 2013 at 9:15 am

      i have tried most of the available methods but in vain...i would rather need a specific fix

    • ha14
      May 28, 2013 at 10:48 am

      you can try to manually install Windows 7 Sp1
      How to install Windows 7 Service Pack 1 – Step by Step

      go to run and type cmd, right click on it and choose run as administrator
      2) on the black screen type: sfc /scannow
      This will produce a file called CBS.log which you can find in %WINDIR%LogsCBS (usually C:WindowsLogsCBS).
      3) now open %WINDIR%infsetupapi.dev.log (c:Windowsinfsetupapi.dev.log)
      4) Look for a line that contains Failed to find driver update or FAILURE(0×00000490).
      sto: Failed to find driver update 'C:WindowsWinSxSxxxxxxxusbvideo.inf' in Driver Store. Error = 0×00000490
      5) Open cmd with administrative rights as above
      enter (pnputil -a INSERT_FILE_NAME_FROM_STEP_3,)
      so it should be something like
      pnputil -a C:WindowsWinSxSxxxxxxxxxusbvideo.inf
      6) reboot and update windows sp1

      How to Reset Windows Update in Vista, Windows 7, and Windows 8

    • Ashwin Divakaran
      May 30, 2013 at 9:08 am

      Service Pack 1 somehow installed but it says "Configuring Service Pack.." and tells " Failure Configuring Service Pack " and reverts changes.

    • ha14
      May 30, 2013 at 9:22 am

      do you get any info in Event viewer? did you install it manually or from windows update, have you tried to install it manually from safe mode?

    • Ashwin Divakaran
      June 1, 2013 at 10:32 am

      i tried downloading SP1 and installing manually but it say Installation cannot continue and displays the same error.And i dont know how to use the event viewer ha14!

    • ha14
      June 2, 2013 at 8:30 am

      1)Renamethe 'Software Distribution folder':
      2) Go to Start Menu and enter: %windir% then press OK
      3) Locate the SoftwareDistribution folder
      4) Right click on the SoftwareDistribution folder and then select the Rename option.
      5) Rename the folder to: SoftwareDistributionOld and press the 'ENTER' key.
      6) Windows will create a new 'SoftwareDistribution' folder.
      78) try to update service pack 1

    • Ashwin Divakaran
      June 11, 2013 at 1:22 am

      Nope ! Still Not Working

    • ha14
      June 11, 2013 at 8:58 am

      are you able to create restore points, perhaps for some reasons i is not possible therefore update fail. Also check permissions on system volume information and take full control.

    • ha14
      June 15, 2013 at 12:26 pm
    • Ashwin Divakaran
      June 18, 2013 at 5:28 am

      Yes I am Able to Create Restore Points and permissions are set to full control for system volume information

Ads by Google