Why do I receive a “RPC:S-5:AEC-0” error when downloading or updating apps on my Nexus 7?

Bumferry H July 30, 2013
Ads by Google

i have just received the new 4.3 update for my nexus 7 (OTA) but have come across a couple of issues.

Firstly, I am unable to download or update my apps as the code PRC:S-5:AEC-0 keeps appearing with the message “error while retrieving information from the server.”

I have followed instruction from another forum which told me to sync my data and log out and then back into my google account.

I did this but to no avail.

I have also deleted cache and data from the google play store app but this still has no effect (upon finding the app again i notice this no longer exists on my list of apps, but I can still access the play store and it shows i am logged in)

I have no idea what i have done wrong or how to fix it.

If anyone can help – please let me know what else i can do short of a full factory reset (or is this my best option?)

  1. Cristena
    August 7, 2013 at 10:19 pm

    I actually found on mine when it started doing this that I had more than one google account on my phone. I took all of them off but the one that I use on my pc and everything started working properly again. I dont know if this will help anyone but look to see if you have more than one account on there.. maybe the phone is just getting confused? either way everything is happy as a clam on my end again! :)

  2. Bumferry H
    July 30, 2013 at 11:30 am

    I seem to have fixed this problem.
    After (somehow) managing to get a rep from Google to call me back, I was instructed to log out of my google account on the devices > turn them off > turn them back on again and sign back into my google accounts.
    As soon as I did this, all my apps began to update as normal and I have had no issues so far.
    If anyone else has issues, this might be your best course of action.

    Thanks you.

    • Hovsep A
      July 30, 2013 at 1:44 pm

      thanks for your feedback, your solution can help others:)

    • Dalsan M
      July 30, 2013 at 9:08 pm

      Glad you were able to sort this out and posted back with your solution. This will certainly help out others with similar issues.

    • Chris Hoffman
      July 31, 2013 at 12:29 am

      I had this same problem and fixed it in the exact same way. Performing a factory reset should also work.

  3. Bumferry H
    July 30, 2013 at 8:58 am

    Thanks Dalsan unfortunately, this didn't work.

    I have tried all of the above and it still doesn't work. I have looked at the link which seems to offer similar instructions - but I am now unable to update apps on both my N4 and N7 since the update to 4.3

    does anyone else have any other ideas?

  4. Dalsan M
    July 30, 2013 at 6:41 am

    Try going into Settings and manage apps. From there, locate Play Store and delete cache. Reboot your device and check to see if you can update any apps. If not, go back to Manage Apps and uninstall updates. Reboot your device and check again. If still no, then go back to Manage Apps and locate the Play Store, then delete data. Reboot and try again. Get back to us if you still have trouble. For more information (this is a fairly common issue with the Play Store), go to this forum: http://productforums.google.com/forum/m/#!topic/mobile/2UKJ7ZyIav0

Ads by Google