Why do I have no connectivity using my Netgear wireless stick?

Adrian Opi January 17, 2013
Ads by Google


I have an old IBM Thinkpad which uses a Netgear wireless stick. It was working fine yesterday but today I cannot for the life of me figure it out. I am getting “Limited or No Connectivity” in Windows XP when checking network status.

So far I have tried:

  • Resetting modem/router
  • The repair connection button (it just tells me it cannot renew IP) in which case I had done a netsh reset for winsock and the catalog which just made the ‘repair’ button say  “the following action could not be completed: renewing your IP address”

I have already looked at many forums and am stumped. Any feedback would be awesome!


  1. Oron Joffe
    January 17, 2013 at 8:01 pm

    "Limited connectivity" means that you have physical access to your router, but have not been allocated an IP address. No connectivity means, well, what is says on the tin - no connectivity at all. Try the following steps:

    1. Check that the device is working (that is, that Windows shows its status as working).
    2. Check for available networks (either using Netgear's WiFi software or Windows's own software if that's how it is configured to work). Can you see your router?
    YES: skp to step 3.
    NO: it could be a problem with the reception (range), interference (other wireless routers with a stronger signal) or a faulty aerial on the netgear stick. Try to figure out which of those it is. If you need further advice, come back to us on the forum.
    3. Try to connect. If it doesn't work, and you still get "Limited or no connectivity", try flushing the DNS cach anbd resetting the IP address as follows:
    a. Bring up the command line by going to Start=>Run..., typing COMMAND and clicking OK.
    b. Type "ipconfig /flushdns" (without the quotation marks) and hit the [Enter] key.
    c: Type "ipconfig /renew" (without the quotation marks) and hit the [Enter] key.
    4. Try connecting again, and repeat stages 2-3 if necessary. If you get nowhere with this, post again on the forum.

  2. Jim Chambers
    January 17, 2013 at 5:57 pm

    Maybe it has failed. Check driver disk or Netgear support site for diagnostic software. Ceck for new driver and install it as well.

  3. Dave Rimmer
    January 17, 2013 at 3:32 pm

    Try turning your firewall off see if you can connect then.

  4. ha14
    January 17, 2013 at 10:23 am

    use windows restore point to revert back to early state where everything was fine.

  5. Jan Fritsch
    January 17, 2013 at 10:11 am

    Does this stick come with it's own connection software/tool or does it work via the Windows built-in Wireless control (taskbar icon)?

    Try reconnecting to the WiFi using the option that applies.