Why do I get “Limited Access” and slow Internet on my network?

Morne v March 14, 2013

I have a D-Link u2750 router. For the past few weeks I have been having this ‘Limited Access’ problem, which makes my Internet extremely slow.

I have tried to reset my router still with no luck.

How can I resolve this? Is it my router, my computer or something else?

  1. Yashodhan Bhatt
    March 15, 2013 at 5:21 pm

    If a simple reset of the router does not work for you then try ha14's post..Its a good one..

  2. Nitesh Badala
    March 15, 2013 at 5:47 am

    your internet services is restricted for the limited users by you network administrator that why you found limited access. or may be due to lower range of your network.

  3. Bruce Epper
    March 14, 2013 at 1:31 pm

    Have you run the Microsoft Network Troubleshooter (Repair button in the connection information dialog) to try to resolve the issue? Have you checked your IP settings? If the DHCP server is no longer functioning properly (had to fix this issue yesterday for a neighbor), you will not get the required addressing information for it to work properly as MS defaults to addresses in a different range than the default 192.168.x.y used by most small networks. If it is only a DHCP issue, you can manually configure your IP settings on the computer and everything should work fine again (as long as the issue is only the DHCP server). In yesterday's case here, I had to replace the entire router/modem.

    Can you successfully ping your router?

    Can you get into the router settings to verfify your LAN and WAN connectivity? In most cases, opening a browser and going to will get you into the router's management tool. It should require a username & password to change any settings but you may be able to get an overview without it.

    Can you ping a server located at your ISP? You don't simply want to try something across the globe if you can't hit something locally. You can try to get ICMP responses from the mail servers or DNS servers first before attempting anything further away. Your response times should be less than 20ms for something this close.

    • Morne v
      March 15, 2013 at 6:09 pm

      I'm an entry level geek, this is too high tech for, thanks for the response though, will work try to unravel it on my own time.

  4. Carlos Remonza
    March 14, 2013 at 12:51 pm

    From my experience, sometimes its just the driver of the network adapter that could be acting up. just go to the device manager and uninstall the network adapter that u have then use the "scan for hardware changes" for the operating system to auto detect and reinstall again the network adapter driver for you. if it asks for drivers, use the one thats being supplied with your hardware.

    • Morne v
      March 15, 2013 at 6:07 pm

      I have 3 network adapter there, how do i know which one is in use ?

    • Carlos Remonza
      March 17, 2013 at 5:56 am

      Go to Control Panel -> Network and Internet -> Network and Sharing Center -> click on the "Change the adapter setting".

      from there you can check which one of the adapter that you're currently using.

    • Morne v
      March 17, 2013 at 1:04 pm

      I tried this, still gives me the 'connection was unsuccessful' error message with the 'limited access' next to my wifi bars. I can connect to the internet however

    • Carlos Remonza
      March 18, 2013 at 5:04 am

      do you have any other devices thats connected to the said router? if the other device also has slow browsing issue than im guessing its either the router configuration or its originated from the ISP.

  5. ha14
    March 14, 2013 at 10:25 am

    How To Resolve Limited Or No Connectivity Errors in Windows

    update driver

  6. susendeep dutta
    March 14, 2013 at 9:48 am

    It happens because of latency.When data packets travel after very long time of time,this phenomena occurs and hence you can't even browse internet.

    Hence,you need to contact your ISP to resolve network issues.

  7. Aleksi Kontkanen
    March 14, 2013 at 8:55 am

    If you are using wi-fi you might want to check your security keys (WEP, etc. WPA2-PSK is recommended with AES encryption) and IP-addresses.

    If you are using DHCP you can reset your router and modem and boot your system at the same time. Try using ethernet cable directly to router and your modem to check if same thing happens.

    Check your wireless network card state to determine speed of your network. If it says 1mbps then there might be problem with wi-fi.
    Did you upgraded your Windows before this problem occured?

Ads by Google