Why do I get an error when launching Explorer.exe in Windows?

Don Blevens May 10, 2013

When I try to launch Explorer.exe to view the files on my system, I get the following error message and Explorer.exe will not launch:

This file does not have a program associated with it for performing this action. Please install a program, or, if one is already installed, create an association in the Default Programs control panel.

If I click on my Computer icon, I can view my files without any problem. It is just when I try to use Explorer.exe – why does this happen?

  1. null
    May 16, 2013 at 3:07 pm

    Check your file associations in registry HKAY_CLASSES_ROOTFoldershell see if there a key and where its subkey "command" points to.

  2. Alan Wade
    May 11, 2013 at 6:25 pm

    You could mark this question as resolved Don :)

  3. DalSan M
    May 10, 2013 at 1:13 pm

    You could try this tool: http://www.tweaking.com/content/page/windows_repair_all_in_one.html. It doesn't always work, but it is with a shot.

    • Don Blevens
      May 10, 2013 at 11:51 pm

      I tried this tool and Bam, it fixed it. Thank You very much. I was about ready to re-install Win7 which I didn't really want to do. -- Fix in, case closed, Thanks to all for your suggestions.

  4. Oron Joffe
    May 10, 2013 at 11:06 am

    You need to restore the Default Associations. If you are using Windows 7 , see the following discussion for details on how to do this -- http://answers.microsoft.com/en-us/windows/forum/windows_7-files/how-can-i-restore-the-default-file-associations-in/c096cd7a-91cd-4460-af4d-f38d7ca54860 .
    Apart from that, it sounds like there's a problem with your PC but start with this and see where it takes you!

  5. Alan Wade
    May 10, 2013 at 9:35 am

    Try running the fixit tool: http://support.microsoft.com/kb/950505
    If that did not solve the problem then logon to a different user account, if you dont have one then create a user account and try that.
    If that solves the problem then your user account is corrupted.

    • Don Blevens
      May 10, 2013 at 10:45 am

      I ran the manual fixit method and it did not fix the problem. I also created a new user and that account was bad as well so it appears my computer is corrupt, not just my account. Thank you

    • Alan Wade
      May 10, 2013 at 10:57 am

      Have you scanned for malware?

  6. ha14
    May 10, 2013 at 8:38 am

    The File Association for your computer is corrupted.
    which version of windows you have?

    try this microsoft solution

    create a new Windows user account and check if this issue occurs with the new user account.

    Fix a corrupted user profile

    try this registry fix

  7. Rajaa Chowdhury
    May 10, 2013 at 2:11 am

    Run sfc /scannow from elevated command prompt (command prompt with admin rights). Go to start accessories, command prompt, right click and run as administrator for elevated command prompt. TThis command will take sometime and when it completes, reboot and check. Issue should get resolved.

    • Don Blevens
      May 10, 2013 at 3:56 am

      Thank you. I did this and it came back and said there was errors but it could not fix all of them and to view the cbs.txt log file. I tried to view the log file but just keep getting access denied. Is there a pgm or install I can run to put good system files back in there???

    • Rajaa Chowdhury
      May 10, 2013 at 5:00 am

      Now you can use the Windows Repair utility. Insert your Windows CD and select the option. Kindly refer to http://www.pcworld.com/article/243190/how_to_repair_a_corrupt_windows_7_installation.html . This will keep all your programs, personal data, and user accounts intact.

    • Don Blevens
      May 10, 2013 at 10:47 am

      I cleaned everything up and then tried to do the upgrade but it won't let me. It keeps saying my version of windows is newer (which, of course, is true) so I will have to figure out another way to re-install the system files. At least I know what the problem is now. thanks you.

Ads by Google