Why can’t my Android connect to my Mac Pro’s wireless hotspot?

Shaurya Mishra April 15, 2013


I have been trying to use my office’s Mac Pro network by creating a wireless hotspot for my Android device. I went through the whole procedure, created a network with 40bit encryption and a 5-letter password but when I tried to connect from my Android device the connection failed as it was unable to obtain an IP address.

What am I doing wrong? Is there anything I need to know about creating a hotspot in Mac OS X 10.7.5? I am using Android Jelly Bean (4.2).

  1. macwitty
    April 26, 2013 at 12:27 pm

    Even if the Internet share say that you should use a 5-letter password for 40bit encryption when share outside the Apple eco system I have found that 13-letter password for 128bit encryption often works better

  2. Anay Chaubal
    April 17, 2013 at 7:39 pm

    lotsa issues with getting an android phone to connect to an ad-hoc wifi connection.
    I had that issue on winXP, but a move to Windows 7 fixed it, since i noticed a friend's computer had Win7 and was able to create a working hotspot.
    So, maybe specifically searching for a solution for this issue on google with the proper mac os version might help you out.

  3. DalSan M
    April 16, 2013 at 8:51 pm

    What kind of wireless connection is your Mac Pro broadcasting? If it is an ad-hoc connection, then stock Android will not connect to it. Rooting the phone and changing the WPA supplicant would solve the problem. Some Android phones will connect to ad-hoc without these changes, but most newer Android phones will not. http://forum.xda-developers.com/showthread.php?t=1591207

  4. justinpot
    April 16, 2013 at 1:40 pm

    Have you tried connecting any other device to this ad-hoc network? If a PC or Mac can connect we know the issue is Android-specific, or at least specific to your device. I'm thinking the problem is handing out IP addresses, though...

  5. Jan Fritsch
    April 16, 2013 at 11:01 am

    I could be wrong but I believe it is a problem with the way Apple does encryption (simultaneous WPA/WPA2) and how Android handles encryption.

    I have seen various Android devices failing to connect to AirPort Express, BaseStations or OS X Ad-hoc/Hotspots.

  6. Athul Jayaram
    April 16, 2013 at 4:53 am

    I guess your MAC is highly secured and hence obtaining IP looks hard. Did your android mobile asked for your 5 long password to connect to your wifi?

    Please give a try on http://www.connectify.me software to give wifi for your mobile and let me know if it works. This can solve your problem

  7. ha14
    April 15, 2013 at 11:16 pm

    perhaps because security set it to open to try if connection is enabled.

    • shaurya
      April 16, 2013 at 4:21 am

      well perhaps if u cud help me how will i be able to do that

    • ha14
      April 16, 2013 at 8:59 pm

      try to deactivate Enable Encryption

Ads by Google