Why can’t I use the web browser in the Android SDK?

Yashraj Talan February 5, 2013


I am unable to use any app which requires data access, not even the web browser on Android SDK (the latest version as of January 2013). I have Android Jelly Bean 4.1, 2.1 and 2.3.3 installed and have tried searching Google and Q&A forums. Please help. I use Windows XP 32-bit SP2 and my internet connection is a wired landline (telephone-very common in India) cable broadband (sadly, just 1Mbps).


  1. Yashraj Talan
    February 11, 2013 at 10:33 am

    Thanks ha14! It took time to figure out but the webpage http://bencoding.com/2012/01/15/using-ddms-to-set-your-android-emulators-location/ pointed to the right solution! Thanks everyone!

    • ha14
      February 12, 2013 at 11:31 am

      thanks for your feedback and glad that the solution worked for you:)

  2. Gaurav Joshi
    February 6, 2013 at 4:31 pm

    if you want to use android as virtual machine use it on virtualbox download ova file from http://androvm.org/blog/download/ and simply import it into virtualbox

  3. Gaurav Joshi
    February 6, 2013 at 4:28 pm

    you must provide internet access via writing " " in android manifest file of your android app source

  4. ha14
    February 6, 2013 at 2:20 pm

    if you are on wireless, Disable your LAN card. go to your Network connections, find your LAN card, right click it and choose disable

    perhaps it is your antivirus/firewall give full access to emulator.exe.

    What is DDMS and how it works?

    Using DDMS To Set Your Android Emulator’s Location

    go to DDMS select Emulator Control ,which contains Telephony Status in telephony status contain data -->select Home , this will enable your internet connection ,if you want disable internet connection for Emulator then select None

Ads by Google