Why can’t I install WiFi drivers on Acer Aspire 5733Z running Windows 7 64 bit?

Cristián T December 12, 2013

So I just factory reset my Acer Aspire 5733Z running Windows 7 Home Premium 64 bit and I seemed to have successfully installed all drivers except for the Wireless LAN drivers that I found on the manufacturer’s website. When I start the setup it starts to install, but 30 seconds in, it says that the “Device may not be present or could have been ejected/unplugged from the system” and that I should “Insert or Reinsert Now”. Because of this error I cannot install the drivers and thus connect to the Internet via Wi-Fi. Please help.

  1. Jan F
    December 12, 2013 at 10:05 pm

    My first guess would be that your laptop comes with a physical switch (e.g. a slider) or a logical switch (e.g. a Fn + XX key combination) to turn the WiFi adapter on and off ~ and it is currently in the off state.

    From the Acer website it appears that the Aspire 5733Z has several hardware configurations with different wireless chipsets (Atheros, Broadcom, Intel, Realtek). Therefor when head over to the Acer support site to download drivers make sure that you not only select the correct operating system (Win 7 64-bit) but also the correct driver for your chipset.

    • Cristián T
      December 12, 2013 at 11:35 pm

      It says that it finished installing, and then asked to reboot. After that, I was still unable to turn on the Internet.

  2. Hovsep A
    December 12, 2013 at 9:58 pm

    try to run it as administrator

    • Cristián T
      December 12, 2013 at 11:20 pm

      I tried running the driver setup application as an Administrator but I still got the same error message.

    • Hovsep A
      December 13, 2013 at 7:22 am

      try to update BIOS, reset cmos battery, also check if wifi is not disables in BIOS