Why can’t I accept Google Play Terms and Conditions on my LG Optimus V?

Mike Haubrich December 24, 2012

I have LG Optimus V with Android 2.2.2 with Kernel Version It is a used phone. I am trying to access Google Play, but I can’t find the Accept link in Terms and Conditions. How do I get past this step?

  1. ha14
    December 24, 2012 at 9:14 am

    1.Visit Menu > Settings > Applications > Manage applications
    2.Tab over to "All"
    3.Select the Google Play Store app, and then tap "Clear data" and "Clear cache;" then, select Download manager and tap "Clear data" and "Clear cache"

    • Mike Haubrich
      December 24, 2012 at 12:22 pm

      There was no Google Play Store App in the applications listing. However, I did clear the browser cache and data and the "Downloads" cache and data.

      When I choose the Downloads icon on my home screen, it opens the browser and brings me to the "upgrade" link, and then it loads the Terms and Conditions screen and I am back where I started.

      • ha14
        December 25, 2012 at 3:34 pm

        nice that was fixed for you, thanks for the reply :)

  2. Junil Maharjan
    December 24, 2012 at 5:47 am

    have you tried scrolling down? or clicking next?

    • Mike Haubrich
      December 24, 2012 at 12:19 pm

      Yes, I did. I went to the bottom of the page and there is no "Accept" nor "Decline" button.

      • Jono schnell
        December 24, 2012 at 11:35 pm

        The same thing is happening for me too however I fixed it !!

        try clearing data/cache on the new market : Settings > Applications > Manage Applications > All tab > Play Store (or some name to do with the market) > Clear data.

        Then try the market app again and the accept/decline message will show !
        It will again direct you to the terms site although go back to the market app and hit again, it should go to the proper market then !

        • Mike Haubrich
          December 25, 2012 at 12:11 pm

          Got it! Thanks!

Ads by Google