Why can I not turn on the wireless device in Windows 8?

Danny Roy Jenuil II February 9, 2013
Ads by Google

I just did a fresh install of Windows 8 Pro on my Lenovo IdeaPad Z470 a few days ago. After using it for a while, today, I noticed that I couldn’t get connected to the Internet via my home wireless network. Clicking on the network icon from the system tray does not show any available wireless networks and from the network menu, it says “WiFi (Off)”.

At first, I thought maybe it was my router which is having problems, but my iPad and my phone are successfully connected to my home wireless network and the Internet also works fine using those devices. I tried to turn on my wireless device via Windows 8 PC settings, but it seems that the on/off slider of my wireless device is being disabled as I couldn’t click on it to turn it on. The Flight Mode is also turned off and I had already installed all the latest Windows 8 updates prior to this problem.

It would be appreciated if anyone could help me with this complicated problem as soon as possible. Thanks in advance.

  1. balusme
    July 1, 2013 at 3:43 pm

    mine is z570 and wireless is indicating me as
    wifi(off )
    i installed all wireless drivers of windows8 64bit
    when i am sliding my wireless button only blue-tooth is switching on
    wifi is not at all working give me solution

  2. Oron Joffe
    February 10, 2013 at 5:15 pm

    OK, "WiFi Off" means your WiFi card on the laptop (not at the router) is currently not working. There are two basic possibilities:
    1. It is actually switched off, and can be switched on via a physical switch (on the front, just right of centre) or a keyboard combination or
    2. The driver is faulty or not installed.
    Since you have already confirmed that you have checked option (1), what remains is a driver issue. If you have downloaded and installed a new driver from Lenovo, and still have no joy, then you need to explore this avenue further. I've had issues with WiFi in the past (including a couple with Lenovo, strangely enough) which turned out to require system patches and/or BIOS updates! The solution is simply to call Lenovo tech. support. They have always been helpful and have never charged me for this sort of advice.

  3. Yiz Borol
    February 10, 2013 at 5:06 pm

    You have of course tried restarting the computer,right?

  4. Danny Roy Jenuil II
    February 10, 2013 at 10:34 am

    Well I tried that, but the Wireless device cannot be set to On as it is greyed out. Clicking on it doesn't do anything/

  5. Danny Roy Jenuil II
    February 10, 2013 at 10:32 am

    Doesn't work. I tried using keyboard and physical switch but to no avail too.

  6. Danny Roy Jenuil II
    February 10, 2013 at 3:32 am

    Hey guys, I took a screenshot of the problem that I am facing. Hope this will help to find the right solution.

    Screenshot 1:


    Screenshot 2:


  7. Jim Chambers
    February 10, 2013 at 2:50 am

    Does your laptop have a physical switch to turn on/off the WiFi transmitter? If so you may have inadvertently switched it off.

    • Danny Roy Jenuil II
      February 10, 2013 at 3:12 am

      Yes, I had tried using the physical switch, but, the switch has been useless ever since I installed Windows 8. Sliding it to left or right doesn't do anything at all.

  8. ha14
    February 9, 2013 at 8:20 pm

    install a new driver from Lenovo website, check firewall...

    if the slider is the problem perhaps to check Lenovo IdeaPad Z470 disassembly

Ads by Google