Why can I not log into MakeUseOf?

Kenneth March 12, 2013

No matter what I do the site will not log me in. I have used everything – Yahoo, Facebook, Google, MSN, the only one I have not tried is Twitter, I don’t use Twitter that often.

I’ve tried re-registering. Nothing seems to work. I know I have an account; I’ve seen my points. I don’t know what to do about this!!

Waiting for help,
Kenneth M.

  1. muotechguy
    March 13, 2013 at 8:18 am

    Hi Kenneth. Looks like you're registered with Facebook and Yahoo on the account. First, please try clearing your cookies and cache. If that doesn't help, send me a full browser screenshot to jamesbruce@ this domain so I can identify any plugins that might be interfering with the login process.

  2. Imesh
    March 13, 2013 at 6:08 am

    Are you on a proxy? I recently had an issue with a proxy where, I cannot log into any website, even with valid security certificates! if you are in a proxy, try contacting your administrator.

  3. Tina Sieber
    March 12, 2013 at 4:52 pm

    Since you were able to post this question, you were logged in, at least semi-successfully. However, there appears to be an issue with your account. I had to manually add your user name to the question you submitted.

    I will forward your question to James and maybe he can figure out what is wrong.

    Meanwhile, try to clear cache and cookies on your browser and see whether this has an effect. Also, do log in using the social login on the website (top right).