Why can I not download anything using µTorrent?

george guichard April 4, 2013

When I attempt to download any material using µTorrent nothing happens. The material is listed, but there is no inflow. There seems to be a block of some sort. I have AVG installed.

  1. Md Mukhtar Mohsin
    May 12, 2013 at 2:52 am

    There are just lot of torrents who don't have any seeders so simply you can't leech them. Nay be that's your problem.

  2. Naveen Mv
    April 9, 2013 at 1:43 pm

    First check your Firewall and whitelist utorrent or simply skip to another torrent downloader like bit torrent :)

  3. Theodore Grammenos
    April 8, 2013 at 1:55 pm

    There are many reasons:
    a) Your firewall port is not open
    b)There are no seeders
    and c)Your ISP is blocking P2P

    for the last try Cyberghost VPN

  4. Joseph Stephen
    April 6, 2013 at 4:19 am

    You need a torrent to download it from µTorrent. Make sure the torrent has enough seeds for it to start because it requires a P2P connection.

  5. yudics
    April 6, 2013 at 2:34 am

    check whether the avg firewall is blocking mtorrent, please uncheck if blocked, how to uncheck?: open avg user interface, click the firewall options, click change tab in firewall mode options, you will see, the general menu, applications, printers and share on the left, click on the application, find if mtorent is blocked, then click edit, change to allow, finish. but if mtorent not blocked by avg firewall, you can do some tricks. choose the highest seeder, if you download the torrent file there must be found seeds and leechers, seeds are of people who have downloaded the file 100% and leechers are the people who download the file but not done over 100 percent. the highest seeder means that the file will be very easy to download, so choose the file that have the highest seeder. thanks

  6. salim benhouhou
    April 5, 2013 at 1:33 pm

    check if your firewall blocking utorrent .and does the torrent you are trying to download have seeders ?

  7. Alan Wade
    April 5, 2013 at 11:55 am

    Here is another link which has a FAQ with your sort of problem:

  8. Alan Wade
    April 5, 2013 at 11:49 am

    uTorrent has a forum for problems here: http://forum.utorrent.com/viewforum.php?id=11
    But the biggest causes of this is a) no seeders and b) your firewall is not letting the traffic through.

  9. Harsh Sharma
    April 5, 2013 at 3:11 am

    Check whether it is allowed through your firewall.

  10. Lisa Santika Onggrid
    April 5, 2013 at 2:56 am

    There are several possible reasons, some of them already listed above. One common problem is perhaps no one seed the file anymore,

  11. Bruce Epper
    April 5, 2013 at 1:24 am

    Has it worked for you in the past? Has your system configuration changed since the last time it worked? Is your ISP blocking P2P? Do you have the appropriate ports opened on your firewall?

  12. ha14
    April 4, 2013 at 10:15 pm

    have you tried to whitelist/make exception on avg firewall?

    Freezing Issues With Torrent Downloads

Ads by Google