Why can I not connect to my mobile Android hotspot with my Nexus 7?

Tim Lenahan March 21, 2013

I just recently added wireless tethering to my mobile plan and now I’m having trouble connecting my Nexus 7 to my mobile hotspot. It connects to other WiFi networks just fine, but stalls at “obtaining IP address” with my Android phone’s hotspot. I’ve tried foxfi and the stock app but to no avail.

  1. Tim Lenahan
    April 3, 2013 at 1:34 am

    I at least got the hotspot working with WEP encryption without messing with contact my service provider. Thanks for all the help!

  2. Mudassar
    March 28, 2013 at 5:17 am

    make sure you have checked "Allow all devices to connect" feature in you mobile phone portable Wi-Fi hotspot settings.

  3. susendeep dutta
    March 22, 2013 at 11:48 am

    Try deleting the settings of phone stored in Nexus 7 and try to reconnect as a fresh from Nexus 7 .

    • Tim Lenahan
      March 23, 2013 at 10:21 am

      I've tried "forgetting" the network and then retrying, but still the same problem.

  4. ha14
    March 21, 2013 at 10:49 pm

    phone hotspot security to WEP?

    • Tim Lenahan
      March 23, 2013 at 10:19 am

      I've tried changing the settings to both wpa 1 and 2 and have also tried wep. I've been hesitant to set it to be unprotected but maybe it's an option.

    • ha14
      March 23, 2013 at 11:42 am

      have you tried to update to android 4.2.2?

      have you contacted your mobile provider to get the right APN settings?

      it might be because of third party ad-hoc tethering apps do to iptables rules.

      maybe you need to factory reset Nexus and try again?

    • Tim Lenahan
      March 23, 2013 at 1:39 pm

      I'm looking at my One X (the phone that is broadcasting the hotspot) and the apn setting are greyed over. Should I mess with an apn manager?

    • Tim Lenahan
      March 23, 2013 at 1:44 pm

      Oh, and the Nexus 7 is running 4.2.2

    • Tim Lenahan
      March 23, 2013 at 1:54 pm

      Update: The tablet does connect when there is no security. When on the move, I suppose this isn't that big of a deal. Maybe there's something up with my security settings? Or could the apn settings still be at fault?

    • ha14
      March 23, 2013 at 2:10 pm

      apn settings can be loaded from the sim card.

      well if apn settings are grayed out perhaps your mobile provider forbid tethering, if it is the case with your phone then contact your mobile provider because your new mobile data provides tether option.

      to create a new APN
      Settings - Wireless & networks.- Access Point Names


    • timmyjohnboy
      March 24, 2013 at 3:20 am

      I just had tethering added to my data plan, so maybe contacting the provider (ugg) will be my best bet.

    • ha14
      March 24, 2013 at 9:07 am

      perhaps it is security problem like supports unsecured or WPA2 security
      best to contact the provider perhaps they can send you new APN settings.

Ads by Google