Why can I no longer access my Western Digital Passport?

me November 7, 2012
Ads by Google

I used my passport Saturday night to make a DVD of pictures. I shut everything down and when I tried to use it later my computer (an HP laptop) didn’t recognize it, saying that I would have to reformat it before use. The next time I tried, it said that the “H” drive couldn’t be found.

I brought it in to work and it is not recognized on this computer (Dell). I have another computer at home (Acer laptop) that I tried to use it on and that didn’t work either.

I searched for the passport and it showed a shortcut, I clicked on it and a box came up saying Windows can’t open it to use another program. I closed that box and it gave me the option to use iTunes. So I clicked on it and most of my icons on the desktop and the ones on the bottom turned into iTunes. I tried to restore to a previous time and it ran for over an hour and no results.

  1. Jim Chambers
    November 8, 2012 at 3:57 am

    Definitely try removing the HDD from the enclosure and test it by temporarily installing it inside a friends desktop computer. To connect it you may have to use the SATA cables of the DVD drive. Failing this, buy an enclosure to test it and if drive still doesn't work, return the case. Kind of cheesie but if you buy a replacement external drive from them it makes it a little better.

  2. Wouter Ruelens
    November 7, 2012 at 9:27 pm

    I had the same problem with a WD passport a while ago, it probably is the S-ATA to USB converter. You could take the enclosure of and connect it to an internal S-ATA connector (of another HDD) to copy it. The drive is still usable but without a new enclosure it is to fragile, so you can either buy a new enclosure or throw it away.

  3. ha14
    November 7, 2012 at 12:56 pm

    Data Lifeguard Diagnostic for Windows
    The Data Lifeguard Diagnostic Tools are used primarily for determining the physical condition of your hard drive. If you are having computer problems which you suspect are hard drive related, you can test your drive with this tool. This diagnostic utility is designed for hard drives larger than 8.4 GB with the model number starting with WDxxx.

  4. Anonymous
    November 7, 2012 at 11:58 am

    Either the USB-to-SATA converter board in the Passport has failed, you have a bad USB cable, or the drive inside the Passport itself has failed. Swap out the cable first to check that. If that doesn't resolve the problem, you will need to open up the external drive casing to remove the hard drive and put it into another enclosure or use a SATA/IDE to USB adapter. (Vantec makes a good one that I use. I picked it up from Amazon for about $15). In most cases, I have found that the converter is what fails and the drive itself is still good.