Why are my downloaded apps from Google Play not updating via 3G?

Rajaa Chowdhury November 19, 2012
Whatsapp Pinterest

I never had a WiFi and always been using my 3G data plan with my Samsung Android smartphone. Since the last 3 weeks, it is not updating the downloaded apps from Google Play. Every time it tries and then gives an error though my 3G is working fine and it can successfully download and install a new app. The Content Filtering in Google Play is set to allow all. Kindly suggest as I am totally at a loss.

  1. Rajaa Chowdhury
    November 29, 2012 at 2:58 am


    I dunno what I did, but the problem seem to have resolved itself since the last couple of days. :) I am stumped!!!

  2. Rajaa Chowdhury
    November 22, 2012 at 2:27 am

    Not resolved and no further answer forthcoming, so closing the question.

  3. Vampie C.
    November 21, 2012 at 1:47 pm

    Are you in the possibility to try to connect to a WIFI and test if you can get updates that way?

    • Rajaa Chowdhury
      November 22, 2012 at 2:26 am

      No, I do not have any WiFi access.

  4. ha14
    November 20, 2012 at 9:47 pm

    reset your phone and see if will help.

    • Rajaa Chowdhury
      November 26, 2012 at 3:49 am

      Factory reset is the resort, however do not want to do that as it is a bit like re-inventing the wheel as again I have to personalize my device. Bit of a pain. :)

  5. Kannon Y
    November 20, 2012 at 4:54 am

    Hey Rajaa, you already know about the setting in Android that allows users to update using WiFi only, so it's likely a cache issue, which is unfortunately a very common problem.

    There are two common sources for these kinds of issues - Google Framework services and the Play/Market app. On some phones there's both a Market and Play app, so you have to be careful.

    Anyway, try going into Settings -> Applications -> Manage Applications -> choose all from the tab in this menu.

    From the All menu choose Google Play Store and wipe its cache. That's the primary source of cache issues, but you can also check anything you see in this menu pertaining to Play/Market and Framework services. You can wipe data on some of these, but I don't think that would solve the issue and would introduce additional difficulties.

    There's also a few apps that let you wipe all caches - these greatly simplify cache management. Good luck!

    • Rajaa Chowdhury
      November 21, 2012 at 2:14 am

      Kannon Y,

      Followed your instruction, but issue was not resolved. :(

      • Kannon Y
        November 22, 2012 at 6:10 pm

        Sorry for the late response! I'm a bit stumped over this Rajaa - cache wiping has always worked for me. I'm certain you've already tried the fundamental "system restart" so my advice will focus only on more advanced methods:

        I can think of four alternative methods: (1) remote installation; (2) wiping the Google Talk cache (and perhaps even Google Talk data); (3) pushing out a cache wiper app over USB; (4) factory reset.

        (1) Have you tried remotely installing apps using a desktop? Give it a shot. It shouldn't work, but in the past I have had problems installing directly through my device.

        (2) Another cache to wipe would be Google Talk. Android uses Google Talk for authentication purposes; if something went wrong in GT, it would impact the services that were dependent on it.

        I would add that you may wish to also wipe data in GT, Market/Play and Framework services, since the only other potential fix is a factory reset, which will remove all your account data.

        (3) Here's a direct link to an APK that will wipe your cache. It doesn't require root, but to get the system cache, it requires root. I suspect that it is the system cache that may be causing your issue.

        Try pushing it out to your device via USB.

        (4) A factory reset is a ridiculous method, but if the previous three fixes failed, this is perhaps the only method that I'm 90% sure will work, but it's such a time consuming method that it's best only used as a last resort.

        I am a little disappointed with Android's design. While it's true that all internet-enabled devices suffer from cache problems, one might hope for a better solution than a factory reset. :-( Hope something in here works for you! Good luck!

        • Rajaa Chowdhury
          November 23, 2012 at 2:09 am

          (1) Have you tried remotely installing apps using a desktop? Give it a shot. It shouldn’t work, but in the past I have had problems installing directly through my device. - This method works, however it is a bit of a pain sometimes as the apps update list always doesn't match in my Google Play on phone and desktop, so I need to refresh multiple times to get the same list. However, before posting the question, this is the alternative method now that I have been following to keep my apps updated on a daily basis. :)

        • Kannon Y
          November 24, 2012 at 2:58 am

          Great minds think alike. :-)

          I believe the app list updates overnight (or takes a few hours). Unfortunately, that's not good enough.

          If the phone can download remotely but not natively, then it's likely a cache issue in the Play Store/Market. Unfortunately, Play Store isn't one of those apps that you can just uninstall and reinstall (I believe it's a system app).

          Perhaps desyncing as many features as you can from the device? A person in this thread desync'd his email and then the play store just magically started working again.

          The reason that might work? I have no clue, but whatever works, works. Hope that helps!

Ads by Google