Why are my bookmarks gone after installing Firefox 11 on Ubuntu?

iStoopKid May 18, 2012

I’m on Ubuntu 10.10, and I installed firefox 11. All my bookmarks are gone. The files are still there from backups at the beginning of the year but if I try to restore them, I get an error. No bookmarks show, and I can’t import or add new bookmarks. My history won’t even show. I literally had like a thousand bookmarks. How do I fix this?

  1. Matthew Graczyk
    May 20, 2012 at 10:18 pm

    Consider switching to a cloud-based bookmarking platform where there's no need to backup, sync or import your bookmarks because they are automatically backed up and inherently synched, and all your bookmarks are always available using any browser from any computer, mobile phone or tablet. My company operates http://iCrumz.com, a free cloud-based Internet bookmarking service. The iCrumz interface allows you to have 100 or more bookmarks on a single webpage without being cluttered. iCrumz also offers an import function, so you can import and consolidate all your bookmarks from all your browsers on all your devices. Check out our short (1 minute) intro video: http://youtu.be/QDD23whIlrw Contact me if you have any questions. Matthew[at]iCrumz[dot]com.

  2. Bruce Epper
    May 19, 2012 at 12:59 am

    What is the error you are getting when you try to restore your bookmarks? Exact text please.

    Also, did you get the following error message when starting Firefox?
    "The bookmarks and history system will not be functional because one of Firefox's files is in use by another application. Some security software can cause this problem"

    If you got that message, restart your computer and try again. (Issue is commonly due to your configuration files being opened by another process and inaccessable by Firefox.)

    • iStoopKid
      May 19, 2012 at 1:12 am

      When I restore backups, it tells me "unable to process the backup file". I didn't get that message you posted about the history. I actually get no error messages when firefox starts.

      • Bruce Epper
        May 19, 2012 at 4:13 am

        Okay, close any visible Firefox windows, open up a command terminal (CTL+ALT+T) and type 'killall firefox' to make sure all Firefox processes are stopped. Reopen Firefox and look for bookmarks and history first. If they are not there, try to restore a backup. If you continue to get the same error message, try the suggestions found here: http://kb.mozillazine.org/Unable_to_process_the_backup_file_-_Firefox They are for an older version, but the process should remain the same.

        • iStoopKid
          May 19, 2012 at 5:56 am

          That link didn't have the exact answer that I needed but it did steer me in the right direction. If anyone has the same problem here is what i did:

          I updated to FF 12 and that didn't fix it so I scrolled to my .mozilla folder in my home directory and there was a profiles.ini file. I deleted it and reopened firefox. It asked me if I wanted to import chrome bookmarks, i hit cancel. I went to the history and it now worked. I went to my bookmarks and then restored a backup from april that was located in my previous firefox profile folder. Afterwards I copied the password files over from the old profile folder into the new one, restarted firefox, then bam it's all good. I wish I knew this months ago, but most of my searches ended up dry.