Why am I getting a “No Sim Card” error on my LG C800?

Chimaroke Amaike January 8, 2013
Ads by Google

I have an LG C800. I have been using it for a while now. Few weeks back, a SIM card with an error icon on it appeared at the top of the screen. Since then, I can’t make/receive calls. I can’t send and receive text messages and I can’t connect to the internet with my phone.

When I try to make a call, I get the “Not Registered on Network” message. When the phone is locked (pressing the power button gently), “No Sim Card” is displayed on the screen.

It’s a T-mobile branded phone, but its unlocked. If I insert SIM card from other providers, I would be able to tell which provider it is from the phone.

I have thought about rooting the phone, but I don’t know if it would solve the problem.

Can anyone help me with this problem?


  1. Bayo
    April 25, 2013 at 8:07 am

    i am also experiencing the same problem here. tried hard resetting didn't fix it. also updating firmware was not succesful as i have the most recent one.Tried repairing using LG tool but also that was unsuccesful .

  2. Ahmed Musani
    January 9, 2013 at 6:29 pm

    reset your phone to factory settings or try updating your firmware. that should fix the problem.

  3. susendeep dutta
    January 9, 2013 at 4:14 pm

    Since,it was released on November 2011 and assuming your phone to be less than 1 year old,then you might try to get free warranty service.Ask T-Mobile to give your service and then they might replace your phone or do something else to help you out.

  4. Junil Maharjan
    January 9, 2013 at 4:38 am

    May be the SIM is broken. Contact your SIM provider for a replacement or for more help.

    • Chimaroke Amaike
      January 9, 2013 at 8:29 am

      Thanks for the tip but i tried the same sim on other phones and they worked just fine.

  5. maria
    January 9, 2013 at 1:57 am

    try to reboot it.

  6. ha14
    January 9, 2013 at 1:00 am

    see if you can update firmware, or soft reset the phone or hard reset (first do a backup).

    • Chimaroke Amaike
      January 9, 2013 at 8:27 am

      Thanks ha14. I will try updating the firmware. i have tried hard and soft reset several times but no luck.

      • ha14
        January 10, 2013 at 7:13 pm

        also perhaps the sim card reader is faulty, or do not accept this specific one.

Ads by Google