What is wrong with my Le Pan II tablet?

Brenda Herring May 29, 2013
Ads by Google

I purchased my 9.7″ Le Pan Capacitive touch tablet with Android 4.0 at Christmas online from Walmart.

I barely got to use it for 2 weeks when it first of all, would not power up one day… I routinely power down and charged it at night when not in use, but after doing so I could not get it to power on for anything. I went online and found in a forum, others who had had the same issue – and the “fix” basically said to unplug and then plug unit back in for 20 mins and then hold power button down, etc… it gave a couple variations of that. After 3 days of trying different things – It finally came on (much to my surprise)!!

This became an ongoing issue, with the same problem occurring MANY times and usually it took a few tries to get powered up but was at least usable. According to some info I had read online, it was recommended to not allow the battery to get drained below 20%, so I began to leave unit on (since such a problem getting it to turn on) and plugged in.

Then a few days after, while plugged in, the unit started powering up and then off and was rebooting over and over again… It would not complete any function even if it did get past the boot up screen. After looking online again, There were a few suggestions, like trying to power up by pressing the volume and power buttons simultaneously, etc – Nothing worked. Finally, I tried to “reset” the unit. Now it will not power up at all….

HELP!! The thing is, Walmart only accepts returns within 15 days (on electronics) come to find out, so I am stuck with this or have to deal with the manufacturer… I am out $200 and desperately need another tablet for my work ASAP – I am a merchandiser. Does anyone know something I can try to get this to work somehow or maybe recommend a way to recoup my money… It appears that this is “an issue” (well, there are 2 separate issues I guess) with THIS particular unit… And so I would think the maker of the product SHOULD be responsible — There was NOTHING done to it on my end anyway… Hope you can help!

Thanks! ~ Bren

  1. ha14
    May 29, 2013 at 1:57 pm

    you can get the LIMITED WARRANTY if you have proof of purchase. They may charge you to repair your unit if it is not defective but has technical problem.

    try to reinstall the firmware or hard reset the unit contact them on how to proceed.