What is a TCP/IP stack and why would I need to reset it?

Donald S December 3, 2013

What exactly is a TCP/IP “stack” and why would you have to reset it?

More specifically, under what circumstances would you have to reset the stack?

I was getting an error while connecting to a network that stated “unauthenticated network” and therefore could not access the Internet. After Googling it I found a few sites that said to “reset the TCP/IP stack”. How would this rectify my problem? Thanks in advance.

  1. Donald S
    December 4, 2013 at 5:53 pm

    I work in the IT department for a college so yes I am on a domain. But I have had problems connecting to our private network because I get an "unauthenticated network". It seems as though it's reaching the router but cannot find the domain and therefore cannot get out. What would cause this and how would you be able to fix. I also have seen this on personal computers too and do not know how to rectify this issue.

    • Jan F
      December 4, 2013 at 9:39 pm

      Group Policies, Domain setup, DNS issue, credentials cache... As I said before, I would look into the Event Viewer if there is any detailed error for the cause of this problem.

      Well, yes. When you are home your computer cannot reach the DC. That requires either a site-to-site VPN or a software based client-to-network VPN with the latter causing issues every now and then as the user usually logs on before the VPN is established.

      First I would go the easy road > troubleshoot it like a simple network problem.
      Make sure DNS servers are received via DHCP and not some static entries from the domain network. Make sure these DNS servers are valid and working (check with another computer/device).

      Other then that it could be a problem if the computer wasn't in contact with the DC for some time.
      If you are using a roaming profile make sure offline files are enabled. If you are using a mandatory profile you NEED a connection to the DC.
      Disable any client-side firewall (Windows and/or third-party) for testing.
      If you are using a wired connection try disabling WiFi.

      Some issues are solved by simply removing the system from the domain and rejoining it ~ which is the next thing I would try, it's simple and often saves you some headaches.

  2. Hovsep A
    December 4, 2013 at 9:43 am

    what you were doing before getting this problem?

  3. Jan F
    December 3, 2013 at 11:51 pm

    "resetting the TCP stack" usually means resetting all IP protocol settings (IP, Subnetmask, DNS server entries, etc.) within Windows and can solve certain configuration errors.

    The error you are getting might be solved by this reset but it feels more like a work-around for the actual issue.

    For example a burst of data packets being sent before the network was successfully joined could trigger this error, a binding problem to a domain controller (if your system is part of a domain) could trigger this, firewall blocking a new "unknown" network, certain network services not working properly.

    Have you checked within the Event Viewer if there are any more details?